[Driver] Touchpad synaptics

Riconoscimento, installazione e configurazione delle periferiche.
Scrivi risposta
Avatar utente
AkiraSama
Prode Principiante
Messaggi: 15
Iscrizione: giovedì 28 dicembre 2006, 0:40

[Driver] Touchpad synaptics

Messaggio da AkiraSama » mercoledì 31 gennaio 2007, 0:17

Sto scelrando dietro a questo problema da una settimana e nn ci capisco fuori un tubo...

Ho il classico Synaptics Touchpad sul mio notebook e vorrei semplicemente rimuovere l'opzione di risposta al click dal touchpad,ovvero lasciarlo esclusivamente come puntatore del mouse ing rado di spostare ilmuose e basta...oppure anke se un po drastico poterlo disattivare o attivare a piacere...
qualcuno sa dirmi se è possibile fare una cosa del genere??
Grazie in anticipo...

kajapezz8
Prode Principiante
Messaggi: 102
Iscrizione: domenica 4 giugno 2006, 18:20
Contatti:

Re: [Driver] Touchpad synaptics

Messaggio da kajapezz8 » mercoledì 31 gennaio 2007, 10:34

prova a installare ksynaptic o qsynaptic sono delle utility per il controllo del touch.

Ciao
Opengeek news e guide sul mondo Gnu/Linux, Android http://www.opengeek.it/

Avatar utente
AkiraSama
Prode Principiante
Messaggi: 15
Iscrizione: giovedì 28 dicembre 2006, 0:40

Re: [Driver] Touchpad synaptics

Messaggio da AkiraSama » mercoledì 31 gennaio 2007, 22:19

mi era stato consigliato ma mi da questo problema quando lo lancio sia normalemente che in sudo...

Can't access shared memory area. SHMConfig disabled?

che cosa vuol dire?

Avatar utente
jonny84
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 558
Iscrizione: sabato 7 ottobre 2006, 18:33

Re: [Driver] Touchpad synaptics

Messaggio da jonny84 » venerdì 2 febbraio 2007, 20:47

fai così,io ho risolto in questo modo:
da synaptic installa gsynaptics

Codice: Seleziona tutto

sudo apt-get install gsynaptics
poi apri lo xorg.conf

Codice: Seleziona tutto

sudo gedit /etc/X11/xorg.conf
nella sezione

Codice: Seleziona tutto

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection
aggiungi dopo il mouse

Codice: Seleziona tutto

    InputDevice    "Synaptics Touchpad"
e sotto questa sezione

Codice: Seleziona tutto

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection
dovresti avere questa,e modificala in questo modo,se non l'hai aggiungila

Codice: Seleziona tutto

Section "InputDevice"
    Identifier      "Synaptics Touchpad"
    Driver          "synaptics"
    Option          "SendCoreEvents"        "true"
    Option          "Device"                "/dev/psaux"
    Option          "Protocol"              "auto-dev"
    Option          "HorizScrollDelta"      "0"
    Option          "SHMConfig"             "on"
EndSection
salva e chiudi
L'installazione del gsynaptics ti dovrebbe aver aggiunto all'avvio la seguente stringa

Codice: Seleziona tutto

gsynaptics-init --sm-disable
se no aggiungile in Sistema-Preferenze-Sessione-Programmi d'Avvio
Riavvia il Serverx oppure il PC,a tua scelta

p.s.Le mie Sezioni potrebbero differire dalle tue

Avatar utente
*blasco*
Prode Principiante
Messaggi: 90
Iscrizione: giovedì 28 settembre 2006, 13:08
Località: Bolzano

Re: [Driver] Touchpad synaptics

Messaggio da *blasco* » lunedì 2 aprile 2007, 18:50

ciao..ho seguito la tua "guida", ho fatto tutto..solo ke riavviando il pc nn è cambiato nulla..continuo ad avere il click attivo..l'unica cosa ke nn ho controllato è verificare se mi ha aggiunto all'avvio la seguente stringa:

Codice: Seleziona tutto

gsynaptics-init --sm-disable
Dove devo guardare esattamente?
grazie

Avatar utente
Cobra78
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 991
Iscrizione: giovedì 18 agosto 2005, 11:08
Località: Ferrara
Contatti:

Re: [Driver] Touchpad synaptics

Messaggio da Cobra78 » martedì 3 aprile 2007, 11:12

Molto più semplice: basta che metti nella sezione del touchpad di xorg.conf

Codice: Seleziona tutto

Option    "MaxTapTime"   "0"
e il maledetto tocco/click (si, lo odio anche io) se ne va senza fare più ritorno

Per configurazioni un poco più avanzate allego le info che ho raccolto in giro :P
Allegati
Touchpad.odt
(23.98 KiB) Scaricato 323 volte
Dell Inspiron 1720 Ice White Windows 7 Professional/Archlinux x86_64 - 2.6.38.x - Gnome3
Msi Wind U100 Windows Xp/Ubuntu 11.04 - Gnome3

beppe_sondaggi
Prode Principiante
Messaggi: 23
Iscrizione: domenica 2 novembre 2008, 0:16

Re: [Driver] Touchpad synaptics

Messaggio da beppe_sondaggi » giovedì 6 novembre 2008, 19:13

Ciao. Ho cercato di seguire i suggerimenti fin qui dati, ma non mi capisco ancora  >:(
Questo è il mio xorg.config ed è tutto qui. Non assomiglia nemmeno a quelli postati anche nelle guide.
Il mio sembra la versione bignami!
HELP!

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Avatar utente
Chetto
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 992
Iscrizione: lunedì 5 dicembre 2005, 16:41
Località: Arco

Re: [Driver] Touchpad synaptics

Messaggio da Chetto » venerdì 4 dicembre 2009, 12:41

Stesso problema ho un xorg.conf poverissimo e il touchpad impazzisce regolarmente spedendo il puntatore da una parte all'altra dello schermo e facendo casini incredibili!
Quello che voglio dire è che, dal momento che voi avete la più completa possibilità di rivoltare la grande tartaruga e strapparla dal fondo dell'oceano, mi fa sorridere vedervi fermi sulla riva, mentre cercate di afferrarla con un'asta da pesca.

spkbri
Prode Principiante
Messaggi: 6
Iscrizione: giovedì 13 gennaio 2011, 18:10

Re: [Driver] Touchpad synaptics

Messaggio da spkbri » sabato 15 gennaio 2011, 3:24

epic gravedig da parte mia e non riesco a trovare niente su internet che mi aiuti...
ho anche io il file xorg.conf ridotto come quello dell'user sopra di me... che devo fare?

gz
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 535
Iscrizione: sabato 9 dicembre 2006, 19:24
Località: Montecatini Terme

Re: [Driver] Touchpad synaptics

Messaggio da gz » lunedì 17 gennaio 2011, 14:56

ciao
non so se questo può andare;
prova
http://forum.ubuntu-it.org/viewtopic.php?t=405806
Pancia piena non crede a digiuno
Attenzione! Scoppiettante Seguace niubbo.

chiccolina86
Prode Principiante
Messaggi: 101
Iscrizione: martedì 7 settembre 2010, 17:00
Desktop: ubuntu
Distribuzione: Ubuntu 12.04.3 LTS i686

Re: [Driver] Touchpad synaptics

Messaggio da chiccolina86 » venerdì 9 settembre 2011, 12:08

jonny84 ha scritto: fai così,io ho risolto in questo modo:
da synaptic installa gsynaptics

Codice: Seleziona tutto

sudo apt-get install gsynaptics
poi apri lo xorg.conf

Codice: Seleziona tutto

sudo gedit /etc/X11/xorg.conf
nella sezione

Codice: Seleziona tutto

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

aggiungi dopo il mouse

Codice: Seleziona tutto

    InputDevice    "Synaptics Touchpad"
e sotto questa sezione

Codice: Seleziona tutto

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection
dovresti avere questa,e modificala in questo modo,se non l'hai aggiungila

Codice: Seleziona tutto

Section "InputDevice"
    Identifier      "Synaptics Touchpad"
    Driver          "synaptics"
    Option          "SendCoreEvents"        "true"
    Option          "Device"                "/dev/psaux"
    Option          "Protocol"              "auto-dev"
    Option          "HorizScrollDelta"      "0"
    Option          "SHMConfig"             "on"
EndSection
salva e chiudi
L'installazione del gsynaptics ti dovrebbe aver aggiunto all'avvio la seguente stringa

Codice: Seleziona tutto

gsynaptics-init --sm-disable
se no aggiungile in Sistema-Preferenze-Sessione-Programmi d'Avvio
Riavvia il Serverx oppure il PC,a tua scelta

p.s.Le mie Sezioni potrebbero differire dalle tue
scusate se mi intrometto nella discussione ma anche il mio touchpad sta tirando le cuoia...
io se provo a eseguire il comando
sudo gedit /etc/X11/xorg.conf
mi esce un documento di testo vuoto ???, sia da terminale che da root...cosa posso fare?
Ultima modifica di chiccolina86 il venerdì 9 settembre 2011, 15:01, modificato 1 volta in totale.

chiccolina86
Prode Principiante
Messaggi: 101
Iscrizione: martedì 7 settembre 2010, 17:00
Desktop: ubuntu
Distribuzione: Ubuntu 12.04.3 LTS i686

Re: [Driver] Touchpad synaptics

Messaggio da chiccolina86 » venerdì 9 settembre 2011, 17:32

up

Scrivi risposta

Ritorna a “Driver e periferiche”

Chi c’è in linea

Visualizzano questa sezione: Google [Bot] e 15 ospiti