Aggiornando Ubuntu vengono corrotti i driver AmdGPU Pro

Riconoscimento, installazione e configurazione delle periferiche.
Avatar utente
cialu
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 338
Iscrizione: mercoledì 7 gennaio 2015, 14:54
Desktop: AwesomeWM - GNOME - i3wm
Distribuzione: Fedora - Ubuntu - Void x86_64
Contatti:

Aggiornando Ubuntu vengono corrotti i driver AmdGPU Pro

Messaggio da cialu » sabato 7 ottobre 2017, 8:34

Salve a tutti,
cerco risposta a un quesito. Ho necessità di utilizzare i driver proprietari AmdGPU Pro e purtroppo sia su Ubuntu 17.04 che 17.10 la cosa sembra impossibile con l'attuale versione. L'unica soluzione fattibile è quella di installare Ubuntu 16.04.

La mia domanda è quindi la seguente: una volta installato il sistema con Ubuntu 16.04 e i relativi driver, devo evitare accuratamente gli aggiornamenti(in particolare, quelli del kernel) per mantenere il sistema stabile?

Grazie anticipatamente.

Avatar utente
steff
Moderatore Globale
Moderatore Globale
Messaggi: 38970
Iscrizione: domenica 18 febbraio 2007, 19:48
Desktop: LXQt
Distribuzione: Arch 64bit | Debian 32bit
Sesso: Maschile
Località: Toscana
Contatti:

Re: Aggiornando Ubuntu vengono corrotti i driver AmdGPU Pro

Messaggio da steff » domenica 8 ottobre 2017, 9:32

Da quanto so in synaptic puoi bloccare la versione di un programma, pacchetto o anche la versione del kernel. In alternativa puoi modificare grub che parte sempre solo con quel kernel.
Da terminale:

Codice: Seleziona tutto

sudo -s
echo "nomepacchetto hold"|dpkg --set-selections
ripristinare

Codice: Seleziona tutto

echo "nomepacchetto install"|dpkg --set-selecions
Hai fatto un backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox

Avatar utente
cialu
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 338
Iscrizione: mercoledì 7 gennaio 2015, 14:54
Desktop: AwesomeWM - GNOME - i3wm
Distribuzione: Fedora - Ubuntu - Void x86_64
Contatti:

Re: Aggiornando Ubuntu vengono corrotti i driver AmdGPU Pro

Messaggio da cialu » martedì 10 ottobre 2017, 14:51

Interessante.
Il mio problema è che i driver AmdGPU Pro sono compatibili solo con Ubuntu 16.04, provai a installarli su 17.04 e 17.10, ma senza successo. La mia paura non è l'aggiornamento dei driver, che sono già l'ultima versione disponibile, ma di tutto il resto del sistema. Non so cosa possa accadere.

Avatar utente
Clover
Prode Principiante
Messaggi: 133
Iscrizione: giovedì 30 agosto 2012, 14:04
Desktop: KDE
Distribuzione: Kubuntu x86_64

Re: Aggiornando Ubuntu vengono corrotti i driver AmdGPU Pro

Messaggio da Clover » martedì 10 ottobre 2017, 15:43

Se non ricordo male i driver "amdgpu-pro" sono strettamente legati alla versione del kernel... la cosa strana è che sulla 17.04 dovrebbero funzionare...
driver 16.40 > kernel 4.8.x
driver 17.30 > kernel 4.10.x

Avatar utente
cialu
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 338
Iscrizione: mercoledì 7 gennaio 2015, 14:54
Desktop: AwesomeWM - GNOME - i3wm
Distribuzione: Fedora - Ubuntu - Void x86_64
Contatti:

Re: Aggiornando Ubuntu vengono corrotti i driver AmdGPU Pro

Messaggio da cialu » mercoledì 11 ottobre 2017, 11:15

Clover [url=https://forum.ubuntu-it.org/viewtopic.php?p=5013722#p5013722][img]https://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:Se non ricordo male i driver "amdgpu-pro" sono strettamente legati alla versione del kernel... la cosa strana è che sulla 17.04 dovrebbero funzionare...
driver 16.40 > kernel 4.8.x
driver 17.30 > kernel 4.10.x
Infatti, io sto utilizzando i driver 17.30 con il kernel 4.10.

Se aggiorno, i kernel più recenti non funzioneranno con i driver, ma il 4.10 dovrebbe rimanere funzionante. C'è modo di aggiornare mantenendo attivo il kernel 4.10?

Avatar utente
Clover
Prode Principiante
Messaggi: 133
Iscrizione: giovedì 30 agosto 2012, 14:04
Desktop: KDE
Distribuzione: Kubuntu x86_64

Re: Aggiornando Ubuntu vengono corrotti i driver AmdGPU Pro

Messaggio da Clover » mercoledì 11 ottobre 2017, 11:32

Se non si fanno operazioni particolari la versione base del kernel rimane la stessa e progredisce solo la sotto-versione (la x di 4.10.x per intenderci) quindi non dovrebbe essere un problema aggiornare (basta che non fai gli aggiornamenti di versione della distribuzione... 16.04 > 16.10 > 17.04...), cmq se vuoi bloccare la versione del kernel basta che usi i comandi che ti ha segnalato in precedenza steff

Avatar utente
cialu
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 338
Iscrizione: mercoledì 7 gennaio 2015, 14:54
Desktop: AwesomeWM - GNOME - i3wm
Distribuzione: Fedora - Ubuntu - Void x86_64
Contatti:

Re: Aggiornando Ubuntu vengono corrotti i driver AmdGPU Pro

Messaggio da cialu » mercoledì 11 ottobre 2017, 20:26

Clover [url=https://forum.ubuntu-it.org/viewtopic.php?p=5013879#p5013879][img]https://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:Se non si fanno operazioni particolari la versione base del kernel rimane la stessa e progredisce solo la sotto-versione (la x di 4.10.x per intenderci) quindi non dovrebbe essere un problema aggiornare (basta che non fai gli aggiornamenti di versione della distribuzione... 16.04 > 16.10 > 17.04...), cmq se vuoi bloccare la versione del kernel basta che usi i comandi che ti ha segnalato in precedenza steff
Io vorrei arrivare alla 17.10 mantenendo il kernel 4.10 compatibile con i driver AMD, temo però che con la 17.10 i problemi aumentino in maniera esponenziale visto il passaggio a Wayland. Probabilmente, opterò per rimanere sulla 16.04 in attesa di driver aggiornati.

Ho chiesto perché magari qualcuno aveva già affrontato la cosa... grazie comunque.

Scrivi risposta

Ritorna a “Driver e periferiche”

Chi c’è in linea

Visualizzano questa sezione: enrico_lx, frapox, GiorgioNoce, Google [Bot], Ilearn e 24 ospiti