[Risolto] Avvio lento (con pausa)

Configurazione e uso delle applicazioni del desktop manager alla base di Lubuntu.

[Risolto] Avvio lento (con pausa)

Messaggioda ANXANX » domenica 6 maggio 2018, 14:54

Avevo notato un avvio stranamente lento (oltre 35 secondi, dove il PC era palesemente fermo a non fare nulla per svariati secondi) con Lubuntu 18.04 e informandomi in giro ho notato che non sono l'unico, quindi dato che ho trovato chi ha risolto, ve la ripropongo.

Con il seguente comando ho confermato i tempi lunghi (oltre 35 secondi):
Codice: Seleziona tutto
systemd-analyze time


Con questo ho verificato la tabella d'avvio dei vari processi:
Codice: Seleziona tutto
dmesg

Dove si passava da 2-3 a 35-36 secondi con la riga "EXT4-fs (dm-0): mounted filesystem with ordered data mode. Opts: (null)"

Quindi ho modificato con privilegi amministratore il seguente file:
Codice: Seleziona tutto
/etc/initramfs-tools/conf.d/resume

Apponendo # sulla riga originale e inserendo la riga:
Codice: Seleziona tutto
RESUME=none


Infine ho fatto applicare le modifiche con il seguente comando:
Codice: Seleziona tutto
sudo update-initramfs -u

E riavviato la macchina

I tempi d'avvio si sono più che dimezzati
Per chi deve comprare un portatile, assicurarsi che sia possibile aggiornare anche il processore oltre alla ram, in quanto altrimenti si ha a che fare con prodotto molto orientati all'usa e getta, una buona soluzione è puntare sui dispositivi classificati come barebone.
Avatar utente
ANXANX
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 607
Iscrizione: settembre 2014
Desktop: Lubuntu
Distribuzione: Ubuntu 18.04.5 LTS x86_64

Re: [Risolto] Avvio lento (con pausa)

Messaggioda Piriponzolo » lunedì 17 settembre 2018, 21:44

Ciao, Anxanx. Ho lo stesso problema tuo con un ritardo di avvio di 81 sec. Seguendo la tua procedura dopo il comando dmesg io ho ottenuto:
"EXT4-fs (dm-0): re-mounted. 0pts: errors=remount-ro"
Dopo questo posso continuare con quanto da te già scritto oppure che devo fare?
Come si accede da terminale al file /etc/initramfs-tools/conf.d/resume ?
Grazie. :ciao:
Piriponzolo
Prode Principiante
 
Messaggi: 32
Iscrizione: maggio 2017

Re: [Risolto] Avvio lento (con pausa)

Messaggioda ANXANX » mercoledì 19 settembre 2018, 14:03

Hai una condizione diversa ma puoi comunque fare un tentativo.

per accedere con il terminale segui queste indicazioni
Per chi deve comprare un portatile, assicurarsi che sia possibile aggiornare anche il processore oltre alla ram, in quanto altrimenti si ha a che fare con prodotto molto orientati all'usa e getta, una buona soluzione è puntare sui dispositivi classificati come barebone.
Avatar utente
ANXANX
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 607
Iscrizione: settembre 2014
Desktop: Lubuntu
Distribuzione: Ubuntu 18.04.5 LTS x86_64

Re: [Risolto] Avvio lento (con pausa)

Messaggioda Piriponzolo » venerdì 21 settembre 2018, 20:21

ANXANX Immagine ha scritto:Hai una condizione diversa ma puoi comunque fare un tentativo.

per accedere con il terminale segui queste indicazioni



Ciao, Anxanx. Ho seguito alla lettera le tue indicazioni, ma Lubuntu 18.04 mantiene gli stessi tempi di avvio su quel vecchio notebook, pur avendo modificato quel file come da te suggerito con il comando da terminale. Pazienza! Grazie per la disponibilità nel rispondermi. :ciao:
Piriponzolo
Prode Principiante
 
Messaggi: 32
Iscrizione: maggio 2017


Torna a LXDE

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 2 ospiti