Crash pacchetto xserver-xorg-core

Configurazione e uso delle applicazioni del desktop manager alla base di Lubuntu.

Crash pacchetto xserver-xorg-core

Messaggioda alukard990 » sabato 12 maggio 2018, 10:27

Salve a tutti, è da un po' di tempo che all'avvio di ogni sessione mi compare la classica segnalazione di un errore interno al sistema. Prima di rivolgermi qui ho cercato un po' in rete ma non ho trovato granché a riguardo; ho provato anche a cancellare i file nascosti xsession-errors nella home sperando che qualche aggiornamento avesse risolto il problema ma ahimè senza risultato. Come da titolo l'errore sembra stare nel seguente package:
Codice: Seleziona tutto
xserver-xorg-core-hwe-16.04 2:1.19.5-0ubuntu2~16.04.1

Cosa posso fare per risolvere?
alukard990
Prode Principiante
 
Messaggi: 159
Iscrizione: febbraio 2014

Re: Crash pacchetto xserver-xorg-core

Messaggioda .:matteo:. » domenica 13 maggio 2018, 11:53

Il sistema è aggiornato?

Puoi provare ad avviare un kernel precedente da GRUB e vedere se per caso l'errore non compare più?
.:matteo:.
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1496
Iscrizione: gennaio 2012
Desktop: XFCE 4.12 / MATE 1.20
Distribuzione: Xubuntu 16.04 / Ubuntu MATE 18.04
Sesso: Maschile

Re: Crash pacchetto xserver-xorg-core

Messaggioda alukard990 » lunedì 14 maggio 2018, 8:49

.:matteo:. Immagine ha scritto:Il sistema è aggiornato?

Puoi provare ad avviare un kernel precedente da GRUB e vedere se per caso l'errore non compare più?


Il sistema è costantemente aggiornato; ho avviato un kernel precedente e l'errore sembra non esserci.
alukard990
Prode Principiante
 
Messaggi: 159
Iscrizione: febbraio 2014

Re: Crash pacchetto xserver-xorg-core

Messaggioda .:matteo:. » lunedì 14 maggio 2018, 18:48

alukard990 Immagine ha scritto:
.:matteo:. Immagine ha scritto:Il sistema è aggiornato?

Puoi provare ad avviare un kernel precedente da GRUB e vedere se per caso l'errore non compare più?


Il sistema è costantemente aggiornato; ho avviato un kernel precedente e l'errore sembra non esserci.

ok, allora rimuovi l'ultimo kernel installato e automaticamente il penultimo kernel verrà avviato di default da grub.
.:matteo:.
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1496
Iscrizione: gennaio 2012
Desktop: XFCE 4.12 / MATE 1.20
Distribuzione: Xubuntu 16.04 / Ubuntu MATE 18.04
Sesso: Maschile

Re: Crash pacchetto xserver-xorg-core

Messaggioda alukard990 » giovedì 17 maggio 2018, 8:35

.:matteo:. Immagine ha scritto:
alukard990 Immagine ha scritto:
.:matteo:. Immagine ha scritto:Il sistema è aggiornato?

Puoi provare ad avviare un kernel precedente da GRUB e vedere se per caso l'errore non compare più?


Il sistema è costantemente aggiornato; ho avviato un kernel precedente e l'errore sembra non esserci.

ok, allora rimuovi l'ultimo kernel installato e automaticamente il penultimo kernel verrà avviato di default da grub.


Ciao, scusa per non averti risposto subito ma vorrei informarti che il problema persiste anche con tutti i kernel precedenti. Avevo detto che il problema non ci fosse più ma avevo il dubbio che si potesse ripresentare e appunto ho esitato a chiudere eventualmente il post.
Attualmente sono installati questi 3 kernel:
Codice: Seleziona tutto
ii linux-image-4.13.0-38-generic
ii  linux-image-4.13.0-39-generic               
ii  linux-image-4.13.0-41-generic

Cosa posso fare? Rimuovo il pacchetto incriminato e lo provo a reinstallare?
alukard990
Prode Principiante
 
Messaggi: 159
Iscrizione: febbraio 2014

Re: Crash pacchetto xserver-xorg-core

Messaggioda .:matteo:. » giovedì 17 maggio 2018, 20:32

Temo non servirebbe, pittosto, al prossimo aggiornamento del kernel potrai cambiarlo e vedere se qualcosa migliora. In ogni caso non mi è ben chiaro se ci sono dei problemi tangibili associati al messaggio di errore che visualizzi. Perchè senza conosce cause e/o effetti è davvero difficile sradicare il problema.

considera che, per problemi simili (mesaggi di errore in avvio su una release abbastanza recente), io "risolvevo" disabilitando temperaneamente il sistema di segnalazione di errori chiamato apport.
https://howtoubuntu.org/how-to-disable- ... -in-ubuntu

in tal modo, almeno per il momento non ricevi segnalazione, ovviamente il problema persiste. tuttavia, se non ti da' reali criticità, puoi semplicemente aspettare che venga bugfixato, su una lts appena rilasciata è normale. Stai usando la 18.04 o la 16.04? Se stai usando la 16.04, non riesci a fare mente locale per capire se avevi effettuato operazioni particolari prima che il problema si presentasse? Se stai usando la 18.04, il problema persiste dal primo avvio.

Mi rendo conto che disabilitare apport non è una reale soluzione, ma in mancanza d'altro...
.:matteo:.
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1496
Iscrizione: gennaio 2012
Desktop: XFCE 4.12 / MATE 1.20
Distribuzione: Xubuntu 16.04 / Ubuntu MATE 18.04
Sesso: Maschile


Torna a LXDE

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 2 ospiti