Crash pacchetto xserver-xorg-core

Configurazione e uso delle applicazioni del desktop manager alla base di Lubuntu.

Crash pacchetto xserver-xorg-core

Messaggioda alukard990 » sabato 12 maggio 2018, 10:27

Salve a tutti, è da un po' di tempo che all'avvio di ogni sessione mi compare la classica segnalazione di un errore interno al sistema. Prima di rivolgermi qui ho cercato un po' in rete ma non ho trovato granché a riguardo; ho provato anche a cancellare i file nascosti xsession-errors nella home sperando che qualche aggiornamento avesse risolto il problema ma ahimè senza risultato. Come da titolo l'errore sembra stare nel seguente package:
Codice: Seleziona tutto
xserver-xorg-core-hwe-16.04 2:1.19.5-0ubuntu2~16.04.1

Cosa posso fare per risolvere?
alukard990
Prode Principiante
 
Messaggi: 170
Iscrizione: febbraio 2014
Desktop: Lubuntu
Distribuzione: 16.04, 64bit

Re: Crash pacchetto xserver-xorg-core

Messaggioda .:matteo:. » domenica 13 maggio 2018, 11:53

Il sistema è aggiornato?

Puoi provare ad avviare un kernel precedente da GRUB e vedere se per caso l'errore non compare più?
.:matteo:.
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1512
Iscrizione: gennaio 2012
Desktop: XFCE 4.12 / MATE 1.20
Distribuzione: Xubuntu 16.04 / Ubuntu MATE 18.04
Sesso: Maschile

Re: Crash pacchetto xserver-xorg-core

Messaggioda alukard990 » lunedì 14 maggio 2018, 8:49

.:matteo:. Immagine ha scritto:Il sistema è aggiornato?

Puoi provare ad avviare un kernel precedente da GRUB e vedere se per caso l'errore non compare più?


Il sistema è costantemente aggiornato; ho avviato un kernel precedente e l'errore sembra non esserci.
alukard990
Prode Principiante
 
Messaggi: 170
Iscrizione: febbraio 2014
Desktop: Lubuntu
Distribuzione: 16.04, 64bit

Re: Crash pacchetto xserver-xorg-core

Messaggioda .:matteo:. » lunedì 14 maggio 2018, 18:48

alukard990 Immagine ha scritto:
.:matteo:. Immagine ha scritto:Il sistema è aggiornato?

Puoi provare ad avviare un kernel precedente da GRUB e vedere se per caso l'errore non compare più?


Il sistema è costantemente aggiornato; ho avviato un kernel precedente e l'errore sembra non esserci.

ok, allora rimuovi l'ultimo kernel installato e automaticamente il penultimo kernel verrà avviato di default da grub.
.:matteo:.
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1512
Iscrizione: gennaio 2012
Desktop: XFCE 4.12 / MATE 1.20
Distribuzione: Xubuntu 16.04 / Ubuntu MATE 18.04
Sesso: Maschile

Re: Crash pacchetto xserver-xorg-core

Messaggioda alukard990 » giovedì 17 maggio 2018, 8:35

.:matteo:. Immagine ha scritto:
alukard990 Immagine ha scritto:
.:matteo:. Immagine ha scritto:Il sistema è aggiornato?

Puoi provare ad avviare un kernel precedente da GRUB e vedere se per caso l'errore non compare più?


Il sistema è costantemente aggiornato; ho avviato un kernel precedente e l'errore sembra non esserci.

ok, allora rimuovi l'ultimo kernel installato e automaticamente il penultimo kernel verrà avviato di default da grub.


Ciao, scusa per non averti risposto subito ma vorrei informarti che il problema persiste anche con tutti i kernel precedenti. Avevo detto che il problema non ci fosse più ma avevo il dubbio che si potesse ripresentare e appunto ho esitato a chiudere eventualmente il post.
Attualmente sono installati questi 3 kernel:
Codice: Seleziona tutto
ii linux-image-4.13.0-38-generic
ii  linux-image-4.13.0-39-generic               
ii  linux-image-4.13.0-41-generic

Cosa posso fare? Rimuovo il pacchetto incriminato e lo provo a reinstallare?
alukard990
Prode Principiante
 
Messaggi: 170
Iscrizione: febbraio 2014
Desktop: Lubuntu
Distribuzione: 16.04, 64bit

Re: Crash pacchetto xserver-xorg-core

Messaggioda .:matteo:. » giovedì 17 maggio 2018, 20:32

Temo non servirebbe, pittosto, al prossimo aggiornamento del kernel potrai cambiarlo e vedere se qualcosa migliora. In ogni caso non mi è ben chiaro se ci sono dei problemi tangibili associati al messaggio di errore che visualizzi. Perchè senza conosce cause e/o effetti è davvero difficile sradicare il problema.

considera che, per problemi simili (mesaggi di errore in avvio su una release abbastanza recente), io "risolvevo" disabilitando temperaneamente il sistema di segnalazione di errori chiamato apport.
https://howtoubuntu.org/how-to-disable- ... -in-ubuntu

in tal modo, almeno per il momento non ricevi segnalazione, ovviamente il problema persiste. tuttavia, se non ti da' reali criticità, puoi semplicemente aspettare che venga bugfixato, su una lts appena rilasciata è normale. Stai usando la 18.04 o la 16.04? Se stai usando la 16.04, non riesci a fare mente locale per capire se avevi effettuato operazioni particolari prima che il problema si presentasse? Se stai usando la 18.04, il problema persiste dal primo avvio.

Mi rendo conto che disabilitare apport non è una reale soluzione, ma in mancanza d'altro...
.:matteo:.
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1512
Iscrizione: gennaio 2012
Desktop: XFCE 4.12 / MATE 1.20
Distribuzione: Xubuntu 16.04 / Ubuntu MATE 18.04
Sesso: Maschile

Re: Crash pacchetto xserver-xorg-core

Messaggioda alukard990 » lunedì 21 maggio 2018, 9:19

Ciao, uso la 16.04 e non ho fatto particolari operazioni se non quella di aggiornare il sistema ogni volta che mi viene proposto. In rete non riesco a trovare granché e sono davvero perso su questo problema... Scusami per aver risposto solo ora ma non ho potuto accendere il pc per qualche giorno.
alukard990
Prode Principiante
 
Messaggi: 170
Iscrizione: febbraio 2014
Desktop: Lubuntu
Distribuzione: 16.04, 64bit

Re: Crash pacchetto xserver-xorg-core

Messaggioda .:matteo:. » martedì 22 maggio 2018, 23:20

alukard990 Immagine ha scritto:Ciao, uso la 16.04 e non ho fatto particolari operazioni se non quella di aggiornare il sistema ogni volta che mi viene proposto. In rete non riesco a trovare granché e sono davvero perso su questo problema... Scusami per aver risposto solo ora ma non ho potuto accendere il pc per qualche giorno.

ok... quindi ti ripropongo la domanda...oltre alla scritta di errore noti qualche tipo di malfunzionamento? Mi sembra di capire che non riesci a ricondurre il problema a un evento preciso.

Purtroppo senza altri elementi faccio molta fatica a venirti incontro ulteriormente, come ti ho suggerito sopra puoi temporaneamente disabilitare il sistema di segnalazione errori se non vedi problematiche tangibili, a parte l'ovvio fastidio di vedere comparire il messaggio. Per come lo racconti, sembra essere un problema di qualche aggiornamento. Non mi sento di consigliarti di fare un downgrade del pacchetto che riporta quell'errore, poichè potrebbe causare più danni che altro. Piuttosto tieni aggiornato il sistema come hai sempre fatto e cerca di tenere d'occhio se pacchetti relativi a xorg vengono aggiornati di tanto in tanto. Esiste la possibilità che venga rilasciato un bugfix. Altro avviso del tutto generico... usi driver proprietari, per esempio per schede video? Hai provato a disabilitarli temporaneamente e vederli se con quelli open il messaggio scompare?
.:matteo:.
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1512
Iscrizione: gennaio 2012
Desktop: XFCE 4.12 / MATE 1.20
Distribuzione: Xubuntu 16.04 / Ubuntu MATE 18.04
Sesso: Maschile

Re: Crash pacchetto xserver-xorg-core

Messaggioda alukard990 » mercoledì 23 maggio 2018, 8:41

.:matteo:. Immagine ha scritto:
alukard990 Immagine ha scritto:Ciao, uso la 16.04 e non ho fatto particolari operazioni se non quella di aggiornare il sistema ogni volta che mi viene proposto. In rete non riesco a trovare granché e sono davvero perso su questo problema... Scusami per aver risposto solo ora ma non ho potuto accendere il pc per qualche giorno.

ok... quindi ti ripropongo la domanda...oltre alla scritta di errore noti qualche tipo di malfunzionamento? Mi sembra di capire che non riesci a ricondurre il problema a un evento preciso.

Purtroppo senza altri elementi faccio molta fatica a venirti incontro ulteriormente, come ti ho suggerito sopra puoi temporaneamente disabilitare il sistema di segnalazione errori se non vedi problematiche tangibili, a parte l'ovvio fastidio di vedere comparire il messaggio. Per come lo racconti, sembra essere un problema di qualche aggiornamento. Non mi sento di consigliarti di fare un downgrade del pacchetto che riporta quell'errore, poichè potrebbe causare più danni che altro. Piuttosto tieni aggiornato il sistema come hai sempre fatto e cerca di tenere d'occhio se pacchetti relativi a xorg vengono aggiornati di tanto in tanto. Esiste la possibilità che venga rilasciato un bugfix. Altro avviso del tutto generico... usi driver proprietari, per esempio per schede video? Hai provato a disabilitarli temporaneamente e vederli se con quelli open il messaggio scompare?


Uso i driver proprietari Nvidia per gpu 820M ma li ho installati almeno da 1 anno da quando sono passato dalla 14.04 alla 16.04 e mai ho avuto problemi.
alukard990
Prode Principiante
 
Messaggi: 170
Iscrizione: febbraio 2014
Desktop: Lubuntu
Distribuzione: 16.04, 64bit

Re: Crash pacchetto xserver-xorg-core

Messaggioda caturen » mercoledì 23 maggio 2018, 9:56

ok... quindi ti ripropongo la domanda...oltre alla scritta di errore noti qualche tipo di malfunzionamento?
quando ti deciderai a rispondere a questa domanda? Perchè se non ti decidi a descrivere questi "presunti" malfunzionamenti si può fare ben poco se non pensare che apport continua a prendere lucciole per lanterne, come da tempo immemore fa. Ti basta fare una ricerca nel forum per venire a conoscenza di questi ipotetici errori.
caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14487
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: Crash pacchetto xserver-xorg-core

Messaggioda alukard990 » mercoledì 23 maggio 2018, 14:20

caturen Immagine ha scritto:
ok... quindi ti ripropongo la domanda...oltre alla scritta di errore noti qualche tipo di malfunzionamento?
quando ti deciderai a rispondere a questa domanda? Perchè se non ti decidi a descrivere questi "presunti" malfunzionamenti si può fare ben poco se non pensare che apport continua a prendere lucciole per lanterne, come da tempo immemore fa. Ti basta fare una ricerca nel forum per venire a conoscenza di questi ipotetici errori.


Ho cercati per vari giorni in rete senza venirne a capo altrimenti non sarei venuto qui a chiedere aiuto, non sono uno di quelli che chiede una mano senza che ce ne sia realmente il bisogno. Non noto alcun malfunzionamento altrimenti lo avrei descritto nei minimi particolari. Se non ho aggiunto altro è perché questo ho a disposizione.
alukard990
Prode Principiante
 
Messaggi: 170
Iscrizione: febbraio 2014
Desktop: Lubuntu
Distribuzione: 16.04, 64bit

Re: Crash pacchetto xserver-xorg-core

Messaggioda Marilù3 » mercoledì 23 maggio 2018, 18:13

Anche a me capita un errore simile , apport mi dice che c'è un errore in xorg, quando passo da un utente all'altro, e per un po' smette quando vado su Schermi e clicco su Applica a tutto il sistema e metto la password.
schermi.png


Non so come mai fa cosi, ho il sospetto che centri qualcosa la pulizia fatta con bleachbit, anche se la faccio da utente normale e non da root.
Avatar utente
Marilù3
Prode Principiante
 
Messaggi: 185
Iscrizione: dicembre 2016
Desktop: MATE
Distribuzione: Ubuntu 16.04.5 LTS x86_64

Re: Crash pacchetto xserver-xorg-core

Messaggioda .:matteo:. » mercoledì 23 maggio 2018, 22:32

io valutarei di disabilitare apport, oppure di ritardarne l'avvio automatico di, che ne so, 10 secondi... così il sistema di segnalazione errori resta attivo, ma non è funzionanete al boot del pc. visto che il problema, da quel che dite, se si presenta si presenta solo in avvio.
.:matteo:.
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1512
Iscrizione: gennaio 2012
Desktop: XFCE 4.12 / MATE 1.20
Distribuzione: Xubuntu 16.04 / Ubuntu MATE 18.04
Sesso: Maschile

Re: Crash pacchetto xserver-xorg-core

Messaggioda Marilù3 » giovedì 24 maggio 2018, 11:37

in d-conf editor si può togliere la spunta per non mostrare le segnalazioni di Apport, ma non saprei come ritardarlo all'avvio: nelle applicazioni d'avvio non c'è.
apport.png
Avatar utente
Marilù3
Prode Principiante
 
Messaggi: 185
Iscrizione: dicembre 2016
Desktop: MATE
Distribuzione: Ubuntu 16.04.5 LTS x86_64

Re: Crash pacchetto xserver-xorg-core

Messaggioda caturen » giovedì 24 maggio 2018, 12:39

Non noto alcun malfunzionamento altrimenti lo avrei descritto nei minimi particolari. Se non ho aggiunto altro è perché questo ho a disposizione.
Se non lo dici come pensi che noi lo possiamo sapere, con la sfera magica della cartomante? Comunque la tua è una ulteriore conferma che quelle segnalazioni di errore sono per la maggior parte campate in aria. Come ti ho già scritto, bastava fare una minima ricerca per averne una conferma. Disattiva apport e quella ciofega non ti darà più notifiche di problemi inesistenti
Codice: Seleziona tutto
sudo -h gedit /etc/default/apport
e cambiare in enabled da “1” a “0”
caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14487
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: Crash pacchetto xserver-xorg-core

Messaggioda Marilù3 » giovedì 24 maggio 2018, 17:41

[quote="caturen
Codice: Seleziona tutto
sudo -h gedit /etc/default/apport
e cambiare in enabled da “1” a “0”[/quote]

A me funziona sudo pluma etc/default/apport (pluma al posto di gedit dato che ho Mate) senza la -h
Avatar utente
Marilù3
Prode Principiante
 
Messaggi: 185
Iscrizione: dicembre 2016
Desktop: MATE
Distribuzione: Ubuntu 16.04.5 LTS x86_64


Torna a LXDE

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 7 ospiti