Problema avvio Debian terminale tty1

Informazioni, consigli e novità sulla galassia delle distribuzioni GNU/Linux, *nix, *BSD e su altri sistemi operativi non liberi.

Problema avvio Debian terminale tty1

Messaggioda Ubuntu1604LTS » lunedì 2 luglio 2018, 12:00

Buongiorno, sono due giorni che cerco di avviare Debian senza successo. La schermata che mi appare, invece di quella classica che permette il login, è tutta nera con le seguenti scritte:
Codice: Seleziona tutto
Debian GNU/Linux  debian tty1
debian login: 

Effettuando l'accesso con le solite credenziali e lanciando il comando
Codice: Seleziona tutto
startx
la schermata da nera diventa azzurra e si blocca, non si avvia alcuna interfaccia grafica. Qualcuno sa come aiutarmi?
Ubuntu1604LTS
Prode Principiante
 
Messaggi: 38
Iscrizione: novembre 2016
Desktop: ubuntu
Distribuzione: 16.04 LTS
Sesso: Maschile

Re: Problema avvio Debian terminale tty1

Messaggioda caturen » lunedì 2 luglio 2018, 12:36

prova ad aggiornare
Codice: Seleziona tutto
sudo apt update && sudo apt upgrade
e riavvia
caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14397
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: Problema avvio Debian terminale tty1

Messaggioda Lo Zio » lunedì 2 luglio 2018, 13:04

hai provato a vedere facendo accesso da Root?
Giusto per capire se è un problema solo a livello Utente
--> * Indice Wiki * Photoshop su Wine * Cerca su Ubuntu.it *
--> * Script per aggiungere Risolto alle discussioni * <-- Servono a tutti, ricordiamoci di usarli
......ti accorgi che fa caldo quando dai come input "sudo" e il terminale ti da come output "Anche io"
Avatar utente
Lo Zio
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1809
Iscrizione: settembre 2009
Località: Torino
Desktop: xfce / kde-plasma
Distribuzione: Debian 9.4 (stretch) x86_64

Re: Problema avvio Debian terminale tty1

Messaggioda Ubuntu1604LTS » lunedì 2 luglio 2018, 14:47

Ho provato sia ad aggiornare e riavviare che ad accedere come root, senza esito positivo o diverso dai tentativi precedenti. Altri suggerimenti?
Ubuntu1604LTS
Prode Principiante
 
Messaggi: 38
Iscrizione: novembre 2016
Desktop: ubuntu
Distribuzione: 16.04 LTS
Sesso: Maschile

Re: Problema avvio Debian terminale tty1

Messaggioda caturen » lunedì 2 luglio 2018, 14:52

che scheda video hai?
Potrebbe essere un problema del login manager che usi. Prova ad installarne un altro e vedi come si comporta
Ultima modifica di caturen il lunedì 2 luglio 2018, 15:09, modificato 1 volta in totale.
caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14397
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: Problema avvio Debian terminale tty1

Messaggioda Ubuntu1604LTS » lunedì 2 luglio 2018, 14:59

caturen Immagine ha scritto:che scheda video hai?

Codice: Seleziona tutto
display     G96 [GeForce 9500 GT]
Ubuntu1604LTS
Prode Principiante
 
Messaggi: 38
Iscrizione: novembre 2016
Desktop: ubuntu
Distribuzione: 16.04 LTS
Sesso: Maschile

Re: Problema avvio Debian terminale tty1

Messaggioda caturen » lunedì 2 luglio 2018, 15:11

hai installato i driver proprietari? Se si eliminali ed usa quelli open per vedere come si comporta.
caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14397
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: Problema avvio Debian terminale tty1

Messaggioda Ubuntu1604LTS » lunedì 2 luglio 2018, 15:14

caturen ha scritto:hai installato i driver proprietari? Se si eliminali ed usa quelli open per vedere come si comporta.

non mi fa proprio entrare, quindi non ho modo di fare quello che dici, inoltre di default credo usi i driver open-source.
Ubuntu1604LTS
Prode Principiante
 
Messaggi: 38
Iscrizione: novembre 2016
Desktop: ubuntu
Distribuzione: 16.04 LTS
Sesso: Maschile

Re: Problema avvio Debian terminale tty1

Messaggioda pachisapiu » lunedì 2 luglio 2018, 15:16

Ubuntu1604LTS Immagine ha scritto:
caturen ha scritto:hai installato i driver proprietari? Se si eliminali ed usa quelli open per vedere come si comporta.

non mi fa proprio entrare, quindi non ho modo di fare quello che dici, inoltre di default credo usi i driver open-source.

da recovery
Carbonara is my law - Chi ?
Curriculum - OffTopic
Avatar utente
pachisapiu
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1738
Iscrizione: maggio 2017
Distribuzione: FreeDOS

Re: Problema avvio Debian terminale tty1

Messaggioda caturen » lunedì 2 luglio 2018, 17:08

caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14397
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: Problema avvio Debian terminale tty1

Messaggioda Lo Zio » lunedì 2 luglio 2018, 19:23

provare a vedere cosa non va al boot?
posta
Codice: Seleziona tutto
nano /var/log/boot.log
--> * Indice Wiki * Photoshop su Wine * Cerca su Ubuntu.it *
--> * Script per aggiungere Risolto alle discussioni * <-- Servono a tutti, ricordiamoci di usarli
......ti accorgi che fa caldo quando dai come input "sudo" e il terminale ti da come output "Anche io"
Avatar utente
Lo Zio
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1809
Iscrizione: settembre 2009
Località: Torino
Desktop: xfce / kde-plasma
Distribuzione: Debian 9.4 (stretch) x86_64

Re: Problema avvio Debian terminale tty1

Messaggioda Ubuntu1604LTS » martedì 3 luglio 2018, 11:23

Lo Zio Immagine ha scritto:provare a vedere cosa non va al boot?
posta
Codice: Seleziona tutto
nano /var/log/boot.log

Credo che il file da te indicato non esista, dato che quando mi apre l'editor di testo il file è vuoto.
Digitando invece
Codice: Seleziona tutto
journalctl -p err -b
ho un errore (tra i vari che ci sono) che forse potrebbe essere il problema
Codice: Seleziona tutto
debian systemd[450]: Failed at step EXEC spawning /bin/plymouth: no such file or directory

C'entra qualcosa con il mio problema?
Ubuntu1604LTS
Prode Principiante
 
Messaggi: 38
Iscrizione: novembre 2016
Desktop: ubuntu
Distribuzione: 16.04 LTS
Sesso: Maschile

Re: Problema avvio Debian terminale tty1

Messaggioda Lo Zio » martedì 3 luglio 2018, 18:34

Codice: Seleziona tutto
debian systemd[450]: Failed at step EXEC spawning /bin/plymouth: no such file or directory

è un errore del plymouth (la schermata del boot all'avvio) ,ti avvisa che non trova il file o la directory.
Provare a eliminarlo all'avvio tramite
Codice: Seleziona tutto
systemctl mask plymouth-start.service plymouth-quit.service plymouth-quit-wait.service
?
(aspetta anche altri consigli perchè non ne sono sicuro al 100%) :shy:
--> * Indice Wiki * Photoshop su Wine * Cerca su Ubuntu.it *
--> * Script per aggiungere Risolto alle discussioni * <-- Servono a tutti, ricordiamoci di usarli
......ti accorgi che fa caldo quando dai come input "sudo" e il terminale ti da come output "Anche io"
Avatar utente
Lo Zio
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1809
Iscrizione: settembre 2009
Località: Torino
Desktop: xfce / kde-plasma
Distribuzione: Debian 9.4 (stretch) x86_64

Re: Problema avvio Debian terminale tty1

Messaggioda caturen » martedì 3 luglio 2018, 18:44

caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14397
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: Problema avvio Debian terminale tty1

Messaggioda Ubuntu1604LTS » mercoledì 4 luglio 2018, 10:03

caturen Immagine ha scritto:https://unix.stackexchange.com/questions/170667/failed-at-step-exec-spawning-bin-plymouth-debian-testing

Nel link da te indicato viene detto di cambiare da "auto" a "noauto" nel file fstab, però nel mio file è già impostato su "noauto".
Ubuntu1604LTS
Prode Principiante
 
Messaggi: 38
Iscrizione: novembre 2016
Desktop: ubuntu
Distribuzione: 16.04 LTS
Sesso: Maschile


Torna a Altre distribuzioni e sistemi operativi

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 4 ospiti