Dual monitor non funziona

Riconoscimento, installazione e configurazione delle periferiche.

Re: Dual monitor non funziona

Messaggioda andrea111 » giovedì 12 luglio 2018, 13:43

Prova a fare un'altra cosa:
apri Registro di Sistema, scorrilo fini in fondo in modo da visualizzare le ultime righe (vedi di memorizzarle) poi connetti il secondo monitor (e tutto diventerà nero), aspetta qualche secondo (conta fino a cinque) e sconnetti il monitor, guarda se nel registro di sistema sono apparse delle righe nuove rispetto a prima. Se ce ne sono dovresti postarle (siamo alla ricerca di eventuali indizi su quello strano comportamento).

Subito dopo aver disconnesso il monitor dovresti anche dare
Codice: Seleziona tutto
dmesg | tail
e postare pure quello.
andrea111
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1321
Iscrizione: novembre 2007

Re: Dual monitor non funziona

Messaggioda fulviot66 » venerdì 13 luglio 2018, 9:31

Ciao a tutti,
di seguito il risultato del mio PC, ho pensato che potesse essere utile.
Codice: Seleziona tutto
fulvio@travelmate-5735:~$ dmesg | tail
[   10.626775] IPv6: ADDRCONF(NETDEV_UP): wlp4s0: link is not ready
[   10.779912] IPv6: ADDRCONF(NETDEV_UP): wlp4s0: link is not ready
[   11.618867] tg3 0000:05:00.0 enp5s0: Link is down
[   13.667688] tg3 0000:05:00.0 enp5s0: Link is up at 100 Mbps, full duplex
[   13.667691] tg3 0000:05:00.0 enp5s0: Flow control is on for TX and on for RX
[   13.667759] IPv6: ADDRCONF(NETDEV_CHANGE): enp5s0: link becomes ready
[   27.640193] Bluetooth: RFCOMM TTY layer initialized
[   27.640201] Bluetooth: RFCOMM socket layer initialized
[   27.640211] Bluetooth: RFCOMM ver 1.11
[   30.458042] rfkill: input handler disabled
fulvio@travelmate-5735:~$ dmesg | tail
[   10.779912] IPv6: ADDRCONF(NETDEV_UP): wlp4s0: link is not ready
[   11.618867] tg3 0000:05:00.0 enp5s0: Link is down
[   13.667688] tg3 0000:05:00.0 enp5s0: Link is up at 100 Mbps, full duplex
[   13.667691] tg3 0000:05:00.0 enp5s0: Flow control is on for TX and on for RX
[   13.667759] IPv6: ADDRCONF(NETDEV_CHANGE): enp5s0: link becomes ready
[   27.640193] Bluetooth: RFCOMM TTY layer initialized
[   27.640201] Bluetooth: RFCOMM socket layer initialized
[   27.640211] Bluetooth: RFCOMM ver 1.11
[   30.458042] rfkill: input handler disabled
[  125.575717] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
fulvio@travelmate-5735:~$

Il primo blocco si riferisce alla situazione senza collegare il monitor esterno.
Il secondo blocco, invece con il monitor esterno collegato, acceso e funzionante.
ACER Travelmate 5735 - Intel Core 2 Duo T6570@2,1 Ghz - 480GB SSD - 4GB Ram - Windows 10 (1803) 32 bit - Ubuntu 18.04_x64 - K4.15.0-33-generic

"Mai discutere con un idiota, ti trascina al suo livello e poi ti batte con l'esperienza" - O.Wilde
Avatar utente
fulviot66
Prode Principiante
 
Messaggi: 222
Iscrizione: marzo 2018
Località: Lessolo (TO)
Desktop: Ubuntu
Distribuzione: Ubuntu 18.04 LTS - x86_64
Sesso: Maschile

Re: Dual monitor non funziona

Messaggioda Sergio_B » venerdì 13 luglio 2018, 11:03

Codice: Seleziona tutto
zeus@ZeusHP:~$ dmesg | tail
[ 2066.777708] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[ 2503.679669] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[ 2567.768185] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[ 2568.010670] do_IRQ: 1.43 No irq handler for vector
[ 2576.161070] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[ 3175.842325] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[ 3178.323415] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[ 3489.765417] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[ 3493.671737] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[ 3496.452901] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
zeus@ZeusHP:~$
Sergio_B
Prode Principiante
 
Messaggi: 92
Iscrizione: ottobre 2013
Località: Poasco - San Donato Milanese
Desktop: ubuntu
Distribuzione: ubuntu 17.10 64bit
Sesso: Maschile

Re: Dual monitor non funziona

Messaggioda andrea111 » venerdì 13 luglio 2018, 13:20

@ Sergio_B
rifai la stessa prova ma alla fine dando
Codice: Seleziona tutto
dmesg | grep -i -e "drm\|error"
potrebbe essere molto lungo, per cui dovrai allegarlo.
Per allegare devi usate il tasto "Invia Allegato" che trovi sotto la finestra in cui scrivi l'intervento-
andrea111
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1321
Iscrizione: novembre 2007

Re: Dual monitor non funziona

Messaggioda Sergio_B » venerdì 13 luglio 2018, 13:31

Codice: Seleziona tutto
zeus@ZeusHP:~$ dmesg | grep -i -e "drm\|error"
[    1.796842] RAS: Correctable Errors collector initialized.
[    2.141204] [drm] Memory usable by graphics device = 2048M
[    2.141210] fb: switching to inteldrmfb from VESA VGA
[    2.141719] [drm] Replacing VGA console driver
[    2.148041] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    2.148042] [drm] Driver supports precise vblank timestamp query.
[    2.203324] [drm] RC6 disabled, disabling runtime PM support
[    2.204106] [drm] Initialized i915 1.6.0 20171023 for 0000:00:02.0 on minor 0
[    2.414952] fbcon: inteldrmfb (fb0) is primary device
[    2.415077] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[    4.880315] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[    6.315528] hp_wmi: query 0xd returned error 0x5
[   13.379575] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[ 4971.434816] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[ 4975.612511] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[ 4977.593292] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[ 5090.401897] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[ 5092.648815] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[ 5094.242458] [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
zeus@ZeusHP:~$
Sergio_B
Prode Principiante
 
Messaggi: 92
Iscrizione: ottobre 2013
Località: Poasco - San Donato Milanese
Desktop: ubuntu
Distribuzione: ubuntu 17.10 64bit
Sesso: Maschile

Re: Dual monitor non funziona

Messaggioda andrea111 » venerdì 13 luglio 2018, 15:47

dopo l'aggiornamento a ubuntu 18.04 non mi funziona più il dual monitor. In pratica, quando collego il secondo monitor (VGA), entrambi i monitor diventano neri. Il monitor si riaccende quando scollego il cavo VGA.
quindi il problema si è manifestato al passaggio alla 18.04, prima era tutto OK.

L'errore che appare nei listati ce l'ha anche fulvio66 ed è del tutto ininfluente nel suo caso perché gli funziona tutto (è uno di quegli errori del tutto asintomatici che a volte (misteriosamente) appaiono), l'unica differenza è che a te si ripete più volte.

Prova ad avviare da un kernel + vecchio (sempre ammesso che ce ne siano) e vedi se persiste; naturalmente gli aggiornamenti li hai già fatti tutti:
Codice: Seleziona tutto
sudo apt update
sudo apt upgrade


Si dovrebbe procedere con l'analisi dei log, ma credo che prima ci siano da fare altre prove, del genere ritentare l'installazione pulita.

Dovresti farti una live della 18.04 (scaricarla e masterizzarle) avviarla e da lì fare la prova del secondo monitor - se lì funziona tutto, c'è poco da fare, dovrai reinstallare - vuol dire che il problema è emerso durante l'aggiornamento dalla 17.10 alla 18.04, se è così è inutile procedere con l'analisi.
andrea111
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1321
Iscrizione: novembre 2007

Re: Dual monitor non funziona

Messaggioda fulviot66 » lunedì 16 luglio 2018, 17:24

by the way
Oggi ho collegato lo stesso monitor esterno che ho usato sul mio Acer TM5735 in firma, sul mio Toshiba M50 anch'esso in firma e ...
Non funziona! O meglio sembrava che non funzionasse, ma se mando il PC in blocco tastiera e poi rientro, ecco che sul monitor esterno compare per magia l'estensione del desktop, ed alcune volte, anche il dialogo di login.
Premendo la combinazione dei tasti Fn + F5 che su questa macchina attivano l'uscita VGA verso il monitor, bisogna selezionare la scheda avanzate dell'applicazione LXRandR ed indicare di attivare entrambi i monitor.
ACER Travelmate 5735 - Intel Core 2 Duo T6570@2,1 Ghz - 480GB SSD - 4GB Ram - Windows 10 (1803) 32 bit - Ubuntu 18.04_x64 - K4.15.0-33-generic

"Mai discutere con un idiota, ti trascina al suo livello e poi ti batte con l'esperienza" - O.Wilde
Avatar utente
fulviot66
Prode Principiante
 
Messaggi: 222
Iscrizione: marzo 2018
Località: Lessolo (TO)
Desktop: Ubuntu
Distribuzione: Ubuntu 18.04 LTS - x86_64
Sesso: Maschile

Re: Dual monitor non funziona

Messaggioda Sergio_B » lunedì 16 luglio 2018, 18:38

Ragazzi, mi devo scusare e ringraziare per la vostra gentilezza, ma al momento sono in.... vacanza e quindi non accenderò il pc per un paio di settimane. Intanto mi segno i vostri consigli. Appena torno a casa, riprovo.
Sergio_B
Prode Principiante
 
Messaggi: 92
Iscrizione: ottobre 2013
Località: Poasco - San Donato Milanese
Desktop: ubuntu
Distribuzione: ubuntu 17.10 64bit
Sesso: Maschile

Precedente

Torna a Driver e periferiche

Chi c’è in linea

Visualizzano questa sezione: vincent29264 e 26 ospiti