Connessione lenta

Riconoscimento, installazione e configurazione delle periferiche.

Connessione lenta

Messaggioda danielepais » giovedì 12 luglio 2018, 13:06

Salve a tutti!
Ho dei problemi con la connessione ad Internet, a cui accedo senza problemi con lo smartphone.
Ho installato Ubuntu 16.04.
C'è qualcuno che può aiutarmi per favore?
Posto un po' di dati sul sistema.

Codice: Seleziona tutto
daniele@daniele-Olidata-ST3000:~$ sudo lshw -short
H/W path         Device      Class       Description
====================================================
                             system      Olidata ST3000
/0                           bus         L51RI1
/0/0                         memory      102KiB BIOS
/0/4                         processor   AMD Turion(tm) 64 X2 Mobile Technology
/0/4/5                       memory      512KiB L2 cache
/0/1b                        memory      1GiB System Memory
/0/1b/0                      memory      512MiB DIMM DRAM Synchronous
/0/1b/1                      memory      512MiB DIMM DRAM Synchronous
/0/100                       bridge      RS480/RS482/RS485 Host Bridge
/0/100/1                     bridge      RC4xx/RS4xx PCI Bridge [int gfx]
/0/100/1/5                   display     RS482M [Mobility Radeon Xpress 200]
/0/100/4                     bridge      RC4xx/RS4xx PCI Express Port 1
/0/100/12                    storage     IXP SB4x0 Serial ATA Controller
/0/100/13                    bus         IXP SB4x0 USB Host Controller
/0/100/13/1      usb2        bus         OHCI PCI host controller
/0/100/13.1                  bus         IXP SB4x0 USB Host Controller
/0/100/13.1/1    usb3        bus         OHCI PCI host controller
/0/100/13.2                  bus         IXP SB4x0 USB2 Host Controller
/0/100/13.2/1    usb1        bus         EHCI Host Controller
/0/100/14                    bus         IXP SB4x0 SMBus Controller
/0/100/14.1                  storage     IXP SB4x0 IDE Controller
/0/100/14.2                  multimedia  IXP SB4x0 High Definition Audio Control
/0/100/14.3                  bridge      IXP SB4x0 PCI-ISA Bridge
/0/100/14.4                  bridge      IXP SB4x0 PCI-PCI Bridge
/0/100/14.4/3    wlp5s3      network     RT2561/RT61 rev B 802.11g
/0/100/14.4/4                bus         Firewire (IEEE 1394)
/0/100/14.4/4.2              generic     Integrated MMC/SD Controller
/0/100/14.4/4.3              storage     Integrated MS/xD Controller
/0/100/14.4/5    enp5s5      network     RTL-8100/8101L/8139 PCI Fast Ethernet A
/0/101                       bridge      K8 [Athlon64/Opteron] HyperTransport Te
/0/102                       bridge      K8 [Athlon64/Opteron] Address Map
/0/103                       bridge      K8 [Athlon64/Opteron] DRAM Controller
/0/104                       bridge      K8 [Athlon64/Opteron] Miscellaneous Con
/0/1             scsi0       storage     
/0/1/0.0.0       /dev/sda    disk        120GB WDC WD1200BEVS-0
/0/1/0.0.0/1     /dev/sda1   volume      19GiB Windows NTFS volume
/0/1/0.0.0/2     /dev/sda2   volume      92GiB Extended partition
/0/1/0.0.0/2/5   /dev/sda5   volume      58GiB HPFS/NTFS partition
/0/1/0.0.0/2/6   /dev/sda6   volume      1004MiB Linux swap / Solaris partition
/0/1/0.0.0/2/7   /dev/sda7   volume      32GiB Linux filesystem partition
/0/2             scsi2       storage     
/0/2/0.0.0       /dev/cdrom  disk        DVDRAM GSA-T10N
/0/2/0.0.0/0     /dev/cdrom  disk       
/1                           power       GLW-SAN



Codice: Seleziona tutto
daniele@daniele-Olidata-ST3000:~$ sudo lshw -c network
  *-network:0             
       description: Wireless interface
       product: RT2561/RT61 rev B 802.11g
       vendor: Ralink corp.
       physical id: 3
       bus info: pci@0000:05:03.0
       logical name: wlp5s3
       version: 00
       serial: 00:19:db:03:0d:72
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rt61pci driverversion=4.4.0-93-generic firmware=0.8 ip=192.168.100.6 latency=64 link=yes multicast=yes wireless=IEEE 802.11bg
       resources: irq:23 memory:c0200000-c0207fff
  *-network:1
       description: Ethernet interface
       product: RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 5
       bus info: pci@0000:05:05.0
       logical name: enp5s5
       version: 10
       serial: 00:03:0d:5c:3d:d3
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=half latency=64 link=no maxlatency=64 mingnt=32 multicast=yes port=MII speed=10Mbit/s
       resources: irq:9 ioport:a000(size=256) memory:c0208c00-c0208cff


Codice: Seleziona tutto
daniele@daniele-Olidata-ST3000:~$ lspci -knn | grep -A 2 -i net
05:03.0 Network controller [0280]: Ralink corp. RT2561/RT61 rev B 802.11g [1814:0302]
   Subsystem: Micro-Star International Co., Ltd. [MSI] RT2561/RT61 rev B 802.11g [1462:b833]
   Kernel driver in use: rt61pci
--
05:05.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8100/8101L/8139 PCI Fast Ethernet Adapter [10ec:8139] (rev 10)
   Subsystem: Uniwill Computer Corp RTL-8100/8101L/8139 PCI Fast Ethernet Adapter [1584:2b04]
   Kernel driver in use: 8139too
   Kernel modules: 8139cp, 8139too


Codice: Seleziona tutto
daniele@daniele-Olidata-ST3000:~$ ifconfig
enp5s5    Link encap:Ethernet  IndirizzoHW 00:03:0d:5c:3d:d3 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1000
          Byte RX:0 (0.0 B)  Byte TX:0 (0.0 B)

lo        Link encap:Loopback locale 
          indirizzo inet:127.0.0.1  Maschera:255.0.0.0
          indirizzo inet6: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2605 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2605 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1
          Byte RX:223176 (223.1 KB)  Byte TX:223176 (223.1 KB)

wlp5s3    Link encap:Ethernet  IndirizzoHW 00:19:db:03:0d:72 
          indirizzo inet:192.168.100.6  Bcast:192.168.100.255  Maschera:255.255.255.0
          indirizzo inet6: fe80::68ac:71f4:12bf:ea30/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16625 errors:0 dropped:0 overruns:0 frame:0
          TX packets:13932 errors:0 dropped:0 overruns:0 carrier:0
          collisioni:0 txqueuelen:1000
          Byte RX:16841750 (16.8 MB)  Byte TX:1810392 (1.8 MB)


Codice: Seleziona tutto
daniele@daniele-Olidata-ST3000:~$ rfkill list all
0: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no



Codice: Seleziona tutto
daniele@daniele-Olidata-ST3000:~$ sudo iwlist enp5s5 scan
enp5s5    Interface doesn't support scanning.


P.S. Ho provato a postare i dati relativi alla scheda di rete (enp5s5), ma sembra che non sia possibile effettuare lo scanning... :(
danielepais
Prode Principiante
 
Messaggi: 34
Iscrizione: marzo 2015
Distribuzione: Ubuntu 16.04.5 LTS X86_64
Sesso: Maschile

Re: Connessione lenta

Messaggioda danielepais » giovedì 12 luglio 2018, 13:16

Ecco i dati sulla scheda di rete (wlp5s3 ;) )

Codice: Seleziona tutto
wlp5s3    Scan completed :
          Cell 01 - Address: 84:A9:C4:A3:D6:98
                    Channel:8
                    Frequency:2.447 GHz (Channel 8)
                    Quality=42/70  Signal level=-68 dBm 
                    Encryption key:on
                    ESSID:"WirelessNet1"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000001f3ff56fff
                    Extra: Last beacon: 80ms ago
                    IE: Unknown: 000C576972656C6573734E657431
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 030108
                    IE: Unknown: 0706236120010E1E
                    IE: Unknown: 2A0100
                    IE: Unknown: 2F0100
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 32040C121860
                    IE: Unknown: 0B050200070000
                    IE: Unknown: 2D1ABD1917FFFFFF0000000000000000000000000000000000000000
                    IE: Unknown: 3D1608001700000000000000000000000000000000000000
                    IE: Unknown: 4A0E14000A002C01C800140005001900
                    IE: Unknown: 7F080500080000000040
                    IE: Unknown: DD090010180202001C0000
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101080003A4000027A4000042435E0062322F00
                    IE: Unknown: 46057200010000
danielepais
Prode Principiante
 
Messaggi: 34
Iscrizione: marzo 2015
Distribuzione: Ubuntu 16.04.5 LTS X86_64
Sesso: Maschile

Re: Connessione lenta

Messaggioda thece » giovedì 12 luglio 2018, 14:26

:ciao:

visto che questo è un problema diverso, è meglio se apri una nuova discussione e fai staccare questi due post in quella discussione

Segnalo la io cosa ad un amministratore
Avatar utente
thece
Rampante Reduce
Rampante Reduce
 
Messaggi: 9561
Iscrizione: aprile 2007
Distribuzione: Debian 9 (Stretch) - KDE

Re: Connessione lenta

Messaggioda thece » giovedì 12 luglio 2018, 20:49

Quanto è distante il PC dal modem / router xDSL? Ostacoli?

Vediamo quanto è affollata la tua zona

Codice: Seleziona tutto
sudo iwlist wlp5s3 scan

Controlliamo le impostazioni del driver

Codice: Seleziona tutto
dmesg | egrep 'wlp5s3|rt61pci|cfg80211|mac80211'

Codice: Seleziona tutto
modinfo rt61pci

Codice: Seleziona tutto
grep -R [[:graph:]] /sys/module/rt61pci/parameters
Avatar utente
thece
Rampante Reduce
Rampante Reduce
 
Messaggi: 9561
Iscrizione: aprile 2007
Distribuzione: Debian 9 (Stretch) - KDE

Re: Connessione lenta

Messaggioda danielepais » martedì 24 luglio 2018, 20:39

Ciao!
Scusate, eccomi! Ero fuori città...
Grazie a chi ha separato i post e creato una nuova discussione.
Rispondendo alla domanda di Thece, che ringrazio :) , il pc dista due metri dal router. Mi collego con cavo LAN (con maggiori difficoltà) e tramite wireless. C'è una porta a separarli.
Per quanto riguarda i dati richiesti:

Codice: Seleziona tutto
sudo iwlist wlp5s3 scan
wlp5s3    Interface doesn't support scanning : Network is down


Codice: Seleziona tutto
dmesg | egrep 'wlp5s3|rt61pci|cfg80211|mac80211'
[   29.328422] cfg80211: World regulatory domain updated:
[   29.328432] cfg80211:  DFS Master region: unset
[   29.328435] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   29.328439] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   29.328443] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   29.328446] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   29.328450] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[   29.328454] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[   29.328457] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[   29.328460] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   29.328463] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   29.864102] rt61pci 0000:05:03.0 wlp5s3: renamed from wlan0
[   65.889280] IPv6: ADDRCONF(NETDEV_UP): wlp5s3: link is not ready



Codice: Seleziona tutto
 modinfo rt61pci
filename:       /lib/modules/4.4.0-93-generic/kernel/drivers/net/wireless/rt2x00/rt61pci.ko
license:        GPL
firmware:       rt2661.bin
firmware:       rt2561s.bin
firmware:       rt2561.bin
description:    Ralink RT61 PCI & PCMCIA Wireless LAN driver.
version:        2.3.0
author:         http://rt2x00.serialmonkey.com
srcversion:     147116748700BC2C93D5888
alias:          pci:v00001814d00000401sv*sd*bc*sc*i*
alias:          pci:v00001814d00000302sv*sd*bc*sc*i*
alias:          pci:v00001814d00000301sv*sd*bc*sc*i*
depends:        rt2x00lib,rt2x00mmio,rt2x00pci,eeprom_93cx6,crc-itu-t
intree:         Y
vermagic:       4.4.0-93-generic SMP mod_unload modversions
parm:           nohwcrypt:Disable hardware encryption. (bool)



Codice: Seleziona tutto
grep -R [[:graph:]] /sys/module/rt61pci/parameters
/sys/module/rt61pci/parameters/nohwcrypt:N



In qualche precedente post ho visto che un altro utente aveva risolto il problema inabilitando IPv6 ed utilizzando IPv4.
Con Windows XP mi connettevo proprio impostando manualmente l'indirizzo IP con il protocollo IPv4 (allora però il provider era Telecom, ora ho la fibra ottica con Wind- Infostrada)
Potrebbe essere una strada percorribile?
Grazie! :ciao:
danielepais
Prode Principiante
 
Messaggi: 34
Iscrizione: marzo 2015
Distribuzione: Ubuntu 16.04.5 LTS X86_64
Sesso: Maschile

Re: Connessione lenta

Messaggioda thece » martedì 24 luglio 2018, 20:59

Proviamo a modificare questa opzione (nohwcrypt) del driver (rt61pci): dai il seguente comando

Codice: Seleziona tutto
echo "options rt61pci nohwcrypt=1" | sudo tee /etc/modprobe.d/rt61pci.conf

poi riavvia il PC. Ripeti i seguenti comandi per controllare

Codice: Seleziona tutto
grep -R [[:graph:]] /sys/module/rt61pci/parameters
sudo iwlist wlp5s3 scan

Se il secondo comando dovesse dirti "Network is down" significa che la scheda di rete WIFI è stata disattivata. Attivala con il comando

Codice: Seleziona tutto
ifconfig wlp5s3 up

e ripeti la scansione
Avatar utente
thece
Rampante Reduce
Rampante Reduce
 
Messaggi: 9561
Iscrizione: aprile 2007
Distribuzione: Debian 9 (Stretch) - KDE

Re: Connessione lenta

Messaggioda DoctorStrange » martedì 24 luglio 2018, 22:49

Sembra che il tuo sistema abbia solo 1 Gb di memoria. Secondo me é un pó troppo tirato per il collo. Magari hai provato con una distribuzione un pó piú leggera, se ottieni qualche miglioramento?
Avatar utente
DoctorStrange
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1271
Iscrizione: ottobre 2015
Località: Roma, Italia
Desktop: Unity
Distribuzione: Ubuntu 16.04.03 Xenial Xerus
Sesso: Maschile

Re: Connessione lenta

Messaggioda danielepais » giovedì 26 luglio 2018, 18:29

Ciao! Grazie Thece! :)
Ho dato il tuo comando:

Codice: Seleziona tutto
echo "options rt61pci nohwcrypt=1" | sudo tee /etc/modprobe.d/rt61pci.conf
[sudo] password di daniele:
options rt61pci nohwcrypt=1


Arresto e riavvio.
Doctorstrange, no, non ho mai provato un'altra distibuzione più leggera.
Credo che il problema non sia quello: a seconda dei giorni, non è possibile accedere alla rete per nulla (solo con il pc, invece riesco con lo smartphone), in altri sembra quasi normale, anche per video in streaming.
danielepais
Prode Principiante
 
Messaggi: 34
Iscrizione: marzo 2015
Distribuzione: Ubuntu 16.04.5 LTS X86_64
Sesso: Maschile

Re: Connessione lenta

Messaggioda thece » giovedì 26 luglio 2018, 18:48

E i restanti output? La connessione alla rete WIFI è migliorata?
Avatar utente
thece
Rampante Reduce
Rampante Reduce
 
Messaggi: 9561
Iscrizione: aprile 2007
Distribuzione: Debian 9 (Stretch) - KDE

Re: Connessione lenta

Messaggioda danielepais » giovedì 26 luglio 2018, 19:53

Dopo aver dato il comando, spento e riavviato, non riesco più ad accedere alla rete, né con il wireless né con il cavo LAN. :o
Ora mi sono collegato con lo smartphone.
Il primo dei tre comandi ha generato una lista lunghissima di dati. Non so come copiarli qui: il classico copia e incolla su una cartella dello smartphone non funziona.
Il secondo comando mi dà : bash:sys/module/ecc: è una directory.
danielepais
Prode Principiante
 
Messaggi: 34
Iscrizione: marzo 2015
Distribuzione: Ubuntu 16.04.5 LTS X86_64
Sesso: Maschile

Re: Connessione lenta

Messaggioda thece » giovedì 26 luglio 2018, 20:48

Strano, la modifica non dovrebbe portare i problemi che hai descritto.
Mi fai vedere cosa è finito dentro il file /etc/modprobe.d/rt61pci.conf ?

Codice: Seleziona tutto
cat /etc/modprobe.d/rt61pci.conf

Per ripristinare la situazione precedente è sufficiente cancellare il file

Codice: Seleziona tutto
sudo rm /etc/modprobe.d/rt61pci.conf     <-----<< Corretto: aggiunto sudo

e riavviare il PC.
Se il problemi dovessero persistere allora il problema non è dovuto alla mia modifica


danielepais Immagine ha scritto:Il primo dei tre comandi ha generato una lista lunghissima di dati. Non so come copiarli qui: il classico copia e incolla su una cartella dello smartphone non funziona.
Il secondo comando mi dà : bash:sys/module/ecc: è una directory.

Rileggendo, mi sono anche fatto l'idea che tu abbi scritto male i comandi suggeriti. La prossiva volta, in caso di errori, riporta sia i comandi impartiti sia i loro output facendo Copia&Incolla direttamente dal terminale, altrimenti è difficile sapere cosa hai fatto esattamente.
Ultima modifica di thece il giovedì 2 agosto 2018, 14:47, modificato 1 volta in totale.
Avatar utente
thece
Rampante Reduce
Rampante Reduce
 
Messaggi: 9561
Iscrizione: aprile 2007
Distribuzione: Debian 9 (Stretch) - KDE

Re: Connessione lenta

Messaggioda danielepais » venerdì 27 luglio 2018, 0:04

Ora sono connesso dal pc.
È molto lento.

Posto gli output richiesti:

Codice: Seleziona tutto
grep -R [[:graph:]] /sys/module/rt61pci/parameters
/sys/module/rt61pci/parameters/nohwcrypt:Y


Codice: Seleziona tutto
sudo iwlist wlp5s3 scan
[sudo] password di daniele:
wlp5s3    Scan completed :
          Cell 01 - Address: 84:A9:C4:A3:D6:98
                    Channel:9
                    Frequency:2.452 GHz (Channel 9)
                    Quality=32/70  Signal level=-78 dBm 
                    Encryption key:on
                    ESSID:"WirelessNet1"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=00000027dd2add29
                    Extra: Last beacon: 24ms ago
                    IE: Unknown: 000C576972656C6573734E657431
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 030109
                    IE: Unknown: 0706236120010E1E
                    IE: Unknown: 2A0100
                    IE: Unknown: 2F0100
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 32040C121860
                    IE: Unknown: 0B050200190000
                    IE: Unknown: 2D1ABD1917FFFFFF0000000000000000000000000000000000000000
                    IE: Unknown: 3D1609001700000000000000000000000000000000000000
                    IE: Unknown: 4A0E14000A002C01C800140005001900
                    IE: Unknown: 7F080500080000000040
                    IE: Unknown: DD090010180202001C0000
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101080003A4000027A4000042435E0062322F00
                    IE: Unknown: 46057200010000




Codice: Seleziona tutto
cat /etc/modprobe.d/rt61pci.conf
options rt61pci nohwcrypt=1



Faccio sempre copia & incolla per e dal terminale; prima ero allo smartphone ed ho ricopiato un breve output, non riuscendo a fare altrimenti.
danielepais
Prode Principiante
 
Messaggi: 34
Iscrizione: marzo 2015
Distribuzione: Ubuntu 16.04.5 LTS X86_64
Sesso: Maschile

Re: Connessione lenta

Messaggioda danielepais » venerdì 27 luglio 2018, 0:14

Ancora non ho cancellato il file con "rm /etc/modprobe.d/rt61pci.conf"; forse il problema non era quello, come suggerivi, ma era dovuto al consueto andamento randomico della connessione. :(
Aspetto le tue direttive. ;)
danielepais
Prode Principiante
 
Messaggi: 34
Iscrizione: marzo 2015
Distribuzione: Ubuntu 16.04.5 LTS X86_64
Sesso: Maschile

Re: Connessione lenta

Messaggioda thece » venerdì 27 luglio 2018, 8:19

Procedi pure con la rimozione del file /etc/modprobe.d/rt61pci.conf ed il riavvio del PC.


Proviamo a lavorare sul protocollo di rete IPv6

Disabilitiamo il protocollo di rete IPv6 a livello di sistema
Con un editor di testi in modalità amministratore apri il file di testo /etc/sysctl.conf

Codice: Seleziona tutto
sudo gedit /etc/sysctl.conf

e in fondo al file aggiungi le seguenti righe

Codice: Seleziona tutto
# Disabilito globalmente il protocollo di rete IPv6
net.ipv6.conf.all.disable_ipv6 = 1

salva il file.

Disabilitiamo il protocollo di rete IPv6 a livello di connessione
Dai il comando

Codice: Seleziona tutto
nmcli connection

verranno elencati i nomi di tutte le tue connessioni di rete. Usa questo output per completare il seguente comando

Codice: Seleziona tutto
nmcli connection modify "NOME_DELLA_CONNESSIONE_WIFI" ipv6.method ignore

Una volta fatto, riavvia il PC


Come verifica puoi usare i seguenti comandi

Codice: Seleziona tutto
find /proc/sys/net -name "disable_ipv6" -exec echo '{}' \; -exec cat '{}' \;
sudo iwlist wlp5s3 scan

Questi dopo che ti sei connesso alla tua rete WIFI

Codice: Seleziona tutto
ifconfig
iwconfig
Avatar utente
thece
Rampante Reduce
Rampante Reduce
 
Messaggi: 9561
Iscrizione: aprile 2007
Distribuzione: Debian 9 (Stretch) - KDE

Re: Connessione lenta

Messaggioda danielepais » sabato 28 luglio 2018, 18:39

Ciao!
Problema nel problema...
Oggi ho effettuato degli aggiornamenti, in seguito ai quali il sistema operativo è andato in crash! :muro: "Si è verificato un problema ad un programma di sistema".
Credo che ora la priorità sia questa: non posso avviare nessun programma: le icone vanno e vengono in modo intermittente.
Apro una nuova discussione e lascio in sospeso questa.
danielepais
Prode Principiante
 
Messaggi: 34
Iscrizione: marzo 2015
Distribuzione: Ubuntu 16.04.5 LTS X86_64
Sesso: Maschile

Re: Connessione lenta

Messaggioda danielepais » giovedì 2 agosto 2018, 12:09

Ciao !
Rieccomi!
Sono subentrati dei problemi in seguito ad un aggiornamento. Ora uso la versione 4.40-93 del kernel (recovery mode).
Per quanto riguarda la cancellazione del file, non riesco a dare l'input "yes"!
Ho fatto delle ricerche, provato in vari modi, con parentesi quadre, yes, y, con un'apposita riga di comando... Nulla! :(
Permesso negato.
Posto qui l'output:

Codice: Seleziona tutto
daniele@daniele-Olidata-ST3000:~$ rm /etc/modprobe.d/rt61pci.conf
rm: rimuovere il file regolare protetto dalla scrittura '/etc/modprobe.d/rt61pci.conf'? yes | sudo ./vmware-install.pl -d
rm: impossibile rimuovere '/etc/modprobe.d/rt61pci.conf': Permesso negato


Cerco poi di disabilitare IpV6 con un editor di testo... Spero di farcela!
Intanto posto questo...
A presto (spero) ! ;)
danielepais
Prode Principiante
 
Messaggi: 34
Iscrizione: marzo 2015
Distribuzione: Ubuntu 16.04.5 LTS X86_64
Sesso: Maschile

Re: Connessione lenta

Messaggioda maxbigsi » giovedì 2 agosto 2018, 12:12

Codice: Seleziona tutto
sudo rm /etc/modprobe.d/rt61pci.conf
W il software libero..... W Ubuntu -- Ubuntu User # 31322
Avatar utente
maxbigsi
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 16273
Iscrizione: maggio 2008
Desktop: Mate
Distribuzione: Ubuntu Mate 16.04 64bit
Sesso: Maschile

Re: Connessione lenta

Messaggioda danielepais » giovedì 2 agosto 2018, 12:55

Da terminale ho dato il primo output; è comparsa una schermata (immagino dell'editor di testo), che riporto:

Codice: Seleziona tutto
#
# /etc/sysctl.conf - Configuration file for setting system variables
# See /etc/sysctl.d/ for additional system variables.
# See sysctl.conf (5) for information.
#

#kernel.domainname = example.com

# Uncomment the following to stop low-level messages on console
#kernel.printk = 3 4 1 3

##############################################################3
# Functions previously found in netbase
#

# Uncomment the next two lines to enable Spoof protection (reverse-path filter)
# Turn on Source Address Verification in all interfaces to
# prevent some spoofing attacks
#net.ipv4.conf.default.rp_filter=1
#net.ipv4.conf.all.rp_filter=1

# Uncomment the next line to enable TCP/IP SYN cookies
# See http://lwn.net/Articles/277146/
# Note: This may impact IPv6 TCP sessions too
#net.ipv4.tcp_syncookies=1

# Uncomment the next line to enable packet forwarding for IPv4
#net.ipv4.ip_forward=1

# Uncomment the next line to enable packet forwarding for IPv6
#  Enabling this option disables Stateless Address Autoconfiguration
#  based on Router Advertisements for this host
#net.ipv6.conf.all.forwarding=1


###################################################################
# Additional settings - these settings can improve the network
# security of the host and prevent against some network attacks
# including spoofing attacks and man in the middle attacks through
# redirection. Some network environments, however, require that these
# settings are disabled so review and enable them as needed.
#
# Do not accept ICMP redirects (prevent MITM attacks)
#net.ipv4.conf.all.accept_redirects = 0
#net.ipv6.conf.all.accept_redirects = 0
# _or_
# Accept ICMP redirects only for gateways listed in our default
# gateway list (enabled by default)
# net.ipv4.conf.all.secure_redirects = 1
#
# Do not send ICMP redirects (we are not a router)
#net.ipv4.conf.all.send_redirects = 0
#
# Do not accept IP source route packets (we are not a router)
#net.ipv4.conf.all.accept_source_route = 0
#net.ipv6.conf.all.accept_source_route = 0
#
# Log Martian Packets
#net.ipv4.conf.all.log_martians = 1
#



ho aggiunto il comando al file.
Dal terminale è comparso questo:
Codice: Seleziona tutto
daniele@daniele-Olidata-ST3000:~$ sudo gedit /etc/sysctl.conf
[sudo] password di daniele:

(gedit:5428): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

** (gedit:5428): WARNING **: Set document metadata failed: Impostazione dell'attributo metadata::gedit-spell-enabled non supportata

** (gedit:5428): WARNING **: Set document metadata failed: Impostazione dell'attributo metadata::gedit-encoding non supportata

** (gedit:5428): WARNING **: Set document metadata failed: Impostazione dell'attributo metadata::gedit-spell-enabled non supportata

** (gedit:5428): WARNING **: Set document metadata failed: Impostazione dell'attributo metadata::gedit-encoding non supportata

** (gedit:5428): WARNING **: Set document metadata failed: Impostazione dell'attributo metadata::gedit-spell-enabled non supportata

** (gedit:5428): WARNING **: Set document metadata failed: Impostazione dell'attributo metadata::gedit-encoding non supportata

** (gedit:5428): WARNING **: Set document metadata failed: Impostazione dell'attributo metadata::gedit-spell-enabled non supportata

** (gedit:5428): WARNING **: Set document metadata failed: Impostazione dell'attributo metadata::gedit-encoding non supportata


Forse non ho i privilegi di amministratore?
Provo a proseguire ugualmente con la procedura.

Codice: Seleziona tutto
daniele@daniele-Olidata-ST3000:~$ nmcli connection
NOME                    UUID                                  TIPO             DEVICE
Connessione Ethernet 1  c4341895-25f0-44b5-b0b7-b7cb5b33efc9  802-3-ethernet   enp5s5
WirelessNet1 1          0c2f41cf-e52a-425a-aeb9-3fcce0f9186d  802-11-wireless  wlp5s3
Connessione Ethernet 2  4f4ad7ff-3414-459c-9775-f131bb412ec8  802-3-ethernet   --     
WebPocket-08A7          5304a697-cc40-46e7-a4b6-472a72a24120  802-11-wireless  --     
WirelessNet1            42e8fcd6-cc2f-4f3e-94ff-fc4658b287de  802-11-wireless  --     
wireless                e32093a4-8ca7-426f-8562-c9db6309318d  802-11-wireless  --     


Codice: Seleziona tutto
daniele@daniele-Olidata-ST3000:~$ nmcli connection modify "WirelessNet1" ipv6.method ignore


Ora riavvio il pc... Ed incrocio le dita! ;)
danielepais
Prode Principiante
 
Messaggi: 34
Iscrizione: marzo 2015
Distribuzione: Ubuntu 16.04.5 LTS X86_64
Sesso: Maschile

Re: Connessione lenta

Messaggioda danielepais » giovedì 2 agosto 2018, 12:58

Prima però: anche con il suggerimento di Maxbigsi ( che ringrazio) l'esito è lo stesso:

Codice: Seleziona tutto
daniele@daniele-Olidata-ST3000:~$ nmcli connection modify "WirelessNet1" ipv6.method ignore
daniele@daniele-Olidata-ST3000:~$ rm /etc/modprobe.d/rt61pci.conf
rm: rimuovere il file regolare protetto dalla scrittura '/etc/modprobe.d/rt61pci.conf'? sudo rm /etc/modprobe.d/rt61pci.conf
rm: impossibile rimuovere '/etc/modprobe.d/rt61pci.conf': Permesso negato
danielepais
Prode Principiante
 
Messaggi: 34
Iscrizione: marzo 2015
Distribuzione: Ubuntu 16.04.5 LTS X86_64
Sesso: Maschile

Re: Connessione lenta

Messaggioda thece » giovedì 2 agosto 2018, 14:48

Controlliamo, posta questo output

Codice: Seleziona tutto
ls -l /etc/modprobe.d/rt61pci.conf
Avatar utente
thece
Rampante Reduce
Rampante Reduce
 
Messaggi: 9561
Iscrizione: aprile 2007
Distribuzione: Debian 9 (Stretch) - KDE

Successiva

Torna a Driver e periferiche

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 18 ospiti