problemi con virtualbox, vmware player, wubi non esiste più?

Installazione di Ubuntu su macchina virtuale (Virtualbox, Vmware, Qemu, Parallels, KVM, Xen, Virtual pc, ecc.), configurazione del software e gestione del sistema virtualizzato.

problemi con virtualbox, vmware player, wubi non esiste più?

Messaggioda andremen » domenica 5 agosto 2018, 21:26

Salve, come da titolo oggi, dopo tanto tempo, ho voluto provare a reinstallare ubuntu in macchina virtuale per riprovarlo a usare nonostante le difficoltà che ho sempre incontrato con i sistemi linux, ma sia virtualbox che vmware player, gratuiti entrambi, mi hanno dato problemi, il primo mi dava solo l'elenco completo dei s.o. a 32 bit, e come da manuale ho verificato sul BIOS e nella CPU configuration che Intel VT-x fosse abilitato e infatti lo era, nonostante questo continuo ad avere l'elenco dei sistemi a 32 bit, mentre vmware mi chiedeva di disabilitare, sui criteri di gruppo (gpedit.msc) la sicurezza attiva basata sulla virtualizzazione, tra l'altro neanche configurata, poi di disabilitare HYPER-V che era già disabilitato, ed inserire alcune stringhe sul prompt dei comandi come amministratore per disabilitare Credential Guard e Device Guard:

Codice: Seleziona tutto
Cause
This issue occurs because Device Guard or Credential Guard is incompatible with Workstation.

Resolution
To disable Device Guard or Credential Guard:

Disable the group policy setting that was used to enable Credential Guard.
On the host operating system, click Start > Run, type gpedit.msc, and click Ok. The Local group Policy Editor opens.
Go to Local Computer Policy > Computer Configuration > Administrative Templates > System > Device Guard > Turn on Virtualization Based Security.
Select Disabled.
 
Go to Control Panel > Uninstall a Program > Turn Windows features on or off to turn off Hyper-V.
Select Do not restart.
Delete the related EFI variables by launching a command prompt on the host machine using an Administrator account and run these commands:

mountvol X: /s
copy %WINDIR%\System32\SecConfig.efi X:\EFI\Microsoft\Boot\SecConfig.efi /Y
bcdedit /create {0cb3b571-2f2e-4343-a879-d86a476d7215} /d "DebugTool" /application osloader
bcdedit /set {0cb3b571-2f2e-4343-a879-d86a476d7215} path "\EFI\Microsoft\Boot\SecConfig.efi"
bcdedit /set {bootmgr} bootsequence {0cb3b571-2f2e-4343-a879-d86a476d7215}
bcdedit /set {0cb3b571-2f2e-4343-a879-d86a476d7215} loadoptions DISABLE-LSA-ISO,DISABLE-VBS
bcdedit /set {0cb3b571-2f2e-4343-a879-d86a476d7215} device partition=X:
mountvol X: /d

Note: Ensure X is an unused drive, else change to another drive.
 
Restart the host.
Accept the prompt on the boot screen to disable Device Guard or Credential Guard.

Tutto questo l'ho fatto, ma il risultato è che dopo aver riavviato il pc e previa disattivazione con F3 di entrambe queste voci, all'avvio della macchina virtuale il messaggio d'errore non era relativo alle due credenziali ma ad hyper-v che è sempre stato disattivato, da notare che tutta questa immensa quantità di istruzioni vanno date ogni qualvolta si spegne e riavvia il pc, per cui alla fine la domanda è questa:

ma WUBI che fine ha fatto ? era veramente la soluzione migliore perchè tra l'altro occupava una cartella del disco come fosse un programma, senza macchine virtuali e con tutti i problemi conseguenti

Grazie.
Ultima modifica di trekfan1 il lunedì 6 agosto 2018, 6:18, modificato 2 volte in totale.
Motivazione: Sistemati i tag CODE
ASUS H81M-C Intel Core i3-4130, 3333 MHz (34 x 98) 8 GB RAM 1 HD SSD 120 GB + 1 HD 2000 GB NVIDIA GeForce GT 630
andremen
Prode Principiante
 
Messaggi: 71
Iscrizione: maggio 2010

Re: problemi con virtualbox, vmware player, wubi non esiste

Messaggioda trekfan1 » domenica 5 agosto 2018, 21:35

1) Per l'output NON si usa il grassetto ma il tag CODE, clicca su Modifica e correggi
2) Wubi ci dovrebbe essere ancora ma non è più supportato in quanto sfruttando un file sul disco windows era soggetto alle limitazioni del file system NTFS come la frammentazione inoltre se cerchi troverai una marea di topic (vecchi ovviamente) di gente a cui ha dato un sacco di problemi, inoltre con UEFI non dovrebbe funzionare
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 18562
Iscrizione: maggio 2006
Località: Formigine (MO) | Tenace Tecnocrate
Desktop: Gnome
Distribuzione: Ubuntu 18.10 e 19.04 (dev) 64 bit
Sesso: Maschile

Re: problemi con virtualbox, vmware player, wubi non esiste

Messaggioda woddy68 » domenica 5 agosto 2018, 22:29

Oltre alla virtualizzazione che francamente a me non piace (a meno che non si utilizzi un pc con una ottima cpu e ram in abbondanza) esiste l'installazione normale su hard disk che rimane la migliore e che non è certo roba da scienziati . Oggi un dual boot non lo si nega a nessuno. :) :ciao:
Desktop - Acer Aspire M5500 (AMD) OpenSuse Leap 15 Kde -- Kubuntu 18.04 -- Tumbleweed
Notebook Acer Aspire E1 -522 (Amd) Tumbleweed
Avatar utente
woddy68
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3731
Iscrizione: febbraio 2011
Località: Bellano Lc
Desktop: Kde Plasma5
Distribuzione: Leap 15 - Tumbleweed- Kubuntu 18.04
Sesso: Maschile

Re: problemi con virtualbox, vmware player, wubi non esiste

Messaggioda willy54 » lunedì 6 agosto 2018, 0:17

Confermo, anche io non vedo l'utilità di utilizzare la virtualizzazione se non hai un hardware super dotato di processore o di ram, considera poi la difficoltà di configurazione , di driver che fanno le bizze, la grafica che si inceppa se la usi con giochi recenti, il wifi che non sempre si riesce a fare funzionare, gli hardisk oggi sono capienti , un dual boot è sicuramente più facile da gestire che non una macchina virtuale e funziona meglio e più velocemente.
La macchina virtuale può essere ancora valida se devi utilizzare degli SO molto datati che potrebbero non avere driver adeguati alle strutture hardware di oggi, un esempio se devi utilizzare un windows98 o Me su un computer recente la macchina virtuale è quasi un obbligo , ma per altri casi ..... la escluderei tanto più che la licenza windows la hai pagata.
Toshiba Satellite A660 11M Intel® Core™ i7 CPU Q 720 @ 1.60GHz × 8, SSD 250 gb + hdd 500 gb ram 2x4 Gb : Win7 - Win10 - Ubuntu 18.04 LTS - Kubuntu 18.04 LTS - - VisualBasic 2008 su win7 gparted sda inxi -Fz
Una cortesia per favore per chi cerca di aiutarvi, quando la soluzione è trovata, mettete il [Risolto] sul primo post, la discussione può aiutare altri.
Avatar utente
willy54
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2022
Iscrizione: dicembre 2017
Località: Castell'Alfero (AT)
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile


Torna a Ubuntu su macchina virtuale

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 1 ospite