[Risolto] errore: boot grub i386-pcnormal.mo

Problemi riscontrati durante l'installazione di Ubuntu, degli aggiornamenti e degli avanzamenti del sistema.

Re: SOS!stack in grub rescue.errore: boot/grub/i386-pc/norma

Messaggioda trekfan1 » domenica 12 agosto 2018, 20:17

Devi averla appunto in fase di installazione di ubuntu, inoltre NON selezionare una partizione LOGICA come destinazione del GRUB ma /dev/sda che è il settore di avvio (MBR) del disco rigido
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 17827
Iscrizione: maggio 2006
Località: Formigine (MO) | Tenace Tecnocrate
Desktop: Gnome Shell
Distribuzione: Ubuntu 18.04 e 18.10 (dev) 64 bit
Sesso: Maschile

Re: SOS!stack in grub rescue.errore: boot/grub/i386-pc/norma

Messaggioda Hitogj » domenica 12 agosto 2018, 21:03

Ciao, come diceva @Trekfan1 devi avviare dal Bios/uefi il dispositivo di installazione(dvd o Chiavetta) selezionando quello del
caso senza la scritta "UEFI" davanti...
:ciao:
Chi non lo prova...non lo crede!
Non tutti i mali vengono per nuocere!
Avatar utente
Hitogj
Prode Principiante
 
Messaggi: 90
Iscrizione: giugno 2007
Località: Napoli
Desktop: Ubuntu
Distribuzione: 16.04.5LTS_64bit
Sesso: Maschile

Re: SOS!stack in grub rescue.errore: boot/grub/i386-pc/norma

Messaggioda alco1900 » lunedì 13 agosto 2018, 8:03

trekfan1 Immagine ha scritto:Devi reinstallare in modalità normale, evita l'installazione UEFI, inoltre puoi cancellare le partizione LOGICHE


Ok, ho come hai detto reinstallato in modalità normale e modificando in modalità manuale le partizioni. Nel menu a tendina che dice "scegli il dev dove installare il bootloader" ho messo la partizione dove cè la roort di ubuntu.

Stesso problema di prima: quando accendo va in grub rescue.
Poi ho notato che il grub rescue cerca il normal.mod in boot/grub/i386-pc mentre invece da live il percorso di normal.mod risulta essere boot/grub/x86_64-efi
E' normale questa differenza?
Avatar utente
alco1900
Prode Principiante
 
Messaggi: 20
Iscrizione: agosto 2018
Desktop: ubuntu
Distribuzione: 17.10
Sesso: Maschile

Re: SOS!stack in grub rescue.errore: boot/grub/i386-pc/norma

Messaggioda giulux » lunedì 13 agosto 2018, 8:09

giulux Immagine ha scritto:Scarica e metti su CD o pennetta supergrubdisk
Avvia con quello, fai partire ubuntu e dai
Codice: Seleziona tutto
sudo grub-install /dev/sda && sudo update-grub

Riavvia il computer (senza disco/pennetta) e vedi se hai risolto.
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...
Avatar utente
giulux
Amministratore
Amministratore
 
Messaggi: 20988
Iscrizione: gennaio 2010
Località: Roma
Desktop: xubuntu - ubuntu 17.10
Distribuzione: Ubuntu 16.04.1 LTS x86_64
Sesso: Maschile

Re: SOS!stack in grub rescue.errore: boot/grub/i386-pc/norma

Messaggioda alco1900 » lunedì 13 agosto 2018, 8:34

Hitogj Immagine ha scritto:Ciao, come diceva @Trekfan1 devi avviare dal Bios/uefi il dispositivo di installazione(dvd o Chiavetta) selezionando quello del
caso senza la scritta "UEFI" davanti...
:ciao:


Ciao.
Io entro nel bios premendo F10 in fase di avvio del pc. Nel Bios, sotto a "configurazione sistema", vi è la possibilità di scegliere il "boot order". Ci sono però
due elenchi: uno UEFI e l'altro Legacy Bios.
Mi stai dicendo di mettere al primo posto la chiavetta USB con ubuntu nell'elengo Legacy Bios?
Avatar utente
alco1900
Prode Principiante
 
Messaggi: 20
Iscrizione: agosto 2018
Desktop: ubuntu
Distribuzione: 17.10
Sesso: Maschile

SOS: Problema Post Installazione Ubuntu 18

Messaggioda alco1900 » lunedì 13 agosto 2018, 11:30

Salve a tutti.
Ho un hp15 modello r212nl. Seguendo le guide online avevo creato un dual boot WIndows10 - ubuntu 17. Tutto funzionava bene. Poi ho avuto la brillante idea di fare quanto segue.
Ho creato una chiavetta bootable con ubuntu 18 (ultima versione). Ho inserito la chiavetta e fatto l'installazione selezionando la voce "rimuovi ubuntu 17 e installa ubuntu 18". L'installazione va a buon fine ma poi quando avvio arrivo nel grub rescue.

Dal boot rescue digitando "set" vedo che root = hdo5 cioè una partizione efi (fat32).
allora digito
set root = hd0,7
set prefix=(hd0,7)/boot/grub
insmod normal e qui mi da l'errore [error file boot/grub/i386-pc/not found].

Osservazioni:
1) non accedo piu nemmeno a Windows perche rimango nel boot rescue
2) Posso solo accedere dalla live ubuntu
3) Ho installato ubuntu in modalità Legacy Bios
4) Dall'errore si vede che normal.mod viene ricercato sotto la cartella i386-pc mentre da live io vedo che sta sotto x86_64-efi
5)Le partizioni sono:
dev/sda1 [ntfs] [riservato per il sistema]
dev/sda2 [ntfs] [OS]
dev/sda4 [extended]
>>>>>dev/sda5 [fat32] [flag=boot,esp]
>>>>> dev/sda6 [ext4] [root ubuntu]
Avatar utente
alco1900
Prode Principiante
 
Messaggi: 20
Iscrizione: agosto 2018
Desktop: ubuntu
Distribuzione: 17.10
Sesso: Maschile

Re: SOS!stack in grub rescue.errore: boot/grub/i386-pc/norma

Messaggioda trekfan1 » lunedì 13 agosto 2018, 11:49

Ti ho unito il post dalla nuova discussione che hai creato (PS: il regolamento VIETA il crossposting!) in questa perché risponde casualmente alla domanda che avevo scritto al posto di questo post, sugli HP puoi usare il tasto F9 per modificare in modo temporaneo l'ordine di boot. E, forse non ci siamo capiti, il grub deve andare in /dev/sda e NON in una partizione LOGICA!
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 17827
Iscrizione: maggio 2006
Località: Formigine (MO) | Tenace Tecnocrate
Desktop: Gnome Shell
Distribuzione: Ubuntu 18.04 e 18.10 (dev) 64 bit
Sesso: Maschile

Re: SOS!stack in grub rescue.errore: boot/grub/i386-pc/norma

Messaggioda alco1900 » lunedì 13 agosto 2018, 11:55

trekfan1 Immagine ha scritto:Ti ho unito il post dalla nuova discussione che hai creato (PS: il regolamento VIETA il crossposting!) in questa perché risponde casualmente alla domanda che avevo scritto al posto di questo post, sugli HP puoi usare il tasto F9 per modificare in modo temporaneo l'ordine di boot. E, forse non ci siamo capiti, il grub deve andare in /dev/sda e NON in una partizione LOGICA!


Va bene, grazie. Chiedo scusa.
Avatar utente
alco1900
Prode Principiante
 
Messaggi: 20
Iscrizione: agosto 2018
Desktop: ubuntu
Distribuzione: 17.10
Sesso: Maschile

Re: SOS!stack in grub rescue.errore: boot/grub/i386-pc/norma

Messaggioda dxgiusti » lunedì 13 agosto 2018, 13:05

io non credo che tu abbia un avvio gestito da efi ( per quanto ne so serve il disco con le tabelle gpt ed il tuo ha le tabelle msdos altrimenti non potresti avere una partizione estesa con dentro partizioni logiche ).
cosa fare quindi per risolvere? da gparted metti il flag di boot alla prima partizione dev/sda1. fatto questo ripristina l'avvio di 10 ( e qui il web aiuta moltissimo, io per comodità uso quando mi capita >>> Rescatux in live ).
terminato , cancella dev/sda5 e dav/sda6 e ricrea per installare ex novo li dentro. solo la partizione in ext4 e la swap ( vedo che non l'avevi fatta ).
l'avvio su /dev/sda senza nessun numero di partizione.
Avatar utente
dxgiusti
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2814
Iscrizione: novembre 2007
Località: Lodi
Desktop: gnome
Distribuzione: ubuntu 18.04
Sesso: Maschile

Re: SOS!stack in grub rescue.errore: boot/grub/i386-pc/norma

Messaggioda alco1900 » lunedì 13 agosto 2018, 16:29

RISOLTO.
In pratica come mi avete consigliato, in particolare trekfan1, pigiando f9 ho fatto l'accesso da chiavetta USB non Uefi. HO installato Ubuntu e ora si apre grub con il boot manager regolare.
Non so cosa succedeva. Anzi mi piacerebbe capirlo. In particolare non capisco quella partizione EFI. Io non l'ho mai creata.
Avatar utente
alco1900
Prode Principiante
 
Messaggi: 20
Iscrizione: agosto 2018
Desktop: ubuntu
Distribuzione: 17.10
Sesso: Maschile

Re: [RISOLTO] errore: boot grub i386-pcnormal.mo

Messaggioda trekfan1 » lunedì 13 agosto 2018, 16:37

Succedeva perché facevi partire la chiavetta USB in modalità UEFI, per il futuro evita di mettere il [Risolto] tutto maiuscolo, grazie
Avatar utente
trekfan1
Moderatore Globale
Moderatore Globale
 
Messaggi: 17827
Iscrizione: maggio 2006
Località: Formigine (MO) | Tenace Tecnocrate
Desktop: Gnome Shell
Distribuzione: Ubuntu 18.04 e 18.10 (dev) 64 bit
Sesso: Maschile

Re: SOS!stack in grub rescue.errore: boot/grub/i386-pc/norma

Messaggioda alco1900 » lunedì 13 agosto 2018, 16:40

dxgiusti Immagine ha scritto:io non credo che tu abbia un avvio gestito da efi ( per quanto ne so serve il disco con le tabelle gpt ed il tuo ha le tabelle msdos altrimenti non potresti avere una partizione estesa con dentro partizioni logiche ).
cosa fare quindi per risolvere? da gparted metti il flag di boot alla prima partizione dev/sda1. fatto questo ripristina l'avvio di 10 ( e qui il web aiuta moltissimo, io per comodità uso quando mi capita >>> Rescatux in live ).
terminato , cancella dev/sda5 e dav/sda6 e ricrea per installare ex novo li dentro. solo la partizione in ext4 e la swap ( vedo che non l'avevi fatta ).
l'avvio su /dev/sda senza nessun numero di partizione.


CIao e grazie per la risposta. Non mi è molto chiaro se ho Uefi oppure no. Adesso che ho risolto ho avviato la pennetta in modalità non UEFI. Per come dici tu al livello di partizione non sembra che io abbia UEFI. BHa non ho capito sinceramente e mi piacerebbe capirlo.
Comunque credo di avere l'UEFI con la possibilità di attivare LEgacy Bios, ma non ne sono sicuro.

In pratica se installavo Ubuntu dalla pennetta avviata in modalità UEFI avevo problemi con il bootloader invece accedendo in modoalità NON UEFI, nessun problema.

Ti chiedo un consiglio.
Ora la mia tabella di partizioni è:
sda1 ntfs
sda2 OS
sda4 extension
>>>sda5 fat32 EFI
>>>sda6 root Ubuntu

2 domande:
1) La partizione EFI a cosa mi serve? come è saltata fuori?
2) L'area di swap è davvero necessaria? Ho letto che da Ubuntu 17 in poi non è più necessaria.
Avatar utente
alco1900
Prode Principiante
 
Messaggi: 20
Iscrizione: agosto 2018
Desktop: ubuntu
Distribuzione: 17.10
Sesso: Maschile

Re: [RISOLTO] errore: boot grub i386-pcnormal.mo

Messaggioda alco1900 » lunedì 13 agosto 2018, 16:41

trekfan1 Immagine ha scritto:Succedeva perché facevi partire la chiavetta USB in modalità UEFI, per il futuro evita di mettere il [Risolto] tutto maiuscolo, grazie

ok grazie a te
Avatar utente
alco1900
Prode Principiante
 
Messaggi: 20
Iscrizione: agosto 2018
Desktop: ubuntu
Distribuzione: 17.10
Sesso: Maschile

Re: [Risolto] errore: boot grub i386-pcnormal.mo

Messaggioda dxgiusti » lunedì 13 agosto 2018, 19:53

la gestione del computer può essere efi oppure legacy ( questo nei computer + recenti ).
ovviamente non puoi avere un sistema installato in una modalità e l'altro in modo differente.
far gestire l'avvio da efi con il bios impostato in tale modalità, comporta l'obbligo di avere le tabelle su cui scrivere la partizioni in modo gpt.
con le tabelle gpt non puoi creare partizioni estese/logiche, solo primarie in numero molto elevato.
ovvio che i sistemi vanno installati ex novo se si cambia tipo di partizionamento.
tornando alla tua partizione efi, con gparted mettigli il flag >>> hidden, praticamente la nascondi. riavvia il sistema e lei non verrà presa in considerazione. se tutto funziona vuol dire che non serve a nulla, la puoi eliminare.
per la swap non saprei, io la faccio sempre.
Avatar utente
dxgiusti
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2814
Iscrizione: novembre 2007
Località: Lodi
Desktop: gnome
Distribuzione: ubuntu 18.04
Sesso: Maschile

Re: [Risolto] errore: boot grub i386-pcnormal.mo

Messaggioda Hitogj » lunedì 13 agosto 2018, 21:29

Ciao a tutti! Scusate, ma per capire...perchè ci sono cose che ancora non capisco in questa discussione...cerco di farla breve!

@dxgiusti se pure @alco1900 avesse ripristinato sda5 ed sda6 in "primarie" da logiche quali erano, cosa che lui non ha mai
ammesso, perchè installare in modalità "NON UEFI??"

Grazie e scusate
Chi non lo prova...non lo crede!
Non tutti i mali vengono per nuocere!
Avatar utente
Hitogj
Prode Principiante
 
Messaggi: 90
Iscrizione: giugno 2007
Località: Napoli
Desktop: Ubuntu
Distribuzione: 16.04.5LTS_64bit
Sesso: Maschile

Re: [Risolto] errore: boot grub i386-pcnormal.mo

Messaggioda alco1900 » martedì 14 agosto 2018, 7:36

Hitogj Immagine ha scritto:Ciao a tutti! Scusate, ma per capire...perchè ci sono cose che ancora non capisco in questa discussione...cerco di farla breve!

@dxgiusti se pure @alco1900 avesse ripristinato sda5 ed sda6 in "primarie" da logiche quali erano, cosa che lui non ha mai
ammesso, perchè installare in modalità "NON UEFI??"

Grazie e scusate

Ciao @Hitogi. Non lo ho mai ammesso perche non sapevo bene la differenza tra partizioni primarie e logiche. Cmq credo che, anche se avessi voluto fare questo cambio da partizioni logiche a primarie, non avrei potuto farlo perchè al massimo si possono avere 4 primarie...se non sbaglio.
Avatar utente
alco1900
Prode Principiante
 
Messaggi: 20
Iscrizione: agosto 2018
Desktop: ubuntu
Distribuzione: 17.10
Sesso: Maschile

Re: [Risolto] errore: boot grub i386-pcnormal.mo

Messaggioda alco1900 » martedì 14 agosto 2018, 7:37

dxgiusti Immagine ha scritto:la gestione del computer può essere efi oppure legacy ( questo nei computer + recenti ).
ovviamente non puoi avere un sistema installato in una modalità e l'altro in modo differente.
far gestire l'avvio da efi con il bios impostato in tale modalità, comporta l'obbligo di avere le tabelle su cui scrivere la partizioni in modo gpt.
con le tabelle gpt non puoi creare partizioni estese/logiche, solo primarie in numero molto elevato.
ovvio che i sistemi vanno installati ex novo se si cambia tipo di partizionamento.
tornando alla tua partizione efi, con gparted mettigli il flag >>> hidden, praticamente la nascondi. riavvia il sistema e lei non verrà presa in considerazione. se tutto funziona vuol dire che non serve a nulla, la puoi eliminare.
per la swap non saprei, io la faccio sempre.

Grazie mille!!!
Avatar utente
alco1900
Prode Principiante
 
Messaggi: 20
Iscrizione: agosto 2018
Desktop: ubuntu
Distribuzione: 17.10
Sesso: Maschile

Re: [Risolto] errore: boot grub i386-pcnormal.mo

Messaggioda dxgiusti » martedì 14 agosto 2018, 11:36

Hitogj Immagine ha scritto:Ciao a tutti! Scusate, ma per capire...perchè ci sono cose che ancora non capisco in questa discussione...cerco di farla breve!

@dxgiusti se pure @alco1900 avesse ripristinato sda5 ed sda6 in "primarie" da logiche quali erano, cosa che lui non ha mai
ammesso, perchè installare in modalità "NON UEFI??"

Grazie e scusate

se capisco bene, lui inizialmente aveva un totale di 5 partizioni, una in più del limite delle quattro primarie. immagino sia questo il motivo.
anche se la discussione può sembrare interessante mi sembra che su di una sezione tecnica già risolta si vada fuori seminato rischiando di creare un "minestrone". direi che si potrebbe eventualmente continuare al bar. lo scambio di idee ed opinioni lo reputo sempre costruttivo.
Avatar utente
dxgiusti
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 2814
Iscrizione: novembre 2007
Località: Lodi
Desktop: gnome
Distribuzione: ubuntu 18.04
Sesso: Maschile

Re: [Risolto] errore: boot grub i386-pcnormal.mo

Messaggioda Hitogj » martedì 14 agosto 2018, 14:08

Si, grazie per la risposta, ma io mi sono già fatto un opinione in merito!
Non mi dilungo oltre, ma conto di incontrarti ancora, magari al Bar.
Ciao
Chi non lo prova...non lo crede!
Non tutti i mali vengono per nuocere!
Avatar utente
Hitogj
Prode Principiante
 
Messaggi: 90
Iscrizione: giugno 2007
Località: Napoli
Desktop: Ubuntu
Distribuzione: 16.04.5LTS_64bit
Sesso: Maschile

Precedente

Torna a Installazione e aggiornamento del sistema operativo

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 2 ospiti