[Risolto]wallpaper e gestore pacchetti spariti dopo aggiorn.

Informazioni, consigli e novità sulla galassia delle distribuzioni GNU/Linux, *nix, *BSD e su altri sistemi operativi non liberi.

[Risolto]wallpaper e gestore pacchetti spariti dopo aggiorn.

Messaggioda Lo Zio » domenica 12 agosto 2018, 11:22

Buongiorno e buon lavoro a chi non è andato in ferie (come me).
Mi è successo questo: dopo l'ultimo aggiornamento su Debian non ho più la possibilità di impostare uno sfondo al desktop.Mi ritrovo un sfondo grigio e "sembra"che non sia nemmeno cliccabile (tasto dx non avvia nessun menù),selezionando direttamente un' immagine dando "Imposta come sfondo" non si ottiene nessun risultato.
Dall'Editor delle impostazioni di xfce al menù backdrop->screen0->monitor0->image-path ha il percorso corretto.image-show è selezionato.last-image e last-image-show sono selezionate correttamente.
Oltre a questo problema ne ho un'altro che credo sia in qualche modo correlato (anche se non direttamente,all'altro).il Gestore pacchetti.
Se dal menù provo a lanciarlo,non si avvia.Mantre se lo lancio da terminale mi viene lanciato dopo la psw di root
Codice: Seleziona tutto
lozio@debian:~$ synaptic-pkexec
==== AUTHENTICATING FOR com.ubuntu.pkexec.synaptic ===
Authentication is required to run the Synaptic Package Manager
Authenticating as: root
Password:
polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie
==== AUTHENTICATION FAILED ===
Error executing command as another user: Not authorized

This incident has been reported.
lozio@debian:~$ sudo synaptic-pkexec
[sudo] password di lozio:

Qualche consiglio?Ciao e grazie a tutti :ciao:
Ultima modifica di Lo Zio il mercoledì 15 agosto 2018, 11:39, modificato 1 volta in totale.
--> * Indice Wiki * Photoshop su Wine * Cerca su Ubuntu.it *
--> * Script per aggiungere Risolto alle discussioni * <-- Servono a tutti, ricordiamoci di usarli
......ti accorgi che fa caldo quando dai come input "sudo" e il terminale ti da come output "Anche io"
Avatar utente
Lo Zio
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1809
Iscrizione: settembre 2009
Località: Torino
Desktop: xfce / kde-plasma
Distribuzione: Debian 9.4 (stretch) x86_64

Re: Debian: wallpaper e gestore pacchetti spariti dopo aggio

Messaggioda pachisapiu » domenica 12 agosto 2018, 11:34

Stretch , Buster o Sid ?
Avatar utente
pachisapiu
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1944
Iscrizione: maggio 2017
Distribuzione: FreeDOS

Re: Debian: wallpaper e gestore pacchetti spariti dopo aggio

Messaggioda Lo Zio » domenica 12 agosto 2018, 11:40

pachisapiu Immagine ha scritto:Stretch , Buster o Sid ?

Codice: Seleziona tutto
lozio@debian:~$ lsb_release -a
No LSB modules are available.
Distributor ID:   Debian
Description:   Debian GNU/Linux 9.5 (stretch)
Release:   9.5
Codename:   stretch
lozio@debian:~$

grazie mille
EDIt: Release: 9.5?Fore è quello il problema...non mi sono reso conto che aveva avanzato.
--> * Indice Wiki * Photoshop su Wine * Cerca su Ubuntu.it *
--> * Script per aggiungere Risolto alle discussioni * <-- Servono a tutti, ricordiamoci di usarli
......ti accorgi che fa caldo quando dai come input "sudo" e il terminale ti da come output "Anche io"
Avatar utente
Lo Zio
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1809
Iscrizione: settembre 2009
Località: Torino
Desktop: xfce / kde-plasma
Distribuzione: Debian 9.4 (stretch) x86_64

Re: Debian: wallpaper e gestore pacchetti spariti dopo aggio

Messaggioda pachisapiu » domenica 12 agosto 2018, 13:01

no 9.5 al momento è normale , ma se hai avuto problemi su Debian stable dopo aggiornamenti sicuramente hai incasinato le sorgenti software aggiungendo roba non ufficiale
Avatar utente
pachisapiu
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1944
Iscrizione: maggio 2017
Distribuzione: FreeDOS

Re: Debian: wallpaper e gestore pacchetti spariti dopo aggio

Messaggioda caturen » domenica 12 agosto 2018, 13:18

per curiosità ho voluto installare in virtualbox debian stabile con xfce. Quando ho avviato il sistema io non riscontro per nulla i tuoi problemi: synaptic si lancia tranquillamente dal menu e il desktop si può modificare tranquillamente ed il menu appare dando tasto destro del mouse sul desktop. Quindi non sono riuscito a confermare i tuoi problemi col sistema, perciò o un qualche bug o il tua sistema lo hai incasinato in qualche modo tu.
caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14493
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: Debian: wallpaper e gestore pacchetti spariti dopo aggio

Messaggioda ALLINONE » lunedì 13 agosto 2018, 15:54

Mi è successo questo: dopo l'ultimo aggiornamento su Debian non ho più la possibilità di impostare uno sfondo al desktop.Mi ritrovo un sfondo grigio e "sembra"che non sia nemmeno cliccabile (tasto dx non avvia nessun menù),selezionando direttamente un' immagine dando "Imposta come sfondo" non si ottiene nessun risultato.

controlla se in sessione e avvio al tab sessione ci sia xfdesktop
ALLINONE
Prode Principiante
 
Messaggi: 37
Iscrizione: luglio 2012
Desktop: lxde - xfce
Distribuzione: debian 6 - debian 7

Re: Debian: wallpaper e gestore pacchetti spariti dopo aggio

Messaggioda woddy68 » lunedì 13 agosto 2018, 16:29

Solitamente per capire se il problema riguarda il sistema o qualche configurazione sballata nel tuo utente, basta creare un nuovo utente, se funziona tutto correttamente il problema è nella tua home, se al contrario anche il nuovo utente soffre gli stessi problemi, significa che il problema sta nel sistema.
Perlomeno così capisci dove eventualmente mettere le mani. Ciao
Desktop - Acer Aspire M5500 (AMD) OpenSuse Leap 15 Kde -- Kubuntu 18.04 -- Tumbleweed
Notebook Acer Aspire E1 -522 (Amd) Tumbleweed
Avatar utente
woddy68
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3731
Iscrizione: febbraio 2011
Località: Bellano Lc
Desktop: Kde Plasma5
Distribuzione: Leap 15 - Tumbleweed- Kubuntu 18.04
Sesso: Maschile

Re: Debian: wallpaper e gestore pacchetti spariti dopo aggio

Messaggioda Selky » lunedì 13 agosto 2018, 18:45

Buona sera a tutti.

@Lo Zio
per il problema "synaptic" controlla che pacchetti hai installato relativi a policykit; da terminale, anche come utente normale, puoi dare questo comando:
Codice: Seleziona tutto
dpkg -l | grep -i policykit


Se ti manca "policykit-1-gnome", installalo, riavvia e prova a vedere se funziona.
Selky
Prode Principiante
 
Messaggi: 52
Iscrizione: novembre 2011

Re: Debian: wallpaper e gestore pacchetti spariti dopo aggio

Messaggioda Lo Zio » lunedì 13 agosto 2018, 23:56

pachisapiu Immagine ha scritto:no 9.5 al momento è normale , ma se hai avuto problemi su Debian stable dopo aggiornamenti sicuramente hai incasinato le sorgenti software aggiungendo roba non ufficiale

Ti posto il sources.list a cui ho aggiunto contrib e non-free,più il repo per multisystem
Codice: Seleziona tutto
  GNU nano 2.7.4                                    File: /etc/apt/sources.list                                               

# deb cdrom:[Debian GNU/Linux 9.3.0 _Stretch_ - Official amd64 NETINST 20171209-12:10]/ stretch main contrib non-free

# deb cdrom:[Debian GNU/Linux 9.3.0 _Stretch_ - Official amd64 NETINST 20171209-12:10]/ stretch main contrib non-free

deb http://ftp.it.debian.org/debian/ stretch main contrib non-free
deb-src http://ftp.it.debian.org/debian/ stretch main contrib non-free

deb http://security.debian.org/debian-security/ stretch/updates main contrib non-free
deb-src http://security.debian.org/debian-security/ stretch/updates main contrib non-free

# stretch-updates, previously known as 'volatile'
deb http://ftp.it.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://ftp.it.debian.org/debian/ stretch-updates main contrib non-free

## Depôt MultiSystem
deb http://liveusb.info/multisystem/depot all main







^G Guida       ^O Salva       ^W Cerca       ^K Taglia      ^J Giustifica  ^C Posizione   ^Y Pag Prec.   M-\ Prima riga
^X Esci        ^R Inserisci   ^\ Sostituisci ^U Incolla     ^T Ortografia  ^_ Vai a riga  ^V Pag Succ.   M-/ Ultima riga

caturen Immagine ha scritto:per curiosità ho voluto installare in virtualbox debian stabile con xfce. Quando ho avviato il sistema io non riscontro per nulla i tuoi problemi: synaptic si lancia tranquillamente dal menu e il desktop si può modificare tranquillamente ed il menu appare dando tasto destro del mouse sul desktop. Quindi non sono riuscito a confermare i tuoi problemi col sistema, perciò o un qualche bug o il tua sistema lo hai incasinato in qualche modo tu.

a me ha funzionato tutto tranquillamente fino all'altro giorno...poi non so se ho toccato qualcosa io (ma a livello sw,non di aggiornamenti),o se è partito lui di suo.Fatto stà che non avvia più il gestore aggiornamenti,e adesso non riesco neanche ad impostare un wallpaper :muro: tutto funzionante (pure conky,ma sfondo grigio)
Immagine
ALLINONE Immagine ha scritto:
Mi è successo questo: dopo l'ultimo aggiornamento su Debian non ho più la possibilità di impostare uno sfondo al desktop.Mi ritrovo un sfondo grigio e "sembra"che non sia nemmeno cliccabile (tasto dx non avvia nessun menù),selezionando direttamente un' immagine dando "Imposta come sfondo" non si ottiene nessun risultato.

controlla se in sessione e avvio al tab sessione ci sia xfdesktop

l'unica voce che risulta con xfce è Xfsettingsd (Demone delle impostazioni di xfce)
woddy68 Immagine ha scritto:Solitamente per capire se il problema riguarda il sistema o qualche configurazione sballata nel tuo utente, basta creare un nuovo utente, se funziona tutto correttamente il problema è nella tua home, se al contrario anche il nuovo utente soffre gli stessi problemi, significa che il problema sta nel sistema.
Perlomeno così capisci dove eventualmente mettere le mani. Ciao

Allora...qua potrebbe essere un problema di sistema...ma non per colpa di Utente etc.
Ho notato che i problemi HW del pc oggi sono "peggiorati" (per chi non sapesse stò valutando l'idea di cambiare il pc,in quanto datato e ultimamente ho il pc che va e non va.Mi ritrovo con un alimentatore "di riserva" perchè il mio è partito.Sempre a causa dell'alimentatore (forse) ho bruciato l'hd dati e non viene neanche visto da parted -l, l'hd principale su cui risiedono Win e Linux per ora non ha dato segni di "squilibri"...però potrebbe anche essere che a causa dell'alimentatore i dati vadano e non vadano...ma è solo un'ipotesi molto azzardata.
Selky Immagine ha scritto:Buona sera a tutti.

@Lo Zio
per il problema "synaptic" controlla che pacchetti hai installato relativi a policykit; da terminale, anche come utente normale, puoi dare questo comando:
Codice: Seleziona tutto
dpkg -l | grep -i policykit


Se ti manca "policykit-1-gnome", installalo, riavvia e prova a vedere se funziona.

Codice: Seleziona tutto
lozio@debian:~$ dpkg -l | grep -i policykit
ii  cups-pk-helper                       0.2.6-1+b1                              amd64        PolicyKit helper to configure cups with fine-grained privileges
ii  libpolkit-agent-1-0:amd64            0.105-18                                amd64        PolicyKit Authentication Agent API
ii  libpolkit-backend-1-0:amd64          0.105-18                                amd64        PolicyKit backend API
ii  libpolkit-gobject-1-0:amd64          0.105-18                                amd64        PolicyKit Authorization API
ii  libpolkit-qt5-1-1:amd64              0.112.0-5                               amd64        PolicyKit-qt5-1 library
ii  policykit-1                          0.105-18                                amd64        framework for managing administrative policies and privileges
ii  policykit-1-gnome                    0.105-6                                 amd64        authentication agent for PolicyKit
lozio@debian:~$

C'è all'ultima voce.

Chiedo scusa se non rispondo celermente,ma ultimamente stò avendo un sacco di cose da fare al di fuori dell'informatica -.-" (e non sono ferie....).Ringrazio tutti gli Utenti del Forum,che in questa e in mille altre occasioni mi danno supporto nei mille problemi posti sul Forum.
:abbracc:
--> * Indice Wiki * Photoshop su Wine * Cerca su Ubuntu.it *
--> * Script per aggiungere Risolto alle discussioni * <-- Servono a tutti, ricordiamoci di usarli
......ti accorgi che fa caldo quando dai come input "sudo" e il terminale ti da come output "Anche io"
Avatar utente
Lo Zio
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1809
Iscrizione: settembre 2009
Località: Torino
Desktop: xfce / kde-plasma
Distribuzione: Debian 9.4 (stretch) x86_64

Re: Debian: wallpaper e gestore pacchetti spariti dopo aggio

Messaggioda caturen » martedì 14 agosto 2018, 7:32

a me ha funzionato tutto tranquillamente fino all'altro giorno.
dato che usi synaptic per gli aggiornamenti, puoi andare nella sua cronologia e vedi in quel giorno quali aggiornamenti hai fatto e quindi troverai il "responsabile" dei tuoi problemi. È molto probabile che sia policykit-1-gnome l'indiziato principale.
a me ha funzionato tutto tranquillamente fino all'altro giorno..
questa cosa non mi quadra perchè l'iso di debian è stata caricata sui server il 14 luglio e da allora non ci sono stati aggiornamenti del sistema perchè io una volta finita l'installazione sono andato proprio a vedere se ci fossero aggiornamenti, ma non ce ne erano da fare. Quindi dubito che la colpa sia degli aggiornamenti. A meno che tu non faccia gli aggiornamenti a babbo morto.
Ultima modifica di caturen il martedì 14 agosto 2018, 10:11, modificato 2 volte in totale.
caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14493
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: Debian: wallpaper e gestore pacchetti spariti dopo aggio

Messaggioda ALLINONE » martedì 14 agosto 2018, 7:58

l'unica voce che risulta con xfce è Xfsettingsd (Demone delle impostazioni di xfce)

ok, controlla se il pacchetto è installato e aggiungilo a quella lista.
Per il desktop dovresti risolvere.
ALLINONE
Prode Principiante
 
Messaggi: 37
Iscrizione: luglio 2012
Desktop: lxde - xfce
Distribuzione: debian 6 - debian 7

Re: Debian: wallpaper e gestore pacchetti spariti dopo aggio

Messaggioda Selky » martedì 14 agosto 2018, 13:50

caturen Immagine ha scritto:
a me ha funzionato tutto tranquillamente fino all'altro giorno..
questa cosa non mi quadra perchè l'iso di debian è stata caricata sui server il 14 luglio e da allora non ci sono stati aggiornamenti del sistema perchè io una volta finita l'installazione sono andato proprio a vedere se ci fossero aggiornamenti, ma non ce ne erano da fare. Quindi dubito che la colpa sia degli aggiornamenti. A meno che tu non faccia gli aggiornamenti a babbo morto.
Gli aggiornamenti ci sono stati. Uno importante di sicurezza il 6 agosto 2018 relativo al kernel linux-image-4.9.0-7.
Nell'installare dalla iso avrai aggiornato automaticamente durante lo scaricamento dei pacchetti.

Ho appena letto un'altra discussione di LoZio e ho notato che il sistema era bello incasinato da repo vari che avranno sporcato non poco il tutto.
Comunque stando a quanto riportato in precedenza dallo stesso, potrebbe anche essere un problema legato alla macchina e/o a uno dei suoi componenti.
Servirebbero più informazioni che potrebbero essere ottenute con uno script di un altro forum.
Selky
Prode Principiante
 
Messaggi: 52
Iscrizione: novembre 2011

Re: Debian: wallpaper e gestore pacchetti spariti dopo aggio

Messaggioda caturen » martedì 14 agosto 2018, 17:34

Gli aggiornamenti ci sono stati.
si, infatti ho scritto una cavolata perchè non ho considerato che non ho installato la versione live di debian perchè mi dava problemi in virtualbox, ma la netinstall che scarica in pratica quasi tutto il sistema della rete. Quindi per forza che non c'erano aggiornamenti. Comunque, aggiornamenti o no su quella installazione non c'è traccia dei suoi problemi.
EDIT
ho fatto partire la live di debian xfce presa da qui https://cdimage.debian.org/debian-cd/cu ... so-hybrid/ dove si vede che la iso è stata caricata il 14 luglio. Lanciato synaptic per vedere se ci fossero per caso degli aggiornamenti dei pacchetti presenti nella iso e di questi aggiornamenti non c'è traccia, tutto aggiornato. Quindi stando a quello che dice synaptic da quella data ad oggi non ci sono aggiornamenti da fare. :o
caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14493
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: Debian: wallpaper e gestore pacchetti spariti dopo aggio

Messaggioda Lo Zio » mercoledì 15 agosto 2018, 3:25

Aggiornamento:
ho fatto una prova...eliminato il mio Utente e ricreato da zero.
Risultato: wallpaper ricomparsi magicamente (avevo provato a loggarmi come root e ho notato che era tutto ok).
Gestore degli aggiornamenti sempre k.o.,quindi mi viene da pensare: qualquadra negli aggiornamenti non ha funzionato nel modo giusto...
a livello Utente ho risolto (wall ritornato e menù tasto dx ok.) a livello root invece ho ancora il problema del gestore pacchi...quindi risolto al 50%
OT:appena tornato da un bel giretto in bici (sono le 03:25) tanta roba ^^
--> * Indice Wiki * Photoshop su Wine * Cerca su Ubuntu.it *
--> * Script per aggiungere Risolto alle discussioni * <-- Servono a tutti, ricordiamoci di usarli
......ti accorgi che fa caldo quando dai come input "sudo" e il terminale ti da come output "Anche io"
Avatar utente
Lo Zio
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1809
Iscrizione: settembre 2009
Località: Torino
Desktop: xfce / kde-plasma
Distribuzione: Debian 9.4 (stretch) x86_64

Re: Debian: wallpaper e gestore pacchetti spariti dopo aggio

Messaggioda Selky » mercoledì 15 agosto 2018, 13:06

caturen Immagine ha scritto:
EDIT
ho fatto partire la live di debian xfce presa da qui https://cdimage.debian.org/debian-cd/cu ... so-hybrid/ dove si vede che la iso è stata caricata il 14 luglio. Lanciato synaptic per vedere se ci fossero per caso degli aggiornamenti dei pacchetti presenti nella iso e di questi aggiornamenti non c'è traccia, tutto aggiornato. Quindi stando a quello che dice synaptic da quella data ad oggi non ci sono aggiornamenti da fare. :o

Perché nelle live Debian (le altre non le conosco) l'unico repo abilitato è quello base
Codice: Seleziona tutto
deb http://deb.debian.org/debian stretch main
tutti gli altri, compreso quello di sicurezza, devono essere aggiunti. ;)

@Lo Zio
Mi sorge il dubbio che "polkit-gnome-authentication-agent-1" non sia avviato. Prova a postare il risultato del comando (anche come utente normale)
Codice: Seleziona tutto
$ ps aux | grep -v grep | grep policykit


Edit
corretto comando "aux", scusa la svista nello scrivere.
Ultima modifica di Selky il mercoledì 15 agosto 2018, 13:15, modificato 1 volta in totale.
Selky
Prode Principiante
 
Messaggi: 52
Iscrizione: novembre 2011

Re: Debian: wallpaper e gestore pacchetti spariti dopo aggio

Messaggioda Lo Zio » mercoledì 15 agosto 2018, 13:09

Selky Immagine ha scritto:@Lo Zio
Mi sorge il dubbio che "polkit-gnome-authentication-agent-1" non sia avviato. Prova a postare il risultato del comando (anche come utente normale)
Codice: Seleziona tutto
$ ps axu | grep -v grep | grep policykit

ecco il risultato,sembra essere avviato
Codice: Seleziona tutto
lozio@debian:~$ ps axu | grep -v grep | grep policykit
root       503  0.0  0.1 288032  8400 ?        Ssl  11:18   0:00 /usr/lib/policykit-1/polkitd --no-debug
lozio@debian:~$
--> * Indice Wiki * Photoshop su Wine * Cerca su Ubuntu.it *
--> * Script per aggiungere Risolto alle discussioni * <-- Servono a tutti, ricordiamoci di usarli
......ti accorgi che fa caldo quando dai come input "sudo" e il terminale ti da come output "Anche io"
Avatar utente
Lo Zio
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1809
Iscrizione: settembre 2009
Località: Torino
Desktop: xfce / kde-plasma
Distribuzione: Debian 9.4 (stretch) x86_64

Re: [Risolto]wallpaper e gestore pacchetti spariti dopo aggi

Messaggioda Selky » mercoledì 15 agosto 2018, 13:19

@Lo Zio
ho corretto il comando, scusami, comunque ha funzionato ugualmente.

Il problema a quanto pare è che è abilitato solo per l'utente root e non per gli altri utenti.

Edit
scusate ma ho priblemi di connessione e a volte non riesco a editare in tempo i post.

Aggiungo per Lo Zio, controlla con il comando
Codice: Seleziona tutto
$ groups
a quali gruppi appartiene il tuo utente normale (non root)
Ultima modifica di Selky il mercoledì 15 agosto 2018, 13:39, modificato 1 volta in totale.
Selky
Prode Principiante
 
Messaggi: 52
Iscrizione: novembre 2011

Re: [Risolto]wallpaper e gestore pacchetti spariti dopo aggi

Messaggioda caturen » mercoledì 15 agosto 2018, 13:24

tutti gli altri, compreso quello di sicurezza, devono essere aggiunti.
hai ragione. Non ho praticamente mai usato la stabile e quindi non sono "preparato" ai suoi repository. Sempre usato testing e poi sid e lì le cose sono molto più "semplici". Ho pure provato ad installare la live , ma in virtualbox non va oltre la schermata del login manager. Mi appare solo lo sfondo del desktop e niente altro. Il puntatore del mouse si vede ma non funziona nulla. Credo sia un problema di quella iso live: sia la versione a 64 che 32 bit hanno lo stesso identico problema.
ho fatto una prova...eliminato il mio Utente e ricreato da zero.
Risultato: wallpaper ricomparsi magicamente (avevo provato a loggarmi come root e ho notato che era tutto ok).
avevi sballato qualche impostazione nella tua home. Per quanto riguarda synaptic anche a me è capitato qualche volta durante gli anni che la voce nel menu di synaptic avesse il tuo stesso problema. La cosa si risolveva poi con ulteriori aggiornamenti. Nel frattempo io cambiavo il comando impostato nel menu per far partire synaptic. Potresti provare a cambiarlo se proprio ti da fastidio fare gli aggiornamenti col terminale.
caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14493
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: [Risolto]wallpaper e gestore pacchetti spariti dopo aggi

Messaggioda Lo Zio » mercoledì 15 agosto 2018, 13:40

Per quanto riguarda synaptic anche a me è capitato qualche volta durante gli anni che la voce nel menu di synaptic avesse il tuo stesso problema. La cosa si risolveva poi con ulteriori aggiornamenti. Nel frattempo io cambiavo il comando impostato nel menu per far partire synaptic. Potresti provare a cambiarlo se proprio ti da fastidio fare gli aggiornamenti col terminale.

prova già fatta.Visto che il Gestore non avviava,ho aperto il menù e guardato il comando (che non conoscevo).Il risultato è che stesso comando,da Terminale funziona,dalanciatore no.Potrei fare una prova ulteriore ora che ci penso...creare un nuovo lanciatore e vedere se funziona.
Non che sia un grosso problema lanciarlo da terminale...però un pò mi "sfastidia"avere un lanciatore farlocco
EDIT:
per il comando da terminale ottengo sempre lo stesso errore:
Codice: Seleziona tutto
lozio@debian:~$ synaptic-pkexec
==== AUTHENTICATING FOR com.ubuntu.pkexec.synaptic ===
Authentication is required to run the Synaptic Package Manager
Authenticating as: root
Password:
polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie
==== AUTHENTICATION FAILED ===
Error executing command as another user: Not authorized

This incident has been reported.
lozio@debian:~$ su
Password:
bash: /root/.bashrc: riga 1: errore di sintassi vicino al token non atteso "("
bash: /root/.bashrc: riga 1: `# ~/.bashrc: executed by bash(1) for non-login shells.'
root@debian:/home/lozio# synaptic-pkexec
root@debian:/home/lozio#

stavo notando gli output:
PolicyKit1.Error.Failed: No session for cookie

e
Codice: Seleziona tutto
Error executing command as another user: Not authorized

non accetta i cookie e non permette l'esecuzione come altro user?Problemi di permessi magari?
--> * Indice Wiki * Photoshop su Wine * Cerca su Ubuntu.it *
--> * Script per aggiungere Risolto alle discussioni * <-- Servono a tutti, ricordiamoci di usarli
......ti accorgi che fa caldo quando dai come input "sudo" e il terminale ti da come output "Anche io"
Avatar utente
Lo Zio
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1809
Iscrizione: settembre 2009
Località: Torino
Desktop: xfce / kde-plasma
Distribuzione: Debian 9.4 (stretch) x86_64

Re: [Risolto]wallpaper e gestore pacchetti spariti dopo aggi

Messaggioda Selky » mercoledì 15 agosto 2018, 13:53

Cortesemente puoi postare il comando che ti ho richiesto sopra?
Codice: Seleziona tutto
$ groups


Il problema è che policytkit non è abilitato per il tuo utente e quindi ti da errore. Usi sudo quindi vorrei capire se il tuo utente è nel gruppo e se basta avviare policykit per risolvere.
Selky
Prode Principiante
 
Messaggi: 52
Iscrizione: novembre 2011

Successiva

Torna a Altre distribuzioni e sistemi operativi

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 1 ospite