errore nella compilazione di warzone2100 3.2.3

Un'area dove scambiarsi informazioni riguardanti l'uso di Ubuntu per giocare. Segnalazione di nuovi giochi e di problemi riscontrati.

errore nella compilazione di warzone2100 3.2.3

Messaggioda zampo » domenica 16 settembre 2018, 11:48

Ciao a tutti,
vorrei installare la versione di warzone2100 3.2.3 tramite sorgenti perchè le precedenti mi danno errore nel caricamento delle partite salvate. Però nel compilare ricevo questo messaggio di errore
Codice: Seleziona tutto
checking for FREETYPE... configure: error: Package requirements (freetype2) were not met:

No package 'freetype2' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables FREETYPE_CFLAGS
and FREETYPE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Ho provato a cercare soluzioni con google e ad installare diversi tools per Freetype2, senza risolvere. Non sono così scafato da mettere mano a pkg-config come consiglia il messaggio e non so come risolvere questo intoppo. Ho provato anche così:
Codice: Seleziona tutto
sudo apt-get install freetype2-demos
[sudo] password di daniele:
Lettura elenco dei pacchetti... Fatto
E: Il valore "xenial" non è valido per APT::Default-Release poiché tale release non è disponibile dalle sorgenti

Utilizzo LinuxMint19 Tara, che si appoggia ad Ubuntu 18.04 LTS Bionic Beaver

Avete qualche suggerimento?

Grazie
Daniele Z. - Linux user # 404412 - Ubuntu user # 17027
[Sto lavorando duro per preparare il mio prossimo errore - Bertolt Brecht]
Avatar utente
zampo
Prode Principiante
 
Messaggi: 125
Iscrizione: luglio 2006
Località: provincia di Bologna

Re: errore nella compilazione di warzone2100 3.2.3

Messaggioda steff » domenica 16 settembre 2018, 21:55

libfreetype6-dev è installato?
Hai fatto il backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox
Avatar utente
steff
Moderatore Globale
Moderatore Globale
 
Messaggi: 37019
Iscrizione: febbraio 2007
Località: Toscana
Desktop: LXQt
Distribuzione: Arch Linux 64bit
Sesso: Maschile

Re: errore nella compilazione di warzone2100 3.2.3

Messaggioda zampo » lunedì 17 settembre 2018, 20:46

steff Immagine ha scritto:libfreetype6-dev è installato?


Sai che non posso saperlo? Credo di sì, ma ora mi trovo che apt-get mi si è incasinato e mi dà questo messaggio
Codice: Seleziona tutto
Il valore "xenial" non è valido per APT::Default-Release poiché tale release non è disponibile dalle sorgenti

:o
credo di aver fatto qualche danno, sto cercando soluzioni sul web :cry:
Daniele Z. - Linux user # 404412 - Ubuntu user # 17027
[Sto lavorando duro per preparare il mio prossimo errore - Bertolt Brecht]
Avatar utente
zampo
Prode Principiante
 
Messaggi: 125
Iscrizione: luglio 2006
Località: provincia di Bologna

Re: errore nella compilazione di warzone2100 3.2.3

Messaggioda zampo » lunedì 17 settembre 2018, 21:22

steff Immagine ha scritto:libfreetype6-dev è installato?


E' installato libfreetype6 non la versione -dev per sviluppatori
Daniele Z. - Linux user # 404412 - Ubuntu user # 17027
[Sto lavorando duro per preparare il mio prossimo errore - Bertolt Brecht]
Avatar utente
zampo
Prode Principiante
 
Messaggi: 125
Iscrizione: luglio 2006
Località: provincia di Bologna

Re: errore nella compilazione di warzone2100 3.2.3

Messaggioda steff » lunedì 17 settembre 2018, 21:33

Beh,stai compilando ci vuole -dev
Hai fatto il backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox
Avatar utente
steff
Moderatore Globale
Moderatore Globale
 
Messaggi: 37019
Iscrizione: febbraio 2007
Località: Toscana
Desktop: LXQt
Distribuzione: Arch Linux 64bit
Sesso: Maschile

Re: errore nella compilazione di warzone2100 3.2.3

Messaggioda zampo » martedì 18 settembre 2018, 17:20

steff Immagine ha scritto:Beh,stai compilando ci vuole -dev


Già. Hai ragione ... Adesso però devo cercare di risolvere il problema di accesso di apt ... ci risentiamo.

Per ora Grazie
Daniele Z. - Linux user # 404412 - Ubuntu user # 17027
[Sto lavorando duro per preparare il mio prossimo errore - Bertolt Brecht]
Avatar utente
zampo
Prode Principiante
 
Messaggi: 125
Iscrizione: luglio 2006
Località: provincia di Bologna


Torna a Videogiochi

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 3 ospiti