Problema con CUPS su portatile ubuntu

Networking, configurazione della connessione, periferiche e condivisione di rete, ecc.

Re: Problema con CUPS su portatile ubuntu

Messaggioda vga-0 » sabato 5 gennaio 2019, 8:43

Avevo inserito:

Codice: Seleziona tutto
http://192.168.0.100:631/printers/HPLaserJetP1102



Ho inserito:

Codice: Seleziona tutto
http://192.168.0.100:631/printers/Hewlett-Packard-HP-LaserJet-Professional-P1102


P.S. Ho seguito le tue istruzioni ma ancora mi dice nome non corretto.
vga-0
Prode Principiante
 
Messaggi: 103
Iscrizione: dicembre 2018

Re: Problema con CUPS su portatile ubuntu

Messaggioda thece » sabato 5 gennaio 2019, 12:37

Credo che esistano dei limiti al nome che si possa assegnare ad una stampante, non ricordo esattamente quali, comunque io procederei a rinominarla ed ad assegnarle un nome più "umano": HPLaserJetP1102 va benissimo. Utilizzando il pannello di controllo Web di CUPS, cancella e ricrea la configurazione della stampante.

Per il resto, posta l'output di

Codice: Seleziona tutto
sudo netstat -tulnp | grep -i cups
sudo iptables-save
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 10455
Iscrizione: aprile 2007
Distribuzione: Debian 10 (Buster) - KDE

Re: Problema con CUPS su portatile ubuntu

Messaggioda vga-0 » sabato 5 gennaio 2019, 14:54

Ho rimosso la stampante "vecchia" e l'ho riaggiunta con un nome più umano,
ed ora non stampa neppure da locale.
Ecco i risultati:

netstat -tulnp | grep -i cups
Codice: Seleziona tutto
tcp        0      0 0.0.0.0:631             0.0.0.0:*               LISTEN      700/cupsd           
tcp6       0      0 :::631                  :::*                    LISTEN      700/cupsd           
udp        0      0 0.0.0.0:631             0.0.0.0:*                           750/cups-browsed   



iptables-save
Codice: Seleziona tutto
# Generated by iptables-save v1.6.1 on Sat Jan  5 14:47:56 2019
*nat
:PREROUTING ACCEPT [28:2889]
:INPUT ACCEPT [15:1758]
:OUTPUT ACCEPT [2156:162183]
:POSTROUTING ACCEPT [2148:158355]
-A POSTROUTING -s 192.168.0.0/24 ! -d 192.168.0.0/24 -j MASQUERADE
COMMIT
# Completed on Sat Jan  5 14:47:56 2019
vga-0
Prode Principiante
 
Messaggi: 103
Iscrizione: dicembre 2018

Re: Problema con CUPS su portatile ubuntu

Messaggioda thece » sabato 5 gennaio 2019, 15:26

vga-0 Immagine ha scritto:Ho rimosso la stampante "vecchia" e l'ho riaggiunta con un nome più umano,
ed ora non stampa neppure da locale.

Riprova finchè non riesci a stampare da locale. Questo è sempre il primo punto che deve funzionare.

Gli output che hai postato vanno bene.

Testiamo la connessione da Windows XP verso il server CUPS. Prova ad usare il client telnet per connetterti

Codice: Seleziona tutto
telnet 192.168.0.100 631

Se la connessione ha successo usa la combinazione CTRL + C per terminarla.
Non ricordo se su Windows XP il client telnet è installato di default, nel caso installalo. Su Google trovi sicuramente le istruzioni per farlo.
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 10455
Iscrizione: aprile 2007
Distribuzione: Debian 10 (Buster) - KDE

Re: Problema con CUPS su portatile ubuntu

Messaggioda vga-0 » domenica 13 gennaio 2019, 10:38

Ho pingato da entrambe le parti ed è tutto ok.
Ho dato:
Codice: Seleziona tutto
tenet 192.168.0.100 631


ed ottengo:
Codice: Seleziona tutto
Impossibile aprire una connessione con l'host sulla porta 631.


l'ip sopra è quello di CUPS.
vga-0
Prode Principiante
 
Messaggi: 103
Iscrizione: dicembre 2018

Re: Problema con CUPS su portatile ubuntu

Messaggioda vga-0 » domenica 13 gennaio 2019, 11:12

Ho tolto la stampante con la tua sfilza di comandi di qualche post fa.
Ho poi riaggiunto la stampante con il nome HPP1102 (nome abbastanza umano), una volta terminata la procedura
provo a stampare da locale ma non funziona, non stampa niente.
Ho aggiunto la stampante da winXp con lo stesso nome ed è andato a buon fine ma non stampa neppure da lì naturalmente.
Le macchine si pingano a vicenda, ma se do telnet 192.168.0.100:631 non si connette.
Perchè succede questo?
vga-0
Prode Principiante
 
Messaggi: 103
Iscrizione: dicembre 2018

Re: Problema con CUPS su portatile ubuntu

Messaggioda thece » lunedì 14 gennaio 2019, 16:17

Evidentemente non sono capace di farmi capire da te, spero che tu abbia più fortuna con qualche altro utente.
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 10455
Iscrizione: aprile 2007
Distribuzione: Debian 10 (Buster) - KDE

Precedente

Torna a Connessione e configurazione delle reti

Chi c’è in linea

Visualizzano questa sezione: james bong e 8 ospiti