Sovrascrittura opzioni apache2

Installazione, configurazione e uso di Ubuntu come server: web, ftp, mail, news, proxy, dns, ecc.

Sovrascrittura opzioni apache2

Messaggioda Sam9999 » lunedì 31 dicembre 2018, 18:33

Ho un problema con prestashop, in pratica siccome il server apache non permette la sovrascrittura della seguente opzione (in generale non fa sovrascrivere le opzioni e le vuole settate in /etc/apache2/apache2.conf)

Codice: Seleziona tutto
<Directory /var/www/>
        Options FollowSymLinks MultiViews
        AllowOverride FileInfo Indexes Authconfig Limit
        Require all granted
</Directory>


Ora in prestashop nel .htaccess del lato admin mi vuole sovrascrivere la opzione multiviews, se non la commento mi da errore 500.
Codice: Seleziona tutto
# <IfModule mod_negotiation.c>
#     Options -MultiViews
# </IfModule>


Allora in installazione, una volta completata edito il file .htaccess commento le linee e prestashop funziona.
Il problema è in upgrade, in quanto con la procedura guidata 1-click-upgrade, una volta finito il backup va a sovrascrivere .htaccess e andando poi in errore 500 non continua la upgrade, nello stesso tempo se non gli permetto di sovrascrivere non continua l'aggiornamento, dando errore.

Quindi ora o elimino l'opzione da /etc/apache2/apache2.conf oppure devo permetterne la sovrascrittura, dove trovo l'opzione per farlo ?
Anche solo momentaneamente per fare le upgrade.
Ho gia provato a fare manualmente ma non riesco a upgradare e devo sempre fare nuova installazione.

Non funziona nemmeno dando "AllowOverride All" o eliminando l'opzione MultiViews, in entrambi i casi se poi ripristino le linee commentate in htaccess mi rende l'errore 500

ora ho anche cambiato così in apache2.conf

Codice: Seleziona tutto
<Directory /var/www/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride All Options=MultiViews
        Require all granted
</Directory>


Ma se poi decommento in .htaccess vado sempre in errore 500

In una nuova installazione sotto altro dominio per prova, non mi da più errore 500 anche senza avere cambiato il file .htaccess.
Pare quindi che la modifica funziona ma sul nuovo dominio, sulla installazione precedente invece continua a dare errore se lascio il file .htaccess originale di prestashop.

Queste le opzioni in apache2.conf
Codice: Seleziona tutto
<Directory /var/www/>
        Options Indexes FollowSymLinks MultiViews
#       AllowOverride FileInfo Indexes Authconfig Limit
        AllowOverride All Options=All,MultiViews
        Require all granted
        Order allow,deny
        allow from all
</Directory>


In ultimo aggioranmento ho quindi preso l'installazione aggiornata di prestashop sul secondo dominio, poi ci ho copiato su l'sql delal prima instalalzione, rinominata la cartella e cambiato dominio con phpmyadmin, adesso pestrashop funziona e l'htaccess non l'ho commentato peril multiviews.

Magari la seconda installazione fatta con già la nuova configurazione ha preso qualche parametro che adesso gli permette la sovrascrittura.

Però non sono tanto convinto di avere messo quel: "AllowOverride All " che non sia pericoloso per apache.... :nono:
-------------
S. @-M.
-------------
Avatar utente
Sam9999
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1774
Iscrizione: giugno 2014
Località: BO
Desktop: Studio Xfce
Distribuzione: Ubuntu 19.04 (Disco Dingo)

Torna a Ubuntu su server

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 5 ospiti