Problemi su installazione Ubuntu 18.4

Problemi riscontrati durante l'installazione di Ubuntu, degli aggiornamenti e degli avanzamenti del sistema.

Problemi su installazione Ubuntu 18.4

Messaggioda highrisk » domenica 13 gennaio 2019, 20:57

Ciao a tutti.
Ho aggiornato Ubuntu passando dalla versione 16 alla 18.4. Durante la fase di aggiornamento si sono verificati degli errori su circa 30 - 40 pacchetti. Per tutti mi rispondeva che non era possibile installarli. In realtà la versione 18.4 sembra funzionare ma appena avviato compare in alto a destra un segnale rosso (tipo divieto di accesso) e cliccandoci su scrive"Si è verificato un errore. Per ulteriori informazioni sull'errore avviare il gestore pacchetti tramite il menù richiamabile con un clic del tasto destro del mouse, oppure dare il comando apt_get da terminale. Il messaggio di errore è:"Errore:BrokenCount > 0". Di solito questo significa che i pacchetti installati presentano delle dipendenze irrisolte."


Inoltre dovrei fare degli aggiornamenti ma compare il seguente errore"Il sistema pacchetti è danneggiato
Verificare se sono in uso repository di terze parti. Qualora così fosse, disabilitarli, poiché questi sono talvolta causa di problemi.
Inoltre eseguire il seguente comando in un terminale: apt-get install -f
Transaction failed: Il sistema di pacchetti è danneggiato
I seguenti pacchetti presentano dipendenze non soddisfatte:

libpam-modules: PreDepends: libaudit1 (>= 1:2.2.1) ma 1:2.8.2-1ubuntu1 è installato
PreDepends: libc6 (>= 2.15) ma 2.27-3ubuntu1 è installato
PreDepends: libselinux1 (>= 2.1.9) ma 2.7-2build2 è installato
PreDepends: libpam-modules-bin (= 1.1.8-3.2ubuntu2.1) ma 1.1.8-3.6ubuntu2 è installato"
Potete aiutarmi???

:cry: :cry:
highrisk
Prode Principiante
 
Messaggi: 23
Iscrizione: aprile 2018

Re: Problemi su installazione Ubuntu 18.4

Messaggioda caturen » domenica 13 gennaio 2019, 21:03

posta
Codice: Seleziona tutto
sudo apt update
e
Codice: Seleziona tutto
sudo apt upgrade
caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 14802
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: Problemi su installazione Ubuntu 18.4

Messaggioda highrisk » martedì 15 gennaio 2019, 20:52

Al comando sudo apt update risponde:

Codice: Seleziona tutto
Errore:1 http://security.ubuntu.com/ubuntu bionic-security InRelease
  Impossibile risolvere "security.ubuntu.com"
Errore:2 http://archive.ubuntu.com/ubuntu bionic InRelease                 
  Impossibile risolvere "archive.ubuntu.com"
Errore:3 http://archive.canonical.com/ubuntu bionic InRelease             
  Impossibile risolvere "archive.canonical.com"
Errore:4 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
  Impossibile risolvere "archive.ubuntu.com"
Errore:5 http://archive.ubuntu.com/ubuntu bionic-backports InRelease
  Impossibile risolvere "archive.ubuntu.com"
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
1 pacchetto può essere aggiornato: eseguire "apt list --upgradable" per vederlo.
W: Impossibile recuperare http://archive.ubuntu.com/ubuntu/dists/bionic/InRelease  Impossibile risolvere "archive.ubuntu.com"
W: Impossibile recuperare http://archive.ubuntu.com/ubuntu/dists/bionic-updates/InRelease  Impossibile risolvere "archive.ubuntu.com"
W: Impossibile recuperare http://security.ubuntu.com/ubuntu/dists/bionic-security/InRelease  Impossibile risolvere "security.ubuntu.com"
W: Impossibile recuperare http://archive.ubuntu.com/ubuntu/dists/bionic-backports/InRelease  Impossibile risolvere "archive.ubuntu.com"
W: Impossibile recuperare http://archive.canonical.com/ubuntu/dists/bionic/InRelease  Impossibile risolvere "archive.canonical.com"
W: Impossibile scaricare alcuni file di indice: saranno ignorati o verranno usati quelli vecchi.


mentre al comando sudo apt upgrade risponde:

Codice: Seleziona tutto
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt --fix-broken install" per correggere ciò.
I seguenti pacchetti hanno dipendenze non soddisfatte:
 libpam-modules : Pre-dipende: libpam-modules-bin (= 1.1.8-3.2ubuntu2.1)
                  Raccomanda: update-motd ma non è installato
E: Dipendenze non soddisfatte. Provare "apt --fix-broken install" senza pacchetti (o specificare una soluzione).


Grazie!
highrisk
Prode Principiante
 
Messaggi: 23
Iscrizione: aprile 2018

Re: Problemi su installazione Ubuntu 18.4

Messaggioda giulux » martedì 15 gennaio 2019, 21:37

Intanto dai il comando che ti suggerisce
Codice: Seleziona tutto
sudo apt --fix-broken install
e posta qui il risultato.
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...
Avatar utente
giulux
Amministratore
Amministratore
 
Messaggi: 22389
Iscrizione: gennaio 2010
Località: Roma
Desktop: xubuntu - ubuntu 18.04
Distribuzione: Ubuntu+Xubuntu 18.04.1 LTS x86_64
Sesso: Maschile

Re: Problemi su installazione Ubuntu 18.4

Messaggioda highrisk » mercoledì 16 gennaio 2019, 11:53

Al comando sudo apt --fix-broken install ha risposto:

Codice: Seleziona tutto
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  account-plugin-facebook account-plugin-flickr account-plugin-google
  app-install-data apt-transport-https espeak-data ethtool
  evolution-data-server-online-accounts flashplugin-installer g++-5
  gconf-service gconf-service-backend gconf2 gconf2-common hardening-includes
  hwdata imagemagick-common libaccount-plugin-1.0-0
  libaccount-plugin-generic-oauth libaccount-plugin-google libaccounts-qt5-1
  libandroid-properties1 libapparmor-perl libappindicator1 libappstream3
  libass5 libavcodec-ffmpeg56 libavfilter-ffmpeg5 libavformat-ffmpeg56
  libavresample-ffmpeg2 libavutil-ffmpeg54 libbabeltrace-ctf1 libbind9-140
  libbluray1 libboost-date-time1.58.0 libboost-filesystem1.58.0
  libboost-iostreams1.58.0 libboost-system1.58.0 libcamel-1.2-54
  libcapnp-0.5.3 libcapnp-0.6.1 libcdio-cdda1 libcdio-paranoia1 libcdio13
  libcgmanager0 libchromaprint0 libcolamd2.9.1 libcurl3 libdata-alias-perl
  libdbusmenu-gtk4 libdirectfb-1.2-9 libdns162 libebook-1.2-16
  libedataserver-1.2-21 libedataserverui-1.2-1 libespeak1 libevent-2.0-5
  libfcitx-gclient0 libfreerdp-cache1.1 libfreerdp-client1.1
  libfreerdp-codec1.1 libfreerdp-common1.1.0 libfreerdp-core1.1
  libfreerdp-crypto1.1 libfreerdp-gdi1.1 libfreerdp-locale1.1
  libfreerdp-plugins-standard libfreerdp-primitives1.1 libfreerdp-utils1.1
  libfwupd1 libgconf-2-4 libgcr-3-common libgdbm3 libglew1.13 libgmime-2.6-0
  libgnome-desktop-3-12 libgom-1.0-common libgrilo-0.2-1 libgtkglext1
  libgtkspell3-3-0 libgtop-2.0-10 libgweather-3-6 libhardware2 libhud2
  libhunspell-1.3-0 libhybris libhybris-common1 libical1a libindicator7
  libisc160 libisccc140 libisccfg140 libiso9660-10 libiso9660-8 libjasper1
  liblircclient0 liblivemedia50 libllvm3.8 libllvm4.0 libllvm5.0 liblouis9
  liblouisutdml6 liblwres141 libmedia1 libmimic0 libmirclient9 libmircommon5
  libmircommon7 libmircore1 libmirprotobuf3 libmpfr4 libnm-glib-vpn1
  libnm-gtk-common libnma-common libopencv-calib3d2.4v5 libopencv-contrib2.4v5
  libopencv-core2.4v5 libopencv-features2d2.4v5 libopencv-flann2.4v5
  libopencv-highgui2.4v5 libopencv-imgproc2.4v5 libopencv-legacy2.4v5
  libopencv-ml2.4v5 libopencv-objdetect2.4v5 libopencv-video2.4v5 libopenjpeg5
  liborcus-0.10-0v5 libp11-kit-gnome-keyring libpackagekit-glib2-16
  libpango1.0-0 libpangox-1.0-0 libpcre16-3 libpodofo0.9.3 libpoppler58
  libpostproc-ffmpeg53 libprotobuf-lite9v5 libprotobuf9v5 libpython3.5
  libqmi-glib1 libqpdf17 libqt5clucene5 libqt5feedback5 libqt5multimedia5
  libqt5opengl5 libqt5organizer5 libqt5quicktest5 libquvi-scripts libquvi7
  libraw15 libreoffice-gtk libreoffice-gtk2 librhythmbox-core9
  libschroedinger-1.0-0 libsignon-extension1 libsignon-plugins-common1
  libsignon-qt5-1 libsodium18 libsrtp0 libstdc++-5-dev
  libsuitesparseconfig4.4.6 libswresample-ffmpeg1 libswscale-ffmpeg3 libtbb2
  libtracker-sparql-1.0-0 libtxc-dxtn-s2tc0 libunistring0 libunity-action-qt1
  libva-drm1 libva-x11-1 libva1 libvcdinfo0 libvpx3 libwebp5 libwebpdemux1
  libwebpmux1 libwebrtc-audio-processing-0 libwildmidi1 libwinpr-crt0.1
  libwinpr-dsparse0.1 libwinpr-environment0.1 libwinpr-file0.1
  libwinpr-handle0.1 libwinpr-heap0.1 libwinpr-input0.1
  libwinpr-interlocked0.1 libwinpr-library0.1 libwinpr-path0.1
  libwinpr-pool0.1 libwinpr-registry0.1 libwinpr-rpc0.1 libwinpr-sspi0.1
  libwinpr-synch0.1 libwinpr-sysinfo0.1 libwinpr-thread0.1 libwinpr-utils0.1
  libx264-148 libx265-79 libx86-1 libxapian22v5 libxcb-composite0 libxfont1
  linux-headers-4.4.0-140 linux-headers-4.4.0-140-generic
  linux-image-4.4.0-140-generic linux-image-extra-4.4.0-140-generic
  oxideqt-codecs-extra pkg-config plainbox-provider-checkbox
  plainbox-provider-resource-generic plainbox-secure-policy pm-utils
  pyotherside python-beautifulsoup python3-checkbox-support python3-guacamole
  python3-jinja2 python3-padme python3-plainbox python3-pyasn1 python3-pycurl
  python3-pyparsing python3-xlsxwriter qml-module-io-thp-pyotherside
  qml-module-qt-labs-folderlistmodel qml-module-qt-labs-settings
  qml-module-qtfeedback qml-module-qtgraphicaleffects
  qml-module-qtquick-layouts qml-module-qtquick-window2 qml-module-qtquick2
  qml-module-qttest qml-module-qtwebkit qml-module-ubuntu-onlineaccounts
  qml-module-ubuntu-performancemetrics qmlscene qtdeclarative5-accounts-plugin
  qtdeclarative5-dev-tools qtdeclarative5-qtquick2-plugin
  qtdeclarative5-test-plugin qtdeclarative5-unity-action-plugin rename
  signon-keyring-extension signon-plugin-oauth2 signon-plugin-password
  signon-ui signon-ui-service signon-ui-x11 signond snap-confine
  snapd-login-service suru-icon-theme tcpd ubuntu-core-launcher
  ubuntu-mobile-icons ubuntu-ui-toolkit-theme unity-control-center-signon
  unity-scope-gdrive vbetool xml-core
Usare "sudo apt autoremove" per rimuoverli.
I seguenti pacchetti aggiuntivi saranno inoltre installati:
  libpam-modules
Pacchetti raccomandati:
  update-motd
I seguenti pacchetti saranno aggiornati:
  libpam-modules
1 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.
È necessario scaricare 0 B/242 kB di archivi.
Dopo quest'operazione, verranno liberati 7.168 B di spazio su disco.
Continuare? [S/n] S
Preconfigurazione dei pacchetti in corso
(Lettura del database... 229011 file e directory attualmente installati.)
Preparativi per estrarre .../libpam-modules_1.1.8-3.6ubuntu2_amd64.deb...
Estrazione di libpam-modules:amd64 (1.1.8-3.6ubuntu2) su (1.1.8-3.2ubuntu2.1)...
Configurazione di libpam-modules:amd64 (1.1.8-3.6ubuntu2)...
Installazione della nuova versione del file di configurazione /etc/security/namespace.init...
Elaborazione dei trigger per man-db (2.8.3-2ubuntu0.1)...



Ho fatto l'aggiornamento e per ora sembra che non ci siano errori.

Grazie mille!!! :D :D
Però se posso ti chiedo ancora una cosa.
Sono passato dalla versione 16 alla 18 perchè sulla versione precedente non siamo riusciti a far funzionare la scheda dati (vedi altra mia richiesta di aiuto).
Il collegamento con ethernet funziona bene ma con la scheda dati che ho nel portatile non riesco a collegarmi, mentre se avvio il portatile con windows 10 il collegamento con la scheda funziona benissimo.
Hai dei suggerimenti???
highrisk
Prode Principiante
 
Messaggi: 23
Iscrizione: aprile 2018

Re: Problemi su installazione Ubuntu 18.4

Messaggioda giulux » mercoledì 16 gennaio 2019, 12:16

Hai dei suggerimenti???
Purtroppo no.
Ti consiglio di fare pulizia, se non già fatta, di tutti quei file superstiti con
Codice: Seleziona tutto
sudo apt autoremove
Ciao.
con l'aiuto della comunità le cose si mettono quasi sempre a posto (e non apposto), a parte (e non apparte) qualche caso ...
Avatar utente
giulux
Amministratore
Amministratore
 
Messaggi: 22389
Iscrizione: gennaio 2010
Località: Roma
Desktop: xubuntu - ubuntu 18.04
Distribuzione: Ubuntu+Xubuntu 18.04.1 LTS x86_64
Sesso: Maschile


Torna a Installazione e aggiornamento del sistema operativo

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 4 ospiti