[Risolto]Errore nell'installazione di grub

Problemi riscontrati durante l'installazione di Ubuntu, degli aggiornamenti e degli avanzamenti del sistema.

[Risolto]Errore nell'installazione di grub

Messaggioda Nickshw » giovedì 7 febbraio 2019, 17:26

Ho installato Ubuntu 18.04 64bit su un mini pc con processore Atom Z3736F e bios UEFI 32bit. L'installazione è riuscita tranne grub, attualmente per fare il boot uso una chiavetta usb con supergrubdisk2.
Ho provato sia Boot repair disk, che grub customizer per reinstallare grub ma nulla.
Se provo grub install ottengo questo messaggio:
sudo grub-install
Installazione per la piattaforma i386-efi.
Could not prepare Boot variable: No space left on device
grub-install: errore: efibootmgr failed to register the boot entry: Errore di input/output.

Mentre boot repair mi da locked-esp.
Anche le distro 32bit non installano grub.

Qualche suggerimento?
Ultima modifica di Nickshw il lunedì 18 febbraio 2019, 16:17, modificato 1 volta in totale.
Nickshw
Prode Principiante
 
Messaggi: 138
Iscrizione: aprile 2005

Re: Errore nell'installazione di grub

Messaggioda Marym » giovedì 7 febbraio 2019, 18:14

Secondo me dovresti provare a installare una a 64 bit il tuo processore lo supporta https://ark.intel.com/it/products/82115 ... -2-16-GHz-
Il pc ha Windows installato, o era senza OS?
Il partizionamento è gpt (te ne accorgi da una piccola partizione all'inizio del disco in FAT32 efi o esp)?
Oppure è mbr (bios legacy mode)?
Pentium G4600 - 8 GB RAM - hdd 1TB 7200 rpm
Avatar utente
Marym
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 584
Iscrizione: novembre 2012
Desktop: gnome
Distribuzione: Ubuntu 18.04 Mint 18 Manjaro 18 kde
Sesso: Femminile

Re: Errore nell'installazione di grub

Messaggioda steff » giovedì 7 febbraio 2019, 18:35

Codice: Seleziona tutto
Could not prepare Boot variable: No space left on device
Hai letto cosa ti dice?

Non ho mai usato efi ma mi sa che questa partizione in fat32 è piena. Controlla

Codice: Seleziona tutto
df -h
Hai fatto il backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox
Avatar utente
steff
Moderatore Globale
Moderatore Globale
 
Messaggi: 37961
Iscrizione: febbraio 2007
Località: Toscana
Desktop: LXQt
Distribuzione: Arch Linux 64bit
Sesso: Maschile

Re: Errore nell'installazione di grub

Messaggioda Nickshw » giovedì 14 febbraio 2019, 11:05

Facendo varie prove solo lubuntu 16.04 64bit (modificata con isorespin.sh) mi ha installato grub correttamente, ora l'unico problema è che non riesco a modificare la priorità del boot nel bios per far partire ubuntu prima di windows. Non riesco a salvare la modifica della priorità.

Qualche suggerimento?
Grazie
Nickshw
Prode Principiante
 
Messaggi: 138
Iscrizione: aprile 2005

Re: Errore nell'installazione di grub

Messaggioda caturen » giovedì 14 febbraio 2019, 11:24

caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 15171
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: Errore nell'installazione di grub

Messaggioda Nickshw » giovedì 14 febbraio 2019, 11:34

Non intendevo l'ordine dei sistemi in grub, non riesco a mettere grub prima di windows boot manager in bios. Lo sposto sopra ma non mi salva il cambiamento nel bios.
Nickshw
Prode Principiante
 
Messaggi: 138
Iscrizione: aprile 2005

Re: Errore nell'installazione di grub

Messaggioda willy54 » giovedì 14 febbraio 2019, 12:51

Hai installato in modalità Uefi o Legacy/Csm.?
Hai disattivato Avvio Rapido in Windows 10 ?
Come hai fatto il supporto di installazione?
Windows è in versione 32Bit o 64Bit ?
Quanta ram hai ? Non centra con la posizione di grub , ma è importante per il funzionamento del complessivo.
Solo rispondendo alle domande si può arrivare ad una soluzione.
@Marym
tutti i processori costruiti dopo il 2001 supportano il 64 bit , ma non i chipset e la ram .
Toshiba Satellite A660 11M Intel® Core™ i7 CPU Q 720 @ 1.60GHz × 8, SSD 250 gb + hdd 500 gb ram 2x4 Gb : Win7 - Win10 - Ubuntu 18.04 LTS - Kubuntu 18.04 LTS gparted sda inxi -Fz
Hp Pavilon 15-CS2093nl Win10 ----- disattivare Avvio rapido in Windows10
Avatar utente
willy54
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3161
Iscrizione: dicembre 2017
Località: Castell'Alfero (AT)
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile

Re: Errore nell'installazione di grub

Messaggioda Marym » giovedì 14 febbraio 2019, 14:49

Nickshw Immagine ha scritto:Non intendevo l'ordine dei sistemi in grub, non riesco a mettere grub prima di windows boot manager in bios. Lo sposto sopra ma non mi salva il cambiamento nel bios.


Hai fatto 'salva ed esci' dopo aver modificato l'ordine sul bios uefi? E' banale ma visto che non lo ha già chiesto Willy54...

PS: Willy, ti chiedo chiarimenti in mp al riguardo.
Pentium G4600 - 8 GB RAM - hdd 1TB 7200 rpm
Avatar utente
Marym
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 584
Iscrizione: novembre 2012
Desktop: gnome
Distribuzione: Ubuntu 18.04 Mint 18 Manjaro 18 kde
Sesso: Femminile

Re: Errore nell'installazione di grub

Messaggioda Nickshw » giovedì 14 febbraio 2019, 16:28

Si fatto salva ed esci, ma al riavvio non è cambiato nulla. Per fare il boot per ora premo F7 e seleziono ubuntu altrimenti parte la prima Windows.
Nickshw
Prode Principiante
 
Messaggi: 138
Iscrizione: aprile 2005

Re: Errore nell'installazione di grub

Messaggioda andrea111 » giovedì 14 febbraio 2019, 16:37

Ti avevano chiesto di postare
Codice: Seleziona tutto
df -h


E aggiungi anche il risultato di
Codice: Seleziona tutto
sudo fdisk -l

Questi comandi devi darli da ubuntu ovviamente.
andrea111
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1511
Iscrizione: novembre 2007

Re: Errore nell'installazione di grub

Messaggioda Nickshw » giovedì 14 febbraio 2019, 18:36

Ecco i comandi, comunque la 16.04 64bit l'ho installata ora il problema è che il bios non mi mantiene ubuntu come primo sistema di boot dopo aver fatto salva in bios.

Codice: Seleziona tutto
ivma@dubito:~$ df -l
File system            1K-blocchi    Usati Disponib. Uso% Montato su
udev                       957972        0    957972   0% /dev
tmpfs                      197552    21012    176540  11% /run
/dev/mmcblk1p5           10291508  4407924   5337760  46% /
tmpfs                      987752    12660    975092   2% /dev/shm
tmpfs                        5120        4      5116   1% /run/lock
tmpfs                      987752        0    987752   0% /sys/fs/cgroup
/dev/mmcblk1p2              98304    25423     72881  26% /boot/efi
tmpfs                      197552       16    197536   1% /run/user/1000
google-drive-ocamlfuse   15728640   777012  14951628   5% /home/ivma/GDrive
/dev/mmcblk2p1           15154528  5325504   9829024  36% /media/ivma/2634-16F7
/dev/mmcblk1p4           18663420 13957872   4705548  75% /media/ivma/689CB4E89CB4B1C4

Codice: Seleziona tutto
sudo fdisk -l
[sudo] password di ivma:
Disk /dev/mmcblk1: 28,5 GiB, 30601641984 bytes, 59768832 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 50FCAA09-0384-4E8D-8115-C6CA9AC2D661

Dispositivo       Start     Fine  Settori  Size Tipo
/dev/mmcblk1p1     2048  1023999  1021952  499M Windows recovery environment
/dev/mmcblk1p2  1024000  1228799   204800  100M EFI System
/dev/mmcblk1p3  1228800  1261567    32768   16M Microsoft reserved
/dev/mmcblk1p4  1263616 38590463 37326848 17,8G Microsoft basic data
/dev/mmcblk1p5 38590464 59768198 21177735 10,1G Linux filesystem


Disk /dev/mmcblk1boot1: 4 MiB, 4194304 bytes, 8192 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/mmcblk1boot0: 4 MiB, 4194304 bytes, 8192 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/mmcblk2: 14,5 GiB, 15523119104 bytes, 30318592 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Dispositivo    Avvio Start     Fine  Settori  Size Id Tipo
/dev/mmcblk2p1 *      2048 30318591 30316544 14,5G  c W95 FAT32 (LBA)
Ultima modifica di giulux il venerdì 15 febbraio 2019, 9:53, modificato 1 volta in totale.
Motivazione: <pplicati tag code
Nickshw
Prode Principiante
 
Messaggi: 138
Iscrizione: aprile 2005

Re: Errore nell'installazione di grub

Messaggioda Nickshw » giovedì 14 febbraio 2019, 18:46

Se può servire
Codice: Seleziona tutto
efibootmgr -v
BootCurrent: 0005
Timeout: 1 seconds
BootOrder: 0000,0005,0007,0001,0002,0003,0004
Boot0000* Windows Boot Manager   HD(2,GPT,2d2a6080-970d-462c-896b-62d95466d59d,0xfa000,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...B................
Boot0001  UEFI: Built-in EFI Shell    VenMedia(5023b95c-db26-429b-a648-bd47664c8012)..BO
Boot0002* UEFI:CD/DVD Drive   BBS(129,,0x0)
Boot0003* UEFI:Removable Device   BBS(130,,0x0)
Boot0004* UEFI:Network Device   BBS(131,,0x0)
Boot0005* ubuntu   HD(2,GPT,2d2a6080-970d-462c-896b-62d95466d59d,0xfa000,0x32000)/File(\EFI\ubuntu\grubia32.efi)
Boot0007  UEFI: Built-in EFI Shell    VenMedia(5023b95c-db26-429b-a648-bd47664c8012)..BO

Codice: Seleziona tutto
inxi -Fz
System:    Host: dubito Kernel: 4.15.0-45-generic x86_64 (64 bit) Desktop: LXDE (Openbox 3.6.1)
           Distro: Ubuntu 16.04 xenial
Machine:   Mobo: HCD model: Tablet v: 1.0 Bios: HCD v: 1.22 date: 03/14/2017
CPU:       Quad core Intel Atom Z3736F (-MCP-) cache: 1024 KB
           clock speeds: max: 2165 MHz 1: 499 MHz 2: 499 MHz 3: 1783 MHz 4: 2029 MHz
Graphics:  Card: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
           Display Server: X.Org 1.19.6 drivers: (unloaded: fbdev,vesa) Resolution: 1366x768@59.79hz
           GLX Renderer: Mesa DRI Intel Bay Trail GLX Version: 3.0 Mesa 18.0.5
Audio:     Card bytcr-rt5640 driver: bytcr-rt5640 Sound: ALSA v: k4.15.0-45-generic
Network:   Card: Failed to Detect Network Card!
Drives:    HDD Total Size: NA (-) ID-1: /dev/mmcblk1 model: N/A size: 30.6GB
           ID-2: /dev/mmcblk2 model: N/A size: 15.5GB
Partition: ID-1: / size: 9.9G used: 4.4G (48%) fs: ext4 dev: /dev/mmcblk1p5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 35.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 183 Uptime: 2:42 Memory: 862.6/1929.2MB Client: Shell (bash) inxi: 2.2.35
Nickshw
Prode Principiante
 
Messaggi: 138
Iscrizione: aprile 2005

Re: Errore nell'installazione di grub

Messaggioda willy54 » giovedì 14 febbraio 2019, 19:36

Il uefi è giusto come impostazioni come primo SO cerca di partire Lubuntu in posizione 5 da efibootmgr -v
BootCurrent: 0005
........
Boot0005* ubuntu HD(2,GPT,2d2a6080-970d-462c-896b-62d95466d59d,0xfa000,0x32000)/File(\EFI\ubuntu\grubia32.efi) .

Ma nella installazione qualcosa non ha funzionato ovvero o la iso è avariata , o come hai fatto il device di installazione
La ram è solo di 2 gb in parte condivisa , non funzionerebbe una 64 bit.
Posta una schermata di gparted
Toshiba Satellite A660 11M Intel® Core™ i7 CPU Q 720 @ 1.60GHz × 8, SSD 250 gb + hdd 500 gb ram 2x4 Gb : Win7 - Win10 - Ubuntu 18.04 LTS - Kubuntu 18.04 LTS gparted sda inxi -Fz
Hp Pavilon 15-CS2093nl Win10 ----- disattivare Avvio rapido in Windows10
Avatar utente
willy54
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 3161
Iscrizione: dicembre 2017
Località: Castell'Alfero (AT)
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile

Re: Errore nell'installazione di grub

Messaggioda Nickshw » venerdì 15 febbraio 2019, 7:58

Ecco la schermata di Gparted.
Lubuntu 64bit funziona bene, nessun problema.
Allegati
gparted.png
Nickshw
Prode Principiante
 
Messaggi: 138
Iscrizione: aprile 2005

Re: Errore nell'installazione di grub

Messaggioda andrea111 » venerdì 15 febbraio 2019, 14:47

Lo fdisk -l che hai postato prima dice che hai due dispositivi (HD)

Disk /dev/mmcblk1: 28,5 GiB == disco partizionato in gpt (UEFI)

Disk /dev/mmcblk2: 14,5 GiB == disco partizionato in dos (MBR) con il flag di avvio (ovvero disco di boot)

Quando dai il
Codice: Seleziona tutto
sudo grub-install
senza dare indicazioni su quale dispositivo installare ( /dev/mmcblk1 o /dev/mmcblk2) tenterà di installare nel dispositivo d'avvio predefinito (nel tuo caso /dev/mmcblk2 che è in MBR) --- G I U S T O ? -- (È una richiesta di conferma a tutti)

Per quanto riguarda le modifiche al BIOS:
la metodica varia da PC a PC. Prova questo metodo: Imposta la password amministratore ==> salvi e riavvii ==> ora fai le modifiche e vedi se le accetta ==> se le accetta, elimina la password amministratore e vedi se funziona come ti aspetti.
andrea111
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1511
Iscrizione: novembre 2007

Re: Errore nell'installazione di grub

Messaggioda Nickshw » venerdì 15 febbraio 2019, 16:58

Il problema è il bios che non salva la posizione di ubuntu prima di windows. Però la password me l'ha salvata.
Allegati
bios.jpg
Nickshw
Prode Principiante
 
Messaggi: 138
Iscrizione: aprile 2005

Re: Errore nell'installazione di grub

Messaggioda andrea111 » venerdì 15 febbraio 2019, 17:53

Hai riavviato, immesso la password e effettuato la modifica?
E anche così non te la accetta?

Dalla immagine postata, voce "FIXED BOOT ORDER priorities" alla OPTION #2 vedo "HARD DISK Windows..."
Lì hai altre opzioni oltre a Windows?
andrea111
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1511
Iscrizione: novembre 2007

Re: Errore nell'installazione di grub

Messaggioda Nickshw » lunedì 18 febbraio 2019, 10:10

Il bios mi ha memorizzato la password, ma non mi memorizza in "FIXED BOOT ORDER priorities" ubuntu come opzione 1 al riavvio ritrovo windows in posizione 1, anche se ho dato salva con ubuntu al posto 1.

Per ora uso F7 al boot e selezione Ubuntu manualmente. Non so proprio cosa fare.
Nickshw
Prode Principiante
 
Messaggi: 138
Iscrizione: aprile 2005

Re: Errore nell'installazione di grub

Messaggioda Gerry Ghetto » lunedì 18 febbraio 2019, 12:46

andrea111 Immagine ha scritto:senza dare indicazioni su quale dispositivo installare ( /dev/mmcblk1 o /dev/mmcblk2) tenterà di installare nel dispositivo d'avvio predefinito (nel tuo caso /dev/mmcblk2 che è in MBR) --- G I U S T O ? -- (È una richiesta di conferma a tutti)

No, non è giusto. Se si avvia la live in modalità UEFI, Grub si installa in modalità UEFI e si installa nella prima partizione EFI che trova. Inoltre la tabella delle partizioni non è legato alla modalità di avvio (con Windows è un altro discorso).
Gerry Ghetto
 

Re: Errore nell'installazione di grub

Messaggioda Nickshw » lunedì 18 febbraio 2019, 16:17

Risolto per l'ennesima volta ho reinstallato grub, nel bios si è aggiunta una nuova voce ubuntu e stavolta è rimasta in prima posizione nell'ordine di boot nel bios.
Bo sarà un miracolo, comunque ora funziona
Nickshw
Prode Principiante
 
Messaggi: 138
Iscrizione: aprile 2005

Successiva

Torna a Installazione e aggiornamento del sistema operativo

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 1 ospite