[risolto] come faccio a montare il NAS all'avvio?

Networking, configurazione della connessione, periferiche e condivisioni di rete.
mobydick
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 252
Iscrizione: martedì 28 novembre 2006, 15:40

[risolto] come faccio a montare il NAS all'avvio?

Messaggio da mobydick »

ciao non so come fare per montare il NAS all'avvio, ho cercato in rete sia con samba che modificando fstab (che credo sia la strada migliore) ma dando da terminale sudo blkid il risultato è solo

/dev/sda1: UUID="a72309b8-df66-446a-9f7c-51629c979a9d" TYPE="ext4" PARTUUID="3741ba58-01"
/dev/sdb1: LABEL="Secondario 1Tb" UUID="5213082a-a0bd-4d10-89b6-c1ca6a67abf3" TYPE="ext4" PARTUUID="0008c61f-01"
/dev/sr0: UUID="394d5e6820202020" LABEL="FDA" TYPE="udf"
/dev/sdc1: LABEL="Secondario" UUID="0c77785d-cf25-4ebe-b7f4-7dccd9b6841f" TYPE="ext4" PARTUUID="0006aa45-01"

ossia i 3 HD che ho sulla macchina (se ho capito bene), il principale da 1tb e due secondari da 1tb e 500gb.

al NAS ci accedo con "file" e dando "altre posizioni" ma sarebbe molto meglio se lo montasse all'avvio per ovvie ragioni. Insomma sto un po' impantanato e non so come uscirne :muro:
Ultima modifica di mobydick il lunedì 11 febbraio 2019, 15:48, modificato 1 volta in totale.
Avatar utente
Sam9999
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1983
Iscrizione: lunedì 9 giugno 2014, 8:59
Desktop: Studio Xfce
Distribuzione: Ubuntu 20.04 LTS (Focal)
Località: BO
Contatti:

Re: come faccio a montare il NAS all'avvio?

Messaggio da Sam9999 »

Il NAS come è connesso al pc ? Se via rete va fatto con samba...
-------------
S. @-M.
-------------
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 13164
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 12 (Bookworm) - KDE

Re: come faccio a montare il NAS all'avvio?

Messaggio da thece »

:ciao:

per montare il NAS all'avvio è sufficiente inserire nel file /etc/fstab una riga fatta all'incirca così

Codice: Seleziona tutto

//<INDIRIZZO IP NAS>/<SHARE>    /DOVE/VUOI/TU    cifs    auto,_netdev,username=<USERNAME>,password=<PASSWORD>,uid=<UTENTE>,gid=<GRUPPO>    0    0
dove devi sostituire:

- <INDIRIZZO IP NAS>
- <SHARE>
- /DOVE/VUOI/TU , questa directory deve essere già presente sul tuo PC
- <USERNAME> : il nome dell'utente definito sul NAS che può accedere allo share
- <PASSWORD> : la password dell'utente di cui sopra
- <UTENTE> : il nome del tuo utente
- <GRUPPO> : il nome del tuo gruppo principale. Solitamente è uguale al nome del tuo utente. Se non sei sicuro controlla con l'output del comando

Codice: Seleziona tutto

id
In questo caso il comando blkid non serve a nulla
mobydick
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 252
Iscrizione: martedì 28 novembre 2006, 15:40

Re: come faccio a montare il NAS all'avvio?

Messaggio da mobydick »

il NAS è collegato al router...
mobydick
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 252
Iscrizione: martedì 28 novembre 2006, 15:40

Re: come faccio a montare il NAS all'avvio?

Messaggio da mobydick »

thece [url=https://forum.ubuntu-it.org/viewtopic.php?p=5113617#p5113617][img]https://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto::ciao:

per montare il NAS all'avvio è sufficiente inserire nel file /etc/fstab una riga fatta all'incirca così

Codice: Seleziona tutto

//<INDIRIZZO IP NAS>/<SHARE>    /DOVE/VUOI/TU    cifs    auto,_netdev,username=<USERNAME>,password=<PASSWORD>,uid=<UTENTE>,gid=<GRUPPO>    0    0
dove devi sostituire:

- <INDIRIZZO IP NAS>
- <SHARE>
- /DOVE/VUOI/TU , questa directory deve essere già presente sul tuo PC
- <USERNAME> : il nome dell'utente definito sul NAS che può accedere allo share
- <PASSWORD> : la password dell'utente di cui sopra
- <UTENTE> : il nome del tuo utente
- <GRUPPO> : il nome del tuo gruppo principale. Solitamente è uguale al nome del tuo utente. Se non sei sicuro controlla con l'output del comando
scusami ma la directory può essere una qualunque? tipo volendo anche semplicemente /home/utente?
L'utente che può accedere a tutto ora è ovviamente "admin" che ha una password ma non è inserito in nessun gruppo (anzi ora come ora non esiste alcun gruppo definito, sul NAS)
Avatar utente
Stealth
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 17365
Iscrizione: martedì 31 gennaio 2006, 22:55
Desktop: Gnome
Distribuzione: Ubuntu 22.04 LTS

Re: come faccio a montare il NAS all'avvio?

Messaggio da Stealth »

Quel pc è "sicuro" e accedi solo te? In teoria potresti anche lasciare tutto com'è, io suggerisco di creare un utente sul nas, che acceda a quel che si vuole ma che non usi e esponga le stesse credenziali che servono per amministrarlo. E poi userei quello. Ma ovviamente valuta te cosa è meglio.
ciao
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 13164
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 12 (Bookworm) - KDE

Re: come faccio a montare il NAS all'avvio?

Messaggio da thece »

mobydick [url=https://forum.ubuntu-it.org/viewtopic.php?p=5113680#p5113680][img]https://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto: scusami ma la directory può essere una qualunque? tipo volendo anche semplicemente /home/utente?
No, non può proprio essere una directory qualunque. Deve essere una directory esistente ma possibilmente vuota, poichè l'azione di montaggio ne va a ricoprire il contenuto, quindi va da sè che non può essere una /home/utente.
La buona pratica suggerisce di usare una sottodirectory contenuta in /mnt oppure in /media , predisposte appunto a questo scopo. Ma è solo un suggerimento.
mobydick [url=https://forum.ubuntu-it.org/viewtopic.php?p=5113680#p5113680][img]https://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto: L'utente che può accedere a tutto ora è ovviamente "admin" che ha una password ma non è inserito in nessun gruppo (anzi ora come ora non esiste alcun gruppo definito, sul NAS)
Io non ho minimamente fatto accenno ad alcun gruppo dell'utente definito sul NAS. Leggi per bene quello che ti ho scritto nel messaggio precedente.
Avatar utente
Sam9999
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1983
Iscrizione: lunedì 9 giugno 2014, 8:59
Desktop: Studio Xfce
Distribuzione: Ubuntu 20.04 LTS (Focal)
Località: BO
Contatti:

Re: come faccio a montare il NAS all'avvio?

Messaggio da Sam9999 »

Se è connesso al router allora il NAS è in rete.. sempre acceso ? anche perché se lo metti in /etc/fstab e non viene trovato in avvio del computer è possibile che non si avvia Ubuntu.
-------------
S. @-M.
-------------
mobydick
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 252
Iscrizione: martedì 28 novembre 2006, 15:40

Re: come faccio a montare il NAS all'avvio?

Messaggio da mobydick »

@sam9999 si il NAS è sempre acceso

@thece ho creato una cartella "NAS" in /media/massimo, aprendo nautilus al riavvio vedo nell'elenco a sx "NAS" ma se lo seleziono ho un messaggio di errore "mount: /media/massimo/NAS: operation permitted for root only"
dove ho sbagliato ?

la riga aggiunta in fstab è questa:
//<192.168.1.117>/<SHARE> /media/massimo/NAS cifs auto,_netdev,username=<massimo>,password=<PASSWORD>,uid=<massimo>,gid=<massimo> 0 0
(ovviamente ho omesso la psw)
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 13164
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 12 (Bookworm) - KDE

Re: come faccio a montare il NAS all'avvio?

Messaggio da thece »

Frase di rito: come avrai sicuramente già visto in giro per il Forum, per rendere più comprensibile la discussione, dovresti formattare correttamente sia i comandi sia i relativi output racchiudendoli tra i tag [ code ] ... [ /code ] (scritti senza spazi), in modo da ottenere un qualcosa del genere

Codice: Seleziona tutto

COMANDO
...
OUTPUT
...
Puoi applicare i tag automaticamente selezionando il testo che vuoi racchiudere tra di essi e poi premendo il bottone Codice nella pulsantiera posta sopra il riquadro di scrittura.
Sei invitato a modificare il tuo precedente post.


Intanto spero che tu abbia sostituito opportunamente i valori e non usato le parentesi angolari < > , che erano puramente indicative. Per chiarezza espositiva ti ripeto la direttiva da inserire dentro il file /etc/fstab

Codice: Seleziona tutto

//INDIRIZZO_IP_NAS/SHARE    /DOVE/VUOI/TU    cifs    auto,_netdev,username=USERNAME,password=PASSWORD,uid=UTENTE,gid=GRUPPO    0    0
dove devi sostituire:

- INDIRIZZO_IP_NAS
- SHARE
- /DOVE/VUOI/TU , con una directory del tuo PC sulla quale vuoi montare lo share di rete. Questa directory deve essere già presente sul tuo PC
- USERNAME : con il nome dell'utente definito sul NAS che può accedere allo share
- PASSWORD : con la password dell'utente di cui sopra
- UTENTE : con il nome del tuo utente sul tuo PC
- GRUPPO : il nome del tuo gruppo principale. Solitamente è uguale al nome del tuo utente sul tuo PC. Se non sei sicuro controlla con l'output del comando

Codice: Seleziona tutto

id
Nei prossimi comandi tolgo le parentesi angolari in modo da evitare fraintendimenti

Vediamo dove è il problema.

Installa il pacchetto smbclient

Codice: Seleziona tutto

sudo apt install smbclient
poi dai il seguente comando e riportane l'output

Codice: Seleziona tutto

smbclient -L //192.168.1.117 --user="USERNAME"%"PASSWORD"
dove devi sostituire:

- USERNAME : con il nome dell'utente definito sul NAS che può accedere allo share
- PASSWORD : con la password dell'utente di cui sopra

Passo successivo, se volessi provare a montare lo share manualmente, in modo da capire eventuali errori, la forma equivalente della direttiva di cui sopra è

Codice: Seleziona tutto

sudo mount -t cifs -o username="USERNAME",password="PASSWORD",uid=UTENTE,gid=GRUPPO "//INDIRIZZO_IP_NAS/SHARE" "/DOVE/VUOI/TU"
Se lo share viene montato correttamente il comando non restituisce alcun output, inoltre puoi sempre usare questo comando come verifica

Codice: Seleziona tutto

mount | grep INDIRIZZO_IP_NAS
Per smontare lo share puoi usare il comando

Codice: Seleziona tutto

sudo umount //INDIRIZZO_IP_NAS/SHARE
Ultima modifica di thece il sabato 9 febbraio 2019, 18:02, modificato 2 volte in totale.
mobydick
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 252
Iscrizione: martedì 28 novembre 2006, 15:40

Re: come faccio a montare il NAS all'avvio?

Messaggio da mobydick »

Codice: Seleziona tutto

WARNING: The "syslog" option is deprecated

	Sharename       Type      Comment
	---------       ----      -------
	TimeMachineBackup Disk      
	Public          Disk      
	SmartWare       Disk      
	massimo         Disk      
	Transmission    Disk      
	My_Book_1140-1  Disk      USB Device Share
	IPC$            IPC       IPC Service (2-Bay NAS)
Reconnecting with SMB1 for workgroup listing.

	Server               Comment
	---------            -------

	Workgroup            Master
	---------            -------
	WORKGROUP            
mobydick
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 252
Iscrizione: martedì 28 novembre 2006, 15:40

Re: come faccio a montare il NAS all'avvio?

Messaggio da mobydick »

thece [url=https://forum.ubuntu-it.org/viewtopic.php?p=5113735#p5113735][img]https://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:
Passo successivo, se volessi provare a montare lo share manualmente, in modo da capire eventuali errori, la forma equivalente della direttiva di cui sopra è

Codice: Seleziona tutto

mount -t cifs -o username="USERNAME",password="PASSWORD",uid=UTENTE,gid=GRUPPO "//INDIRIZZO_IP_NAS/SHARE" "/DOVE/VUOI/TU"
risultato:

Codice: Seleziona tutto

mount: /media/massimo/NAS: special device //192.168.1.117/SHARE does not exist.
Avatar utente
Sam9999
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1983
Iscrizione: lunedì 9 giugno 2014, 8:59
Desktop: Studio Xfce
Distribuzione: Ubuntu 20.04 LTS (Focal)
Località: BO
Contatti:

Re: come faccio a montare il NAS all'avvio?

Messaggio da Sam9999 »

Com'è l'albero directory del NAS ? Nel senso, quali cartelle risultano condivise.?
-------------
S. @-M.
-------------
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 13164
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 12 (Bookworm) - KDE

Re: come faccio a montare il NAS all'avvio?

Messaggio da thece »

Intanto un'osservazione: quando posti l'output di un comando, posta sempre anche il comando che hai immesso facendo Copia&Incolla dal terminale, altrimenti non è possibile aiutarti nel modo corretto.

Gli share esposti dal NAS dovresti conoscerli di tuo, poichè il NAS è tuo e lo hai configurato tu. In caso di incertezza, potevi comunque dare un'occhiata all'output del comando smbclient, che in questo caso appunto non fa altro che elencare gli share esposti dal NAS.
La domanda che ti faccio è: perchè, nei comandi che ti ho suggerito di provare, non sostituisci correttamente i parametri? Tipo

Codice: Seleziona tutto

sudo mount -t cifs -o username="USERNAME",password="PASSWORD",uid=UTENTE,gid=GRUPPO "//INDIRIZZO_IP_NAS/SHARE" "/DOVE/VUOI/TU"
doveva diventare un qualcosa del genere

Codice: Seleziona tutto

sudo mount -t cifs -o username="USERNAME",password="PASSWORD",uid=massimo,gid=massimo "//192.168.1.117/SmartWare" "/media/massimo/SmartWare"
mobydick
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 252
Iscrizione: martedì 28 novembre 2006, 15:40

Re: come faccio a montare il NAS all'avvio?

Messaggio da mobydick »

afp://Massimo@MyCloudEX2Ultra.local/Public/Shared%20Music/musica_condivisa

dentro public ci sono altre due carelle una è "Shared Foto" e l'altra è "Shared Video" che rispettivamente hanno al loro interno N cartelle (così come ennemila cartelle sono dentro a "musica_condivisa"), sono tutte e tre condivise, ossia accedendo al nas con nautilus viene visto tutto...
Avatar utente
Sam9999
Entusiasta Emergente
Entusiasta Emergente
Messaggi: 1983
Iscrizione: lunedì 9 giugno 2014, 8:59
Desktop: Studio Xfce
Distribuzione: Ubuntu 20.04 LTS (Focal)
Località: BO
Contatti:

Re: come faccio a montare il NAS all'avvio?

Messaggio da Sam9999 »

In un altro caso è capitato che non puoi montare la cartella precedente a quelle condivise..
-------------
S. @-M.
-------------
mobydick
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 252
Iscrizione: martedì 28 novembre 2006, 15:40

Re: come faccio a montare il NAS all'avvio?

Messaggio da mobydick »

[quote="thece [url=viewtopic.php?p=5113916#p5113916]

Codice: Seleziona tutto

sudo mount -t cifs -o username="USERNAME",password="PASSWORD",uid=UTENTE,gid=GRUPPO "//INDIRIZZO_IP_NAS/SHARE" "/DOVE/VUOI/TU"
doveva diventare un qualcosa del genere

Codice: Seleziona tutto

sudo mount -t cifs -o username="USERNAME",password="PASSWORD",uid=massimo,gid=massimo "//192.168.1.117/SmartWare" "/media/massimo/SmartWare"
[/quote]

il risultato di quello sopra è:

Codice: Seleziona tutto

mount: /media/massimo/SmartWare: mount point does not exist.
ho provato anche con "public" al posto di "smartware" (anche perchè le tre cartelle di musica/foto/video le vedo dentro a public mentre dentro a smartware non mi vede nulla) ma il risultato è lo stesso

Codice: Seleziona tutto

mount: /media/massimo/Public: mount point does not exist.
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 13164
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 12 (Bookworm) - KDE

Re: come faccio a montare il NAS all'avvio?

Messaggio da thece »

mobydick [url=https://forum.ubuntu-it.org/viewtopic.php?p=5114315#p5114315][img]https://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto: il risultato di quello sopra è:
mount: /media/massimo/SmartWare: mount point does not exist.
thece ha scritto: ...
dove devi sostituire:

- /DOVE/VUOI/TU , con una directory del tuo PC sulla quale vuoi montare lo share di rete. Questa directory deve essere già presente sul tuo PC
...
mobydick [url=https://forum.ubuntu-it.org/viewtopic.php?p=5114315#p5114315][img]https://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto: ho provato anche con "public" al posto di "smartware" (anche perchè le tre cartelle di musica/foto/video le vedo dentro a public mentre dentro a smartware non mi vede nulla) ma il risultato è lo stesso
Ti ricordo che sulla base del seguente output
mobydick [url=https://forum.ubuntu-it.org/viewtopic.php?p=5113805#p5113805][img]https://forum.ubuntu-it.org/images/icons/icona-cita.gif[/img][/url] ha scritto:
...
TimeMachineBackup Disk
Public Disk
SmartWare Disk
massimo Disk
Transmission Disk
My_Book_1140-1 Disk USB Device Share
IPC$ IPC IPC Service (2-Bay NAS)
...
che hai postato in precedenza, i tuoi share sono solamente quelli indicati nell'output.
Va da sè che tutte le directory contenute negli share sopra indicati vengono automaticamente condivise.
mobydick
Scoppiettante Seguace
Scoppiettante Seguace
Messaggi: 252
Iscrizione: martedì 28 novembre 2006, 15:40

Re: come faccio a montare il NAS all'avvio?

Messaggio da mobydick »

ok, così l'ha preso

Codice: Seleziona tutto

sudo mount -t cifs -o username=massimo,password=PASSWORD,uid=massimo,gid=massimo "//192.168.1.117/SmartWare" "/media/massimo/NAS"
prossimo step ?
Avatar utente
thece
Tenace Tecnocrate
Tenace Tecnocrate
Messaggi: 13164
Iscrizione: lunedì 23 aprile 2007, 14:16
Distribuzione: Debian 12 (Bookworm) - KDE

Re: come faccio a montare il NAS all'avvio?

Messaggio da thece »

Se quel comando ha funzionato (*) allora questa

Codice: Seleziona tutto

//192.168.1.117/SmartWare    /media/massimo/NAS    cifs    auto,_netdev,username=massimo,password=PASSWORD,uid=massimo,gid=massimo    0    0
è la direttiva equivalente da inserire nel file /etc/fstab



(*) Sei sicuro che lo share sia stato montato, vero? Lo hai verificato?
Scrivi risposta

Ritorna a “Connessione e configurazione delle reti”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 5 ospiti