Ubuntu lento su HW recente (forse grafica?)

Riconoscimento, installazione e configurazione delle periferiche.

Ubuntu lento su HW recente (forse grafica?)

Messaggioda EagleBuntu » mercoledì 13 febbraio 2019, 19:09

Ho appena assemblato un fisso con questa cfg:
- amd ryzen 2200g con grafica vega8 integrata;
- msi b450-a pro con bios aggiornato ad ultima versione;
- 2x4gb hyperx predator @3200 cl16 (le faccio andare @2400 che è il default)
- hdd @7200rpm
- no scheda grafica dedicata

Appena installato ubuntu 18.04.1LTS con alcuni accorgimenti grafici per completare l'installazione, ovvero ho aggiunto i seguenti parametri dopo ---:
vga=791 nomodeset
perchè funzionarono molto tempo fa per installare lubuntu 14 su un vecchissimo portatile. In entrambi i casi, senza parametri, ho ottenuti schermata nera.
Durante l'installazione ho fatto scaricare gli aggiornamenti ed adesso la versione indicata a terminale è 18.04.2lts.

Ho appena cominciato ad usarlo e mi sono subito accorto che FF che è lentissimo, ma non a caricare, bensì a renderizzare le pagine (spero di essermi espresso bene): per esempio è lentissimo a scorrere i contenuti di una pagina, anzi è impossibile perchè si impalla. Idem se clicco su impostazioni (barra sn desktop): molto lento a cambiare tra una voce e l'altra e, soprattutto, ciò che si visualizza è reso male: magari si sovrappongono parti di 2 schermate apparteneti a 2 voci diferenti, per esempio. In entrambi i casi è un problema anche spostare le finestre sul desktop sia per lentezza che per "ingarbugliamento" di rendering.
Altro appunto, ma devo verificare meglio: credo che certe finestre, appena aperte, "escono" dai contorni del desktop. Ho quindi visto se si poteva aumentare la risoluzione del monitor, così da rimpicciolire tutto, però l'unica disponibile è 1024x768 (4:3) mentre la risoluzione massima del monitor è 1440x900 (4:2.5, tanto per confrontarlo meglio con l'altro rapporto).
L'unica cosa che sembra molto fluida è il file manager, ma l'hdd è quasi vuoto e poco nidificato quindi non mi pronuncio più di tanto. In questo caso, se provo a trascinare la finestra sul desktop molto velocemente, il contenuto è correttamente visualizzato però sul desktop restano "tracce" di colore del passaggio della finestra.

Credo che la responsabilità sia solo della grafica, altrimenti bisognerebbe concludere che l'HW non ce la fa. Che ne pensate e come risolvere?
Io avrei pensato ad un upgrade del kernel, che attualmente è 4.15.0-45-generic, ma come procedere?
EagleBuntu
Prode Principiante
 
Messaggi: 85
Iscrizione: luglio 2013
Desktop: Gnome
Distribuzione: Ubuntu 18.04.2LTS 64bit

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda willy54 » mercoledì 13 febbraio 2019, 19:23

Abilita i driver proprietari video alcuni problemi dovrebbero risolversi.
Toshiba Satellite A660 11M Intel® Core™ i7 CPU Q 720 @ 1.60GHz × 8, SSD 250 gb + hdd 500 gb ram 2x4 Gb : Win7 - Win10 - Ubuntu 18.04 LTS - Kubuntu 18.04 LTS - - VisualBasic 2008 su win7 gparted sda inxi -Fz
Una cortesia per favore per chi cerca di aiutarvi, quando la soluzione è trovata, mettete il [Risolto] sul primo post, la discussione può aiutare altri.
Avatar utente
willy54
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2404
Iscrizione: dicembre 2017
Località: Castell'Alfero (AT)
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda EagleBuntu » mercoledì 13 febbraio 2019, 19:35

puoi gentilmente spiegarmi step-by-step come fare?
EagleBuntu
Prode Principiante
 
Messaggi: 85
Iscrizione: luglio 2013
Desktop: Gnome
Distribuzione: Ubuntu 18.04.2LTS 64bit

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda willy54 » mercoledì 13 febbraio 2019, 20:49

Cerca la App Software ed aggiornamenti -----> abilita la casella driver e software con restrizioni -----> nella stessa videata seleziona la scheda Driver -----> attendi che finisca la ricerca-------> Seleziona il driver ------> Applica/installa .
Ovviamente devi essere collegato a internet i driver li cerca in rete.
Toshiba Satellite A660 11M Intel® Core™ i7 CPU Q 720 @ 1.60GHz × 8, SSD 250 gb + hdd 500 gb ram 2x4 Gb : Win7 - Win10 - Ubuntu 18.04 LTS - Kubuntu 18.04 LTS - - VisualBasic 2008 su win7 gparted sda inxi -Fz
Una cortesia per favore per chi cerca di aiutarvi, quando la soluzione è trovata, mettete il [Risolto] sul primo post, la discussione può aiutare altri.
Avatar utente
willy54
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2404
Iscrizione: dicembre 2017
Località: Castell'Alfero (AT)
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda EagleBuntu » mercoledì 13 febbraio 2019, 21:28

Avviato "software e aggiornamenti"

scheda "software per ubuntu":
tutte le voci (tranne "codice sorgente") erano già selezionate, comprese:
- driver proprietari per i dispositivi (restricted)
- software con restrizioni per copyright o motivi legali (multiverse)

scheda "driver aggiuntivi":
nessun driver aggiuntivo disponibile

ho provato a modificare "scaricare da": server italia -> server principale. sono ritornato in "driver aggiuntivi" e c'era la scritta "ricerca driver disponibili" però alla fine nulla. ho chiuso ed è comparsa la finestra "le informazioni sul software disponibile non sono aggiornate"..."necessaria una connessione a internet funzionante", clicco su "ricarica" e compare finestra "aggiornamento della cache" e sembra che scarica qualcosa, comunque poi chiude tutto. riapro "software e aggiornamenti" ma non cambia nulla.
nonostante dica che non c'è connessione io navigo con FF anche se molto stentatamente e comunque ho visto che "aggiornamento della cache" scaricava informazioni.
EagleBuntu
Prode Principiante
 
Messaggi: 85
Iscrizione: luglio 2013
Desktop: Gnome
Distribuzione: Ubuntu 18.04.2LTS 64bit

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda andrea111 » giovedì 14 febbraio 2019, 0:07

Giusto per farsi un'idea della situazione grafica, posta il risultato di
Codice: Seleziona tutto
cat /var/log/gpu-manager.log
andrea111
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1342
Iscrizione: novembre 2007

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda EagleBuntu » giovedì 14 febbraio 2019, 0:49

avevo tentato l'upgrade del kernel ma credo senza risultato. ho messo ukuu e proceduto ad installare il 4.20.8, ovvero l'ultimo disponibile in lista tra quelli stabili, ed ho ottenuto black screen e non ha avviato. poi ho provato con 4.19.0-041900, che ho lasciato attualmente, ma la situazione mi sembra identica a quella sopra descritta, con kernel 4.15.0-45. l'unica differenza che ho notato è che quando avvia spunta qualcosa del tipo "error vgacon" però non posso essere più preciso, non ricordo quel comando per richiamare il listato d'avvio.

cat /var/log/gpu-manager.log
Codice: Seleziona tutto
$ cat /var/log/gpu-manager.log
log_file: /var/log/gpu-manager.log
last_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
new_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
can't access /run/u-d-c-nvidia-was-loaded file
can't access /opt/amdgpu-pro/bin/amdgpu-pro-px
Looking for nvidia modules in /lib/modules/4.19.0-041900-generic/updates/dkms
Looking for amdgpu modules in /lib/modules/4.19.0-041900-generic/updates/dkms
Is nvidia loaded? no
Was nvidia unloaded? no
Is nvidia blacklisted? no
Is intel loaded? no
Is radeon loaded? no
Is radeon blacklisted? no
Is amdgpu loaded? no
Is amdgpu blacklisted? no
Is amdgpu versioned? no
Is amdgpu pro stack? no
Is nouveau loaded? no
Is nouveau blacklisted? no
Is nvidia kernel module available? no
Is amdgpu kernel module available? no
Vendor/Device Id: 1002:15dd
BusID "PCI:56@0:0:0"
Is boot vga? yes
Error: can't access /sys/bus/pci/devices/0000:38:00.0/driver
The device is not bound to any driver.
Error : Failed to open /dev/dri
Error : Failed to open /dev/dri
Error : Failed to open /dev/dri
Error : Failed to open /dev/dri
Does it require offloading? no
last cards number = 1
Has amd? yes
Has intel? no
Has nvidia? no
How many cards? 1
Has the system changed? No
Single card detected
Nothing to do

forse è più opportuno spostare questo thread in problematiche hw?
EagleBuntu
Prode Principiante
 
Messaggi: 85
Iscrizione: luglio 2013
Desktop: Gnome
Distribuzione: Ubuntu 18.04.2LTS 64bit

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda willy54 » giovedì 14 febbraio 2019, 1:53

Posso sbagliarmi ma temo sia dovuto a quel 791 anteposto a nomodeset che manda il tutto in blocco e non lascia trovare driver proprietari.
Non ho molta pratica con le cpu amd ,ma solitamente sono ben supportate. Vedi questa guida se ti può aiutare
Toshiba Satellite A660 11M Intel® Core™ i7 CPU Q 720 @ 1.60GHz × 8, SSD 250 gb + hdd 500 gb ram 2x4 Gb : Win7 - Win10 - Ubuntu 18.04 LTS - Kubuntu 18.04 LTS - - VisualBasic 2008 su win7 gparted sda inxi -Fz
Una cortesia per favore per chi cerca di aiutarvi, quando la soluzione è trovata, mettete il [Risolto] sul primo post, la discussione può aiutare altri.
Avatar utente
willy54
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 2404
Iscrizione: dicembre 2017
Località: Castell'Alfero (AT)
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda andrea111 » giovedì 14 febbraio 2019, 3:20

Mi sa che l'hardware è anche troppo recente per linux - c'è da rimboccarsi le maniche.
Da quel che ho visto in giro è richiesto come minimo il kernel 4.15 e come consigliato il 4.18 (dovresti installare dei ppa per poterlo fare).

Ti passo un link dove danno il [Risolto] con Mint cinnamon. Ti fai un'idea.
Q U I il LINK

Per il momento non è ancora roba per principianti.
andrea111
Entusiasta Emergente
Entusiasta Emergente
 
Messaggi: 1342
Iscrizione: novembre 2007

Re: Ubuntu lento su HW recente (forse grafica?)

Messaggioda carved top » giovedì 14 febbraio 2019, 7:48

Grazie per la segnalazione, sposto in driver e periferiche :ciao:
"It's 106 miles to Chicago, we got a full tank of gas, half a pack of cigarettes, it's dark and we're wearing sunglasses." "Hit it!"
Elementary OS 0.4 Loki | AMD A8-6600k | GTX 750 ti | HyperX Fury 8 GB @ 1600MHz
Avatar utente
carved top
Moderatore Globale
Moderatore Globale
 
Messaggi: 2157
Iscrizione: maggio 2012
Desktop: Pantheon
Distribuzione: Elementary 0.4 Loki x86_64


Torna a Driver e periferiche

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 9 ospiti