Google Chrome non si avvia su Ubuntu 16.04

Installazione, configurazione e uso di programmi e strumenti.

Google Chrome non si avvia su Ubuntu 16.04

Messaggioda teramac77 » mercoledì 13 febbraio 2019, 19:15

Salve,
da qualche tempo sto avendo problemi con il browser Google Chrome.
Molto semplicemente non si avvia.
Come distribuzione Linux sto usando Ubuntu 16.04.5 LTS x86_64.
Ho provato a seguire diverse guide proposte in vari forum su internet ma non ho risolto, se non provvisoriamente, e poi il problema è ritornato fuori.
Ho ovviato installando il browser Chromium che funziona regolarmente senza problemi, per quanto riguarda la navigazione in generale, nel particolare per esempio l'altro giorno dovevo inserire dei documenti per lavoro ed il sito non era ottimizzato per Chromium e non potevo farlo..
Il problema si presenta cosi: Chrome non si avvia.
Quando clicco sull'icona del programma compare il cerchietto bianco con quei puntini neri che indicano il caricamento in corso.
Il sottofondo dell'icona di Chrome lampeggia.....ma poi niente, il programma non si avvia.
Ho provato a disinstallare e reinstallare il programma: per un momento sembra funzionare poi il problema si ripresenta.
Più precisamente: la prima volta che il programma viene chiamato si avvia regolarmente.
Dopo di che è come se inizializzasse qualcosa che va in conflitto ed agli avvii successivi non si apre più.
Ho provato anche a cancellare la cartella di Google Chrome che si trova nel percorso: /home/terminale/.config.
Di nuovo la stessa cosa; al primo avvio si apre poi come sopra.
Se provo ad aprire Google Chrome da terminale, quando non si avvia più, salta fuori questo errore:

Codice: Seleziona tutto
terminale@terminale-fracosi:~$ google-chrome
[8569:8569:0213/184833.398413:ERROR:sandbox_linux.cc(364)] InitializeSandbox() called with multiple threads in process gpu-process.

Grazie per l'attenzione.

Cordiali saluti
Ultima modifica di trekfan1 il mercoledì 13 febbraio 2019, 19:22, modificato 1 volta in totale.
Motivazione: Inseriti i tag CODE ricordalo per il futuro
teramac77
Prode Principiante
 
Messaggi: 13
Iscrizione: febbraio 2019
Desktop: Ubuntu
Distribuzione: Ubuntu 18.04.2 LTS bionic x86_64
Sesso: Maschile

Re: Google Chrome non si avvia su Ubuntu 16.04

Messaggioda caturen » mercoledì 13 febbraio 2019, 19:41

prova a lanciare chrome con questo comando
Codice: Seleziona tutto
google-chrome --disable-gpu--disable-software-rasterizer
caturen
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 15041
Iscrizione: aprile 2010
Desktop: diversi
Distribuzione: debian sid

Re: Google Chrome non si avvia su Ubuntu 16.04

Messaggioda teramac77 » mercoledì 13 febbraio 2019, 20:44

Salve,
dopo aver aperto il terminale ed eseguito il comando suggerito, compare questo messaggio di errore:

Codice: Seleziona tutto
terminale@terminale-fracosi:~$ google-chrome --disable-gpu--disable-software-rasterizer
[2774:2774:0213/203413.581399:ERROR:sandbox_linux.cc(364)] InitializeSandbox() called with multiple threads in process gpu-process.


Non so se puo essere d'aiuto: ho notato che anche il terminale aperto rimane in stallo, o non saprei come meglio dire.
Una volta scritto il comando e dato invio esce il messaggio di errore e rimane il cursore, un rettangolino bianco che lampeggia per qualche secondo, dopodiche rimane fisso.

Saluti
Ultima modifica di trekfan1 il mercoledì 13 febbraio 2019, 21:33, modificato 1 volta in totale.
Motivazione: Inseriti i tag CODE, ricordalo per il futuro
teramac77
Prode Principiante
 
Messaggi: 13
Iscrizione: febbraio 2019
Desktop: Ubuntu
Distribuzione: Ubuntu 18.04.2 LTS bionic x86_64
Sesso: Maschile

Re: Google Chrome non si avvia su Ubuntu 16.04

Messaggioda woddy68 » domenica 17 febbraio 2019, 16:42

Hai provato ad aprire Chrome direttamente in modalità incognito ?
Desktop - Acer Aspire M5500 (AMD) OpenSuse Leap 15 Kde -- Kubuntu 18.04 -- Tumbleweed
Notebook Acer Aspire E1 -522 (Amd) Tumbleweed - NO Windows ;)
Avatar utente
woddy68
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4181
Iscrizione: febbraio 2011
Località: Bellano Lc
Desktop: Kde Plasma5
Distribuzione: Leap 15 - Tumbleweed- Kubuntu 18.04
Sesso: Maschile

Re: Google Chrome non si avvia su Ubuntu 16.04

Messaggioda steff » domenica 17 febbraio 2019, 16:54

Prova lanciarlo
Codice: Seleziona tutto
chrome --no-sandbox

ma mai usarlo in quel modo, poi prova di disabilitare l'accelerazione hardware in chrome://settings.
Hai fatto il backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox
Avatar utente
steff
Moderatore Globale
Moderatore Globale
 
Messaggi: 37916
Iscrizione: febbraio 2007
Località: Toscana
Desktop: LXQt
Distribuzione: Arch Linux 64bit
Sesso: Maschile

Re: Google Chrome non si avvia su Ubuntu 16.04

Messaggioda teramac77 » mercoledì 20 febbraio 2019, 20:51

Buonasera,
ho provato ad aprire chrome in incognito non parte.
Ho provato ad aprire chrome con il comando:
Codice: Seleziona tutto
chrome - - no - sandbox

Li per li diceva comando non trovato......allora ho aggiunto google in testa:
Codice: Seleziona tutto
google-chrome - - no - sandbox

Chrome non si è avviato e questo è il solito messaggio di errore:
Codice: Seleziona tutto
terminale@terminale-fracosi:~$ google-chrome --no-sandbox
[4018:4018:0220/194237.063745:ERROR:sandbox_linux.cc(364)] InitializeSandbox() called with multiple threads in process gpu-process.

A questo punto ho cancellato la cartella di google nel percorso:
Codice: Seleziona tutto
/home/terminale/.config

Cancellando la cartella chrome almeno la prima volta si apre.
Avviandolo da terminale questi errori:
Codice: Seleziona tutto
terminale@terminale-fracosi:~$ google-chrome
Gkr-Message: secret service operation failed: Failed to execute program org.freedesktop.secrets: Permission denied
[5484:5484:0220/201527.365457:ERROR:sandbox_linux.cc(364)] InitializeSandbox() called with multiple threads in process gpu-process.
Gkr-Message: secret service operation failed: Failed to execute program org.freedesktop.secrets: Permission denied

Disattivato acceleratore hardware nel percorso "impostazioni -> avanzate -> sistema -> Usa accelerazione hardware quando disponibile".
Digitando nel terminale il comando "google-chrome --no-sandbox", dopo diversi secondi, chrome si è aperto con questi errori evidenziati nella finestra:
Codice: Seleziona tutto
terminale@terminale-fracosi:~$ google-chrome --no-sandbox
Gkr-Message: secret service operation failed: Failed to execute program org.freedesktop.secrets: Permission denied
Gkr-Message: secret service operation failed: Failed to execute program org.freedesktop.secrets: Permission denied
Gkr-Message: secret service operation failed: Failed to execute program org.freedesktop.secrets: Permission denied

Sembrava fatta.
Peccato ancora i soliti problemi.
Resta solo il fatto che cancellando la cartella google al primo avvio parte subito.
teramac77
Prode Principiante
 
Messaggi: 13
Iscrizione: febbraio 2019
Desktop: Ubuntu
Distribuzione: Ubuntu 18.04.2 LTS bionic x86_64
Sesso: Maschile

Re: Google Chrome non si avvia su Ubuntu 16.04

Messaggioda woddy68 » mercoledì 20 febbraio 2019, 21:50

Desktop - Acer Aspire M5500 (AMD) OpenSuse Leap 15 Kde -- Kubuntu 18.04 -- Tumbleweed
Notebook Acer Aspire E1 -522 (Amd) Tumbleweed - NO Windows ;)
Avatar utente
woddy68
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4181
Iscrizione: febbraio 2011
Località: Bellano Lc
Desktop: Kde Plasma5
Distribuzione: Leap 15 - Tumbleweed- Kubuntu 18.04
Sesso: Maschile

Re: Google Chrome non si avvia su Ubuntu 16.04

Messaggioda steff » mercoledì 20 febbraio 2019, 21:56

Trovo due cose pure io, una in tedesco che dice che sia un problema di gnome-keyring e questa qui, simile...
http://www.istitutomajorana.it/forum2/T ... t-di-nuovo
Hai fatto il backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox
Avatar utente
steff
Moderatore Globale
Moderatore Globale
 
Messaggi: 37916
Iscrizione: febbraio 2007
Località: Toscana
Desktop: LXQt
Distribuzione: Arch Linux 64bit
Sesso: Maschile

Re: Google Chrome non si avvia su Ubuntu 16.04

Messaggioda teramac77 » sabato 23 febbraio 2019, 21:49

Buonasera,
ho seguito le guide che mi avete indicato.
Ho creato nel percorso:
Codice: Seleziona tutto
~/.config/autostart/gnome-keyring-daemon.desktop

il file
Codice: Seleziona tutto
 "gnome-keyring-daemon.desktop".

Per curiosità che tipo di file sarebbe un file con estensione .desktop?
Dopo di che nel corpo del file ho copiato ciò che veniva indicato.Per la precisione:
Codice: Seleziona tutto
[Desktop Entry]
Type=Application
Exec=/usr/bin/gnome-keyring-daemon
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
Name[en_US]=Gnome Keyring Daemon
Name=Gnome Keyring Daemon
Comment[en_US]=Load gnome keyring daemon
Comment=Load gnome keyring daemon

Nella guida però dicono che questo non basta.Per risolvere il problema bisogna rendere eseguibile il file
Codice: Seleziona tutto
 "gnome-keyring-daemon"
che si trova nel percorso
Codice: Seleziona tutto
 /usr/bin/gnome-keyring-daemon.

Penso che questo voglia dire accedere alle proprietà del file e mettere la spunta su
Codice: Seleziona tutto
"Esecuzione Consentire l'esecuzione del file come programma".

Il proprietario del file è root, come faccio ad accedere al file come root e mettere la spunta?
Nelle guide ho trovato anche questo comando per avviare Chrome:
Codice: Seleziona tutto
 google-chrome-stable %U --password-store=basic

In effetti digitando questo comando Chrome si avvia con questi messaggi di errore:
Codice: Seleziona tutto
terminale@terminale-fracosi:~$  google-chrome-stable %U --password-store=basic
[3796:3883:0223/213749.328949:ERROR:token_service_table.cc(141)] Failed to decrypt token for service AccountId-111641706387887350873
[3796:3796:0223/213754.296623:ERROR:account_tracker.cc(240)] AccessTokenFetched error: Invalid credentials (credentials missing).
[3796:3796:0223/213757.888983:ERROR:data_type_manager_impl.cc(37)] Passwords cryptographer error was encountered:

Un'ultima curiosità: è possibile inserire nella discussione direttamente delle immagini?
Cerco di spiegarmi meglio: apro il terminale, do un comando, appaiono nel terminale una serie di errori.Con i tasti "alt -> stamp" catturo la schermata.Posso postarla direttamente nella discussione?

Grazie
teramac77
Prode Principiante
 
Messaggi: 13
Iscrizione: febbraio 2019
Desktop: Ubuntu
Distribuzione: Ubuntu 18.04.2 LTS bionic x86_64
Sesso: Maschile

Re: Google Chrome non si avvia su Ubuntu 16.04

Messaggioda steff » sabato 23 febbraio 2019, 22:10

Solo in breve due cose:
- quelli n/usr/bin sono tutti programmi quindi sono tutti eseguibili da sempre
- i file .desktop sono "avviatori" che popolano il menu
- non usare immagini per testo (del terminale nel caso) che si può semplicemente marcare e copiare/incollare
Hai fatto il backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox
Avatar utente
steff
Moderatore Globale
Moderatore Globale
 
Messaggi: 37916
Iscrizione: febbraio 2007
Località: Toscana
Desktop: LXQt
Distribuzione: Arch Linux 64bit
Sesso: Maschile

Re: Google Chrome non si avvia su Ubuntu 16.04

Messaggioda teramac77 » domenica 24 febbraio 2019, 12:49

Buongiorno,
nella discussione
http://www.istitutomajorana.it/forum2/T ... t-di-nuovo
nella parte finale, l'utente "skandy63" dice:
pare che funzioni, ma solo dopo aver cambiato i permessi e rendendolo eseguibile al file /usr/bin/gnome-keyring-daemon
adesso lo provo un po e se regge metto il [RISOLTO]
grazie

Cosa intende dire cambiare i permessi e rendere eseguibile il file "gnome-keyring-daemon"?
Inoltre dopo aver seguito le guide si è presentato un'altro problema: non si avvia più anche Chromium. :cry:
Digitando il comando
Codice: Seleziona tutto
Chromium-browser
sul terminale escono questi messaggi di errore:
Codice: Seleziona tutto
terminale@terminale-fracosi:~$ chromium-browser
[2852:2852:0224/123329.380376:ERROR:sandbox_linux.cc(364)] InitializeSandbox() called with multiple threads in process gpu-process.
Gkr-Message: secret service operation failed: Failed to execute program org.freedesktop.secrets: Permission denied

:frusta:
Se clicco di destro sull'icona di Chromium vengono presentate 3 scelte:
1- Apri una nuova finestra
2- Apri una nuova finestra in modalità incognito
3- Apri una nuova finestra con profilo temporaneo

Se scelgo l'opzione 3 Chromium si avvia.


Saluti
teramac77
Prode Principiante
 
Messaggi: 13
Iscrizione: febbraio 2019
Desktop: Ubuntu
Distribuzione: Ubuntu 18.04.2 LTS bionic x86_64
Sesso: Maschile

Re: Google Chrome non si avvia su Ubuntu 16.04

Messaggioda steff » domenica 24 febbraio 2019, 14:59

Come detto: tutto quel che è in /usr/bin è già eseguibile, quindi se uno dice di aver reso eseguibile qualcosa che è lì non capisce molto.... però vediamo:
Codice: Seleziona tutto
ls -l   /usr/bin/gnome-keyring-daemon

L'unica cosa che hai fatto è mettere in avvio automatica quel demone che ti dovrebbe chiedere il passwd per le chiavi wireless ecc dopo il login.

Se chromium si avvia solo con metodo 3 dovrebbe essere un problema nelle impostazioni sue, non mi sembra collegato a quel altro problema ,cmq puoi togliere dall'avvio automatico gnome-keyring daemon (ci deve essere una gui per gestire le applicazioni in avvio dopo il login da qualche parte...) e verificare.
Hai fatto il backup oggi? Ieri?? Quando???
La Documentazione da consultare e la FAQ sul uso del forum
Sistemi: LXQt - semplice, modulare e configurabile + *ubuntu in Vbox
Avatar utente
steff
Moderatore Globale
Moderatore Globale
 
Messaggi: 37916
Iscrizione: febbraio 2007
Località: Toscana
Desktop: LXQt
Distribuzione: Arch Linux 64bit
Sesso: Maschile

Re: Google Chrome non si avvia su Ubuntu 16.04

Messaggioda teramac77 » mercoledì 27 febbraio 2019, 16:57

Buonasera,
giusto per condivisione, potrebbe aiutare chi ha una situazione simile.
Ho cercato di risolvere il problema del non avvio di Chrome passando ad ubuntu 18.04.
L'avanzamento è andato in crash e non si avviava più ne ubuntu ne windows 10. :pirata:
Attraverso Super Grub Disk sono riuscito ad avviare i sistemi ed a recuperare i dati, ma ho reinstallato tutto di sana pianta. :spalo:
Adesso Chrome si avvia ma all'apertura esce questo messaggio:
Inserire la password per sbloccare.
Un'applicazione vuol accedere al portachiavi <<Portachiavi predefinito>>, ma questo è bloccato

Password: .......

Inserisco la password e Chrome si avvia senza problemi.

Mi domandavo: per caso potrebbe essere legato ai problemi che riscontravo all'apertura?
Magari gli serviva uno sblocco del portachiavi che non riusciva ad esplicitare per conflitti vari.

Faccio per dire, non so neanche cos'è il portachiavi, non sono un esperto di Ubuntu.

Saluti
teramac77
Prode Principiante
 
Messaggi: 13
Iscrizione: febbraio 2019
Desktop: Ubuntu
Distribuzione: Ubuntu 18.04.2 LTS bionic x86_64
Sesso: Maschile

Re: Google Chrome non si avvia su Ubuntu 16.04

Messaggioda woddy68 » mercoledì 27 febbraio 2019, 18:50

Il portachiavi è uno strumento che memorizza in modo sicuro le password, il portachiavi viene automaticamente sbloccando quando si fa il login, ovvio che se si disattiva il login, impostando il login automatico il portachiavi rimane bloccato.
Desktop - Acer Aspire M5500 (AMD) OpenSuse Leap 15 Kde -- Kubuntu 18.04 -- Tumbleweed
Notebook Acer Aspire E1 -522 (Amd) Tumbleweed - NO Windows ;)
Avatar utente
woddy68
Imperturbabile Insigne
Imperturbabile Insigne
 
Messaggi: 4181
Iscrizione: febbraio 2011
Località: Bellano Lc
Desktop: Kde Plasma5
Distribuzione: Leap 15 - Tumbleweed- Kubuntu 18.04
Sesso: Maschile


Torna a Applicazioni

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 10 ospiti