Problema scanner Epson perfection V350 Photo.

Riconoscimento, installazione e configurazione delle periferiche.

Problema scanner Epson perfection V350 Photo.

Messaggioda esimplex » sabato 11 maggio 2019, 19:42

Buonasera a tutti, lo scanner Epson perfection V350 Photo che uso funziona, il problema è fa la ricerca del dispositivo per 2 minuti prima di essere pronto. E' normale o si può fare qualcosa per ridurre questo ritardo?
Grazie.
esimplex
Prode Principiante
 
Messaggi: 21
Iscrizione: febbraio 2013
Località: Roma
Desktop: Unity
Distribuzione: Ubuntu 19.04 64bit
Sesso: Maschile

Re: Problema scanner Epson perfection V350 Photo.

Messaggioda Vir1966 » sabato 11 maggio 2019, 19:56

Quale applicazione usi per lo scanner?
Vir1966
Scoppiettante Seguace
Scoppiettante Seguace
 
Messaggi: 511
Iscrizione: novembre 2015
Desktop: Xfce-Mate
Distribuzione: Xubuntu 16.04_32--LinuxMint 19.1_64
Sesso: Maschile

Re: Problema scanner Epson perfection V350 Photo.

Messaggioda esimplex » sabato 11 maggio 2019, 19:59

Hai ragione l'ho omessa, uso Xsane ma ho lo stesso ritardo con Simple Scan
esimplex
Prode Principiante
 
Messaggi: 21
Iscrizione: febbraio 2013
Località: Roma
Desktop: Unity
Distribuzione: Ubuntu 19.04 64bit
Sesso: Maschile

Re: Problema scanner Epson perfection V350 Photo.

Messaggioda Stealth » sabato 11 maggio 2019, 20:16

Non sono un esperto e non ho quello scanner, quindi probabilmente non saprò aiutarti. Fatta la premessa, se come immagino è uno scanner usb, hai provato a cambiare porta? E i driver come li hai installati, hai già visto questa guida?
ciao
Avatar utente
Stealth
Tenace Tecnocrate
Tenace Tecnocrate
 
Messaggi: 15986
Iscrizione: gennaio 2006
Desktop: Gnome
Distribuzione: Ubuntu 18.04 LTS

Re: Problema scanner Epson perfection V350 Photo.

Messaggioda esimplex » sabato 11 maggio 2019, 21:15

Ho cambiato porta e seguito quella guida precedentemente per l'installazione, ma il risultato è rimasto uguale.
esimplex
Prode Principiante
 
Messaggi: 21
Iscrizione: febbraio 2013
Località: Roma
Desktop: Unity
Distribuzione: Ubuntu 19.04 64bit
Sesso: Maschile

Re: Problema scanner Epson perfection V350 Photo.

Messaggioda magozurlinux » domenica 12 maggio 2019, 17:15

Salve, da terminale postami questi comandi:

Codice: Seleziona tutto
sudo scanimage -L


Codice: Seleziona tutto
sudo sane-find-scanner
Xubuntu 18.04 LTS amd64 :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20899
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64

Re: Problema scanner Epson perfection V350 Photo.

Messaggioda esimplex » lunedì 13 maggio 2019, 18:21

mauro@U-Mac:~$ sudo scanimage -L
device `epkowa:usb:001:003' is a Epson (unknown model) flatbed scanner
device `epkowa:interpreter:001:003' is a Epson (unknown model) flatbed scanner


mauro@U-Mac:~$ sudo sane-find-scanner

# sane-find-scanner will now attempt to detect your scanner. If the
# result is different from what you expected, first make sure your
# scanner is powered up and properly connected to your computer.

# No SCSI scanners found. If you expected something different, make sure that
# you have loaded a kernel SCSI driver for your SCSI adapter.

could not fetch string descriptor: Pipe error
could not fetch string descriptor: Pipe error
found USB scanner (vendor=0x04b8 [EPSON], product=0x012f [EPSON Scanner]) at libusb:001:003
# Your USB scanner was (probably) detected. It may or may not be supported by
# SANE. Try scanimage -L and read the backend's manpage.

# Not checking for parallel port scanners.

# Most Scanners connected to the parallel port or other proprietary ports
# can't be detected by this program.


Fatto
esimplex
Prode Principiante
 
Messaggi: 21
Iscrizione: febbraio 2013
Località: Roma
Desktop: Unity
Distribuzione: Ubuntu 19.04 64bit
Sesso: Maschile

Re: Problema scanner Epson perfection V350 Photo.

Messaggioda magozurlinux » lunedì 13 maggio 2019, 18:47

Da terminale postami questi comandi:

Codice: Seleziona tutto
cat /etc/sane.d/dll.conf


Codice: Seleziona tutto
cat /lib/udev/rules.d/60-libsane1.rules


Codice: Seleziona tutto
dpkg -l | grep sane


Codice: Seleziona tutto
groups
Xubuntu 18.04 LTS amd64 :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20899
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64

Re: Problema scanner Epson perfection V350 Photo.

Messaggioda esimplex » lunedì 13 maggio 2019, 19:44

Di seguito i risultati:

mauro@U-Mac:~$ cat /etc/sane.d/dll.conf
Codice: Seleziona tutto
# dll.conf - Configuration file for the SANE dynamic backend loader
#
# Backends can also be enabled by configuration snippets under the dll.d/
# directory -- third party backends can drop their configuration file in
# this in this directory, named after the backend.
#
# The next line enables the network backend; comment it out if you don't
# need to use a remote SANE scanner over the network -- see sane-net(5)
# and saned(8) for details.
net
abaton
agfafocus
apple
avision
artec
artec_eplus48u
as6e
bh
canon
canon630u
canon_dr
#canon_pp
cardscan
coolscan
#coolscan2
coolscan3
#dc25
#dc210
#dc240
dell1600n_net
dmc
epjitsu
epkowa
#epson
epson2
epsonds
fujitsu
#gphoto2
genesys
gt68xx
hp
hp3900
hpsj5s
hp3500
hp4200
hp5400
hp5590
hpljm1005
hs2p
ibm
kodak
kodakaio
kvs1025
kvs20xx
leo
lexmark
ma1509
magicolor
matsushita
microtek
microtek2
mustek
#mustek_pp
mustek_usb
mustek_usb2
nec
niash
#p5
pie
pint
pixma
plustek
#plustek_pp
#pnm
qcam
ricoh
rts8891
s9036
sceptre
sharp
sm3600
sm3840
snapscan
sp15c
#st400
#stv680
tamarack
teco1
teco2
teco3
#test
u12
umax
#umax_pp
umax1220u
v4l
xerox_mfp
smfp


mauro@U-Mac:~$ cat /lib/udev/rules.d/60-libsane1.rules
Codice: Seleziona tutto
cat: /lib/udev/rules.d/60-libsane1.rules: File o directory non esistente


mauro@U-Mac:~$ dpkg -l | grep sane
Codice: Seleziona tutto
i  libsane:amd64                              1.0.27-3.2ubuntu1                    amd64        API library for scanners
ii  libsane:i386                               1.0.27-3.2ubuntu1                    i386         API library for scanners
ii  libsane-common                             1.0.27-3.2ubuntu1                    all          API library for scanners -- documentation and support files
ii  libsane-hpaio:amd64                        3.19.1+dfsg0-1                       amd64        HP SANE backend for multi-function peripherals
ii  sane                                       1.0.14-13                            amd64        scanner graphical frontends
ii  sane-utils                                 1.0.27-3.2ubuntu1                    amd64        API library for scanners -- utilities
ii  xsane                                      0.999-6ubuntu1                       amd64        featureful graphical frontend for SANE (Scanner Access Now Easy)
ii  xsane-common                               0.999-6ubuntu1                       all          xsane architecture independent files



mauro@U-Mac:~$ groups
Codice: Seleziona tutto
mauro adm cdrom sudo dip plugdev lpadmin scanner sambashare
esimplex
Prode Principiante
 
Messaggi: 21
Iscrizione: febbraio 2013
Località: Roma
Desktop: Unity
Distribuzione: Ubuntu 19.04 64bit
Sesso: Maschile

Re: Problema scanner Epson perfection V350 Photo.

Messaggioda magozurlinux » martedì 14 maggio 2019, 10:33

esimplex Immagine ha scritto:
mauro@U-Mac:~$ cat /lib/udev/rules.d/60-libsane1.rules

cat: /lib/udev/rules.d/60-libsane1.rules: File o directory non esistente


Hanno ricambiato un'altra volta? :muro:

Da terminale postami questo comando:

Codice: Seleziona tutto
locate libsane | grep .rules
Xubuntu 18.04 LTS amd64 :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20899
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64

Re: Problema scanner Epson perfection V350 Photo.

Messaggioda esimplex » martedì 14 maggio 2019, 12:04

mauro@U-Mac:~$ locate libsane | grep .rules
/etc/udev/rules.d/45-libsane.rules
/usr/lib/udev/rules.d/60-libsane.rules
esimplex
Prode Principiante
 
Messaggi: 21
Iscrizione: febbraio 2013
Località: Roma
Desktop: Unity
Distribuzione: Ubuntu 19.04 64bit
Sesso: Maschile

Re: Problema scanner Epson perfection V350 Photo.

Messaggioda esimplex » martedì 14 maggio 2019, 12:16

Questi sono i contenuti:

/etc/udev/rules.d/45-libsane.rules
Codice: Seleziona tutto
# Epson Perfection V350 Photo
ATTRS{idVendor}=="04b8", ATTRS{idProduct}=="012f", MODE="664", GROUP="mauro"



/usr/lib/udev/rules.d/60-libsane.rules
Codice: Seleziona tutto
# This file was automatically created based on description files (*.desc)
# by sane-desc 3.5 from sane-backends 1.0.27
#
# udev rules file for supported USB and SCSI devices
#
# For the list of supported USB devices see /usr/lib/udev/hwdb.d/20-sane.hwdb
#
# The SCSI device support is very basic and includes only
# scanners that mark themselves as type "scanner" or
# SCSI-scanners from HP and other vendors that are entitled "processor"
# but are treated accordingly.
#
# If your SCSI scanner isn't listed below, you can add it to a new rules
# file under /etc/udev/rules.d/.
#
# If your scanner is supported by some external backend (brother, epkowa,
# hpaio, etc) please ask the author of the backend to provide proper
# device detection support for your OS
#
# If the scanner is supported by sane-backends, please mail the entry to
# the sane-devel mailing list (sane-devel@lists.alioth.debian.org).
#
ACTION!="add", GOTO="libsane_rules_end"

# The following rule will disable USB autosuspend for the device
ENV{DEVTYPE}=="usb_device", ENV{libsane_matched}=="yes", TEST=="power/control", ATTR{power/control}="on"

SUBSYSTEMS=="scsi", GOTO="libsane_scsi_rules_begin"
GOTO="libsane_rules_end"

LABEL="libsane_scsi_rules_begin"
KERNEL!="sg[0-9]*", GOTO="libsane_rules_end"

# Generic: SCSI device type 6 indicates a scanner
ATTRS{type}=="6", ENV{libsane_matched}="yes"

# Some scanners advertise themselves as SCSI device type 3

# Wildcard: for some Epson SCSI scanners
ATTRS{type}=="3", ATTRS{vendor}=="EPSON", ATTRS{model}=="SCANNER*", ENV{libsane_matched}="yes"

# Epson Expression 800 | Epson Expression 800
ATTRS{type}=="3", ATTRS{vendor}=="EPSON", ATTRS{model}=="Expression800", ENV{libsane_matched}="yes"

# Epson Perfection 2450 | Epson GT-9700F | Epson Perfection 2450 PHOTO
ATTRS{type}=="3", ATTRS{vendor}=="EPSON", ATTRS{model}=="GT-9700", ENV{libsane_matched}="yes"

# Epson Perfection 3200 | Epson GT-9800F | Epson Perfection 3200 PHOTO
ATTRS{type}=="3", ATTRS{vendor}=="EPSON", ATTRS{model}=="GT-9800", ENV{libsane_matched}="yes"

# Epson GT-X900 | Epson Perfection V700 Photo | Epson Perfection V750 Photo
ATTRS{type}=="3", ATTRS{vendor}=="EPSON", ATTRS{model}=="GT-X900", ENV{libsane_matched}="yes"

# Epson Perfection 636S | Epson Perfection 1200S | Epson Perfection 1200S
ATTRS{type}=="3", ATTRS{vendor}=="EPSON", ATTRS{model}=="Perfection1200", ENV{libsane_matched}="yes"

# Epson Perfection 636 | Epson Perfection 636S
ATTRS{type}=="3", ATTRS{vendor}=="EPSON", ATTRS{model}=="Perfection636", ENV{libsane_matched}="yes"

# Hewlett-Packard ScanJet 4p
ATTRS{type}=="3", ATTRS{vendor}=="HP", ATTRS{model}=="C1130A", ENV{libsane_matched}="yes"

# Hewlett-Packard ScanJet IIc
ATTRS{type}=="3", ATTRS{vendor}=="HP", ATTRS{model}=="C1750A", ENV{libsane_matched}="yes"

# Hewlett-Packard ScanJet IIp
ATTRS{type}=="3", ATTRS{vendor}=="HP", ATTRS{model}=="C1790A", ENV{libsane_matched}="yes"

# Hewlett-Packard ScanJet IIcx
ATTRS{type}=="3", ATTRS{vendor}=="HP", ATTRS{model}=="C2500A", ENV{libsane_matched}="yes"

# Hewlett-Packard ScanJet 4c
ATTRS{type}=="3", ATTRS{vendor}=="HP", ATTRS{model}=="C2520A", ENV{libsane_matched}="yes"

# Hewlett-Packard ScanJet 5p
ATTRS{type}=="3", ATTRS{vendor}=="HP", ATTRS{model}=="C5110A", ENV{libsane_matched}="yes"

# Hewlett-Packard ScanJet 6200C
ATTRS{type}=="3", ATTRS{vendor}=="HP", ATTRS{model}=="C6270A", ENV{libsane_matched}="yes"

# Hewlett-Packard ScanJet 6300C
ATTRS{type}=="3", ATTRS{vendor}=="HP", ATTRS{model}=="C7670A", ENV{libsane_matched}="yes"


LABEL="libsane_rules_end"
esimplex
Prode Principiante
 
Messaggi: 21
Iscrizione: febbraio 2013
Località: Roma
Desktop: Unity
Distribuzione: Ubuntu 19.04 64bit
Sesso: Maschile

Re: Problema scanner Epson perfection V350 Photo.

Messaggioda magozurlinux » martedì 14 maggio 2019, 17:09

esimplex Immagine ha scritto:Questi sono i contenuti:

/etc/udev/rules.d/45-libsane.rules

# Epson Perfection V350 Photo
ATTRS{idVendor}=="04b8", ATTRS{idProduct}=="012f", MODE="664", GROUP="mauro"


modifica mauro con scanner

connesso ad Internet, da terminale dai questo comando:

Codice: Seleziona tutto
sudo apt install libsane-extras


Da terminale dai questi comandi:

Codice: Seleziona tutto
sudo nano /usr/lib/udev/rules.d/60-libsane.rules


scorri il file fino in fondo; prima di LABEL="libsane_rules_end" aggiungi queste righe:

Codice: Seleziona tutto
# Epson Perfection V350 Photo
ATTRS{idVendor}=="04b8", ATTRS{idProduct}=="012f", ENV{libsane_matched}="yes"


per salvare premi i tasti Ctrl o e poi Invio; per uscire premi i tasti Ctrl x

Codice: Seleziona tutto
sudo service udev restart


prova lo scanner.
Xubuntu 18.04 LTS amd64 :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20899
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64

Re: Problema scanner Epson perfection V350 Photo.

Messaggioda esimplex » martedì 14 maggio 2019, 21:18

Non funziona più lo scanner, ora dopo 10 secondi appare:
Allegati
2.jpg
esimplex
Prode Principiante
 
Messaggi: 21
Iscrizione: febbraio 2013
Località: Roma
Desktop: Unity
Distribuzione: Ubuntu 19.04 64bit
Sesso: Maschile

Re: Problema scanner Epson perfection V350 Photo.

Messaggioda esimplex » martedì 14 maggio 2019, 21:19

Successivamente:
Allegati
Schermata del 2019-05-14 22-04-27.jpg
esimplex
Prode Principiante
 
Messaggi: 21
Iscrizione: febbraio 2013
Località: Roma
Desktop: Unity
Distribuzione: Ubuntu 19.04 64bit
Sesso: Maschile

Re: Problema scanner Epson perfection V350 Photo.

Messaggioda esimplex » martedì 14 maggio 2019, 21:42

/etc/udev/rules.d/45-libsane.rules
# Epson Perfection V350 Photo
ATTRS{idVendor}=="04b8", ATTRS{idProduct}=="012f", MODE="664", GROUP="scanner"



Avevo scritto "Scanner" a posto di "scanner" ora è tornato a funzionare però sempre dopo 2 minuti circa.
esimplex
Prode Principiante
 
Messaggi: 21
Iscrizione: febbraio 2013
Località: Roma
Desktop: Unity
Distribuzione: Ubuntu 19.04 64bit
Sesso: Maschile

Re: Problema scanner Epson perfection V350 Photo.

Messaggioda magozurlinux » mercoledì 15 maggio 2019, 11:09

Da terminale dai questo comando:

Codice: Seleziona tutto
sudo chmod a+w /dev/bus/usb/001/003


da terminale postami questo comando:

Codice: Seleziona tutto
cat /etc/sane.d/epkowa.conf
Xubuntu 18.04 LTS amd64 :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20899
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64

Re: Problema scanner Epson perfection V350 Photo.

Messaggioda esimplex » mercoledì 15 maggio 2019, 11:18

Fatto.

mauro@U-Mac:~$ sudo chmod a+w /dev/bus/usb/001/003
[sudo] password di mauro:


mauro@U-Mac:~$ cat /etc/sane.d/epkowa.conf
Codice: Seleziona tutto
# epkowa.conf -- sample configuration for the EPKOWA SANE backend
# Copyright (C) 2004, 2008, 2009  Olaf Meeuwissen
#
# See sane-epkowa(5), sane-usb(5) and sane-scsi(5) for details.

# Detect all devices supported by the backend.
# If you don't have a SCSI device, you can comment out the "scsi"
# keyword.  Similarly for the other keywords.
#
usb usb 0x04b8 0x012f
#scsi


# For any USB scanner not known to the backend (yet), you may, at your
# own peril(!!), force the backend to recognise and use it via libusb.
# You can do so by the following configuration command:
#
#   usb <USB vendor ID> <USB product ID>
#
# SEIKO EPSON's USB vendor ID is '0x04b8' (without quotes).  In order
# to find the USB product ID, use lsusb(1).
# A sample configuration for the Epson Perfection 1650 (Epson GT-8200),
# which has a product ID of 0x0110, would look as follows:
#
usb 0x04b8 0x012f


# For SCSI devices not detected, you can add an entry like:
#
#   scsi EPSON GT-20000
#
# where the GT-20000 bit corresponds to the SCSI model information as
# shown in the output of dmesg(1) or in the /var/log/kern.log file.


# Network attached devices may be made to work by first installing the
# (non-free) iscan-network-nt package and then adding configuration lines
# as per information below.
#
# For each network attached device, you must add an entry as follows:
#
#   net <IP-address|hostname> [port-number]
#
# Ask your network administrator for the device's IP address or check
# for yourself on the panel (if it has one).  The port-number is very
# optional and defaults to 1865.
# Note that network attached devices are not queried unless configured
# in this file.
#
# Examples:
#
#net 192.16.136.2 1865
#net 10.0.0.1
#net scanner.mydomain.com


# Some backend behaviour can be customized by using the option keyword
# followed by an option name, as shown below.
#
#   option <option-name>
#
# Currently available options:
#
# Makes the automatic document feeder the default document source
#option prefer-adf
esimplex
Prode Principiante
 
Messaggi: 21
Iscrizione: febbraio 2013
Località: Roma
Desktop: Unity
Distribuzione: Ubuntu 19.04 64bit
Sesso: Maschile

Re: Problema scanner Epson perfection V350 Photo.

Messaggioda magozurlinux » mercoledì 15 maggio 2019, 11:35

esimplex Immagine ha scritto:
mauro@U-Mac:~$ cat /etc/sane.d/epkowa.conf

# epkowa.conf -- sample configuration for the EPKOWA SANE backend
# Copyright (C) 2004, 2008, 2009 Olaf Meeuwissen
#
# See sane-epkowa(5), sane-usb(5) and sane-scsi(5) for details.

# Detect all devices supported by the backend.
# If you don't have a SCSI device, you can comment out the "scsi"
# keyword. Similarly for the other keywords.
#
usb usb 0x04b8 0x012f
#scsi

# For any USB scanner not known to the backend (yet), you may, at your
# own peril(!!), force the backend to recognise and use it via libusb.
# You can do so by the following configuration command:
#
# usb <USB vendor ID> <USB product ID>
#
# SEIKO EPSON's USB vendor ID is '0x04b8' (without quotes). In order
# to find the USB product ID, use lsusb(1).
# A sample configuration for the Epson Perfection 1650 (Epson GT-8200),
# which has a product ID of 0x0110, would look as follows:
#
usb 0x04b8 0x012f


# For SCSI devices not detected, you can add an entry like:
#
# scsi EPSON GT-20000
#
# where the GT-20000 bit corresponds to the SCSI model information as
# shown in the output of dmesg(1) or in the /var/log/kern.log file.


# Network attached devices may be made to work by first installing the
# (non-free) iscan-network-nt package and then adding configuration lines
# as per information below.
#
# For each network attached device, you must add an entry as follows:
#
# net <IP-address|hostname> [port-number]
#
# Ask your network administrator for the device's IP address or check
# for yourself on the panel (if it has one). The port-number is very
# optional and defaults to 1865.
# Note that network attached devices are not queried unless configured
# in this file.
#
# Examples:
#
#net 192.16.136.2 1865
#net 10.0.0.1
#net scanner.mydomain.com


# Some backend behaviour can be customized by using the option keyword
# followed by an option name, as shown below.
#
# option <option-name>
#
# Currently available options:
#
# Makes the automatic document feeder the default document source
#option prefer-adf


Da terminale dai questi comandi:

Codice: Seleziona tutto
sudo nano /etc/sane.d/epkowa.conf


scorri il file fino alla riga evidenziata in rosso; metti un # prima del comando:

# usb usb 0x04b8 0x012f

quei parametri sono stati messi 2 volte, basta una volta sola, quello blu è corretto..

premi i tasti Ctrl o e poi Invio per salvare; per uscire premi i tasti Ctrl x

Codice: Seleziona tutto
sudo service udev restart


riavvia il pc.
Xubuntu 18.04 LTS amd64 :ciao:
Avatar utente
magozurlinux
Accecante Asceta
Accecante Asceta
 
Messaggi: 20899
Iscrizione: marzo 2010
Località: Pisa
Desktop: Desktop XfCE
Distribuzione: Xubuntu 18.04 LTS x86_64

Re: Problema scanner Epson perfection V350 Photo.

Messaggioda esimplex » mercoledì 15 maggio 2019, 17:50

Sempre uguale, l'interfaccia di Xsane impiega esattamente 1,40 minuti prima di essere visualizzata.
esimplex
Prode Principiante
 
Messaggi: 21
Iscrizione: febbraio 2013
Località: Roma
Desktop: Unity
Distribuzione: Ubuntu 19.04 64bit
Sesso: Maschile

Successiva

Torna a Driver e periferiche

Chi c’è in linea

Visualizzano questa sezione: 0 utenti registrati e 6 ospiti