[Risolto] Skype non funziona microfono interno

Installazione, configurazione e utilizzo di applicativi multimediali, masterizzazione, acquisizione e codec audio/video, streaming e altro.
damfer
Prode Principiante
Messaggi: 33
Iscrizione: venerdì 11 maggio 2012, 12:30
Desktop: ubuntu
Distribuzione: Ubuntu 20.04.2 LTS

[Risolto] Skype non funziona microfono interno

Messaggio da damfer »

Con sorpresa mi sono accorto che skype non funziona con il microfono interno del notebook :o , usando le cuffie non mi ero accorto del problema in quanto con queste funziona tutto bene. Ho quindi per prima cosa provato ad effettuare una registrazione con "registratore di suoni" e funziona. Ho quindi scandagliato vari forum, tentato mille settaggi in alsa e pulse :cry: , sconfortato dai risultati ho provato anche altre distro addirittura fedora e manjaro :muro: , ma non ho risolto.
Solo alcuni tentativi in alsamixer (abbassare il volume di uno dei canali L+R, disattivando nel contempo la regolazione automatica di skype) ha dato qualche risultato, ma appena regolo il volume del mic o riavvio non funziona più :cry: .
immagino sia un problema di stereo/mono, mi pare strano di essere tra i pochi sfortunati che non riescono a risolvere :( . Qualcuno mi può aiutare?

output di "cat /proc/asound/cards":

Codice: Seleziona tutto

 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xc1320000 irq 129
output di "pacmd list-sources":

Codice: Seleziona tutto

2 source(s) available.
    index: 0
	name: <alsa_output.pci-0000_00_1f.3.analog-stereo.monitor>
	driver: <module-alsa-card.c>
	flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: IDLE
	suspend cause: (none)
	priority: 1030
	volume: front-left: 65536 / 100% / 0,00 dB,   front-right: 65536 / 100% / 0,00 dB
	        balance 0,00
	base volume: 65536 / 100% / 0,00 dB
	volume steps: 65537
	muted: no
	current latency: 0,00 ms
	max rewind: 2 KiB
	sample spec: s16le ch 2 44100 Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 0
	configured latency: 2000,00 ms; range is 0,50 .. 2000,00 ms
	monitor_of: 0
	card: 0 <alsa_card.pci-0000_00_1f.3>
	module: 6
	properties:
		device.description = "Monitor of Audio interno Stereo analogico"
		device.class = "monitor"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xc1320000 irq 129"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "9d70"
		device.product.name = "Sunrise Point-LP HD Audio (B51-80 Laptop)"
		device.form_factor = "internal"
		device.string = "0"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
  * index: 1
	name: <alsa_input.pci-0000_00_1f.3.analog-stereo>
	driver: <module-alsa-card.c>
	flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: SUSPENDED
	suspend cause: IDLE
	priority: 9039
	volume: front-left: 45881 /  70% / -9,29 dB,   front-right: 45881 /  70% / -9,29 dB
	        balance 0,00
	base volume: 6554 /  10% / -60,00 dB
	volume steps: 65537
	muted: no
	current latency: 0,00 ms
	max rewind: 0 KiB
	sample spec: s16le ch 2 44100 Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 1
	configured latency: 0,00 ms; range is 0,50 .. 2000,00 ms
	card: 0 <alsa_card.pci-0000_00_1f.3>
	module: 6
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC236 Analog"
		alsa.id = "ALC236 Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xc1320000 irq 129"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "9d70"
		device.product.name = "Sunrise Point-LP HD Audio (B51-80 Laptop)"
		device.form_factor = "internal"
		device.string = "front:0"
		device.buffering.buffer_size = "352800"
		device.buffering.fragment_size = "176400"
		device.access_mode = "mmap+timer"
		device.profile.name = "analog-stereo"
		device.profile.description = "Stereo analogico"
		device.description = "Audio interno Stereo analogico"
		alsa.mixer_name = "Realtek ALC236"
		alsa.components = "HDA:10ec0236,17aa3829,00100002 HDA:80862809,80860101,00100000"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	ports:
		analog-input-internal-mic: Microfono interno (priority 8900, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-mic: Microfono (priority 8700, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-input-microphone"
	active port: <analog-input-internal-mic>
Ultima modifica di damfer il mercoledì 6 maggio 2020, 20:16, modificato 1 volta in totale.
damfer
Prode Principiante
Messaggi: 33
Iscrizione: venerdì 11 maggio 2012, 12:30
Desktop: ubuntu
Distribuzione: Ubuntu 20.04.2 LTS

Re: Skype non funziona microfono interno

Messaggio da damfer »

penso di aver risolto agendo direttamente sulla configurazione di pulse:

Codice: Seleziona tutto

sudo nano /usr/share/pulseaudio/alsa-mixer/paths/analog-input-internal-mic.conf
impostando i canali interessati completamente su "all-right".
riavviando poi il servizio con:

Codice: Seleziona tutto

pulseaudio -k && pulseaudio --start
A differenza delle soluzioni trovate in rete che tirano in ballo ALSA e Pavucontrol questa sembra semplice, diretta e funzionale. :D
Grande Linux, spesso è un puzzle da risolvere, ma dà grandi soddisfazioni :birra: :ciao:
damfer
Prode Principiante
Messaggi: 33
Iscrizione: venerdì 11 maggio 2012, 12:30
Desktop: ubuntu
Distribuzione: Ubuntu 20.04.2 LTS

Re: [Risolto] Skype non funziona microfono interno

Messaggio da damfer »

Con l'aggiornamento del pacchetto pulseaudio, la configurazione che mi aveva permesso di risolvere si è resettata, ho quindi provato una soluzione diversa. Tramite il comando

Codice: Seleziona tutto

pacmd list-sources
si individua la scheda, nel mio caso: alsa_input.pci-0000_00_1f.3.analog-stereo. Fatto accesso a /etc/pulse/default.pa con:

Codice: Seleziona tutto

sudo nano /etc/pulse/default.pa
È possibile rimappare una sorgente di input stereo in una sorgente mono utilizzando una sorgente virtuale, aggiungendo le seguenti righe (personalizzare con la propria scheda):

Codice: Seleziona tutto

load-module module-remap-source master=alsa_input.pci-0000_00_1f.3.analog-stereo source_name=mono channels=2 channel_map=mono,mono
set-default-source mono
Per ora sembra funzionare, spero sia utile ad altri. :ciao:
damfer
Prode Principiante
Messaggi: 33
Iscrizione: venerdì 11 maggio 2012, 12:30
Desktop: ubuntu
Distribuzione: Ubuntu 20.04.2 LTS

Re: [Risolto] Skype non funziona microfono interno

Messaggio da damfer »

Sul portatile Lenovo B51-80 funziona anche la seguente soluzione:
aggiungere:

Codice: Seleziona tutto

options snd_hda_intel model=inv-dmic
al file /etc/modprobe.d/alsa-base.conf
sacarde
Prode Principiante
Messaggi: 174
Iscrizione: giovedì 31 agosto 2006, 10:02

Re: [Risolto] Skype non funziona microfono interno

Messaggio da sacarde »

si puo' vedere una riga sulla quale e' stato messo "all-right" ? dentro analog-input-internal-mic.conf
Scrivi risposta

Ritorna a “Multimediale”

Chi c’è in linea

Visualizzano questa sezione: 0 utenti iscritti e 4 ospiti