[Risolto] Ho rotto ancora il grub e probabilmente ho anche toccato UEFI

Problemi riscontrati durante l'installazione di Ubuntu, degli aggiornamenti e degli avanzamenti del sistema.
Scrivi risposta
LeonardoMarco
Prode Principiante
Messaggi: 13
Iscrizione: lunedì 2 gennaio 2017, 19:56
Distribuzione: Ubuntu Studio 20.04
Sesso: Maschile

[Risolto] Ho rotto ancora il grub e probabilmente ho anche toccato UEFI

Messaggio da LeonardoMarco » sabato 23 maggio 2020, 14:11

Buongiorno,
Il problema principale è che il grub mi dice "minimal bash" e e non riesco ad accedere a win10, ma solo a Ubuntu.
Ho installato Ubuntu Studio 20.04

Guardando in internet la risoluzione sembrava molto semplice, solo che sia con il boot-repair che con i comandi da terminale non riesco a sistemarlo. Il boot-repair dice "risolto con successo" ma resta il problema.

Avevo la 19.10, sempre di Studio, ma non la usavo perché già quando l'ho installata ho avuto problemi simili e ho chiesto aiuto a mio fratello che ha sistemato, però volevo cercare di risolvere i problemi senza di lui (non è che posso sempre correre da lui).
Avendo avuto problemi ho pensato bene di installare da zero la 20.04 e di non fare l'upgrade. La prima installazione è fallita e ho riprovato, a quel punto il grub ha iniziato a dare problemi.
Mi sono detto "ma vuoi vedere che non è uefi" e ho reinstallato, è andato tutto liscio, ma il grub non partiva.
A quel punto ho provato con boot-repair e da bravo intelligentone ho provato a riparare il grub e poi anche il mbr.

Il mio problema è che tutte le guide che ho tentano non hanno funzionato e sto andando un po' in paranoia perché ogni volta che tocco poi il pc ha problemi.
Tutti i programmi che uso per lavorare ci sono anche per Ubuntu, ai file riesco ad accedere senza problemi, quindi non sono in preda alla disperazione.

Cose che penso possano servire:
Ho visto che esiste una partizione efi, ma il grub è installato nella partizione di Ubuntu (l'ho messo seguendo tutorial che promettevano risoluzioni)
Il disco principale è un nvme e ha 7 partizioni (non so bene come)
Durante la prima installazione avevo il telefono attaccato al pc per ricaricarlo e, quando l'ho staccato, è fallita l'installazione (spero sia solo una coincidenza)

È possibile risolvere senza formattare tutto? :(

Grazie in anticipo e scusatemi per il disturbo
Ultima modifica di LeonardoMarco il mercoledì 27 maggio 2020, 15:18, modificato 1 volta in totale.

Avatar utente
willy54
Rampante Reduce
Rampante Reduce
Messaggi: 5264
Iscrizione: lunedì 18 dicembre 2017, 21:42
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile
Località: Castell'Alfero (AT)
Contatti:

Re: Ho rotto ancora il grub e probabilmente ho anche toccato UEFI

Messaggio da willy54 » sabato 23 maggio 2020, 14:18

Visto che nonsei sicuro di come hai installato occorre prima conoscere un po di dati.
Dalla live, se non si avvia l'installato, vedi se la 2a casella nella App Software e aggiornamenti è spuntata
Nel terminale connesso a internet, non importa come, wifi , cavo, tethering Usb

Codice: Seleziona tutto

sudo apt install inxi
inxi -Fz
sudo parted -l
efibootmgr -v
posta i 3 ultimi comandi.
I risultati del terminale vanno postati tra i tag code che si ottengono con il tasto evidenziato Immagine
Hp Pavilon 15-CS2093nl Win10, UbuntuStudio (provvisorio)
Toshiba Satellite A660 11M Win7, Win10, Ubuntu 18.04 LTS- Kubuntu 18.04 LTS gparted sda inxi -Fz
disattivare Avvio rapido in Windows10

LeonardoMarco
Prode Principiante
Messaggi: 13
Iscrizione: lunedì 2 gennaio 2017, 19:56
Distribuzione: Ubuntu Studio 20.04
Sesso: Maschile

Re: Ho rotto ancora il grub e probabilmente ho anche toccato UEFI

Messaggio da LeonardoMarco » sabato 23 maggio 2020, 14:38

Grazie dell'aiuto!

Allora, inzi -Fz

Codice: Seleziona tutto

System:
  Kernel: 5.4.0-31-lowlatency x86_64 bits: 64 Desktop: Xfce 4.14.2 
  Distro: Ubuntu 20.04 LTS (Focal Fossa) 
Machine:
  Type: Desktop Mobo: ASRock model: X570 Steel Legend serial: <filter> 
  UEFI [Legacy]: American Megatrends v: P1.60 date: 07/18/2019 
CPU:
  Topology: 8-Core model: AMD Ryzen 7 3700X bits: 64 type: MT MCP 
  L2 cache: 4096 KiB 
  Speed: 2138 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 2137 2: 2137 
  3: 2137 4: 4275 5: 2200 6: 2199 7: 2199 8: 2200 9: 2137 10: 4275 11: 2199 
  12: 2199 13: 2200 14: 2200 15: 2137 16: 2137 
Graphics:
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] 
  driver: amdgpu v: kernel 
  Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati 
  unloaded: fbdev,modesetting,radeon,vesa 
  resolution: 1280x720~60Hz, 1920x1080~60Hz 
  OpenGL: renderer: AMD Radeon RX 5600 XT (NAVI10 DRM 3.35.0 
  5.4.0-31-lowlatency LLVM 10.0.0) 
  v: 4.6 Mesa 20.2.0-devel (git-685e79a 2020-05-22 focal-oibaf-ppa) 
Audio:
  Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel 
  Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel 
  Device-3: Focusrite-Novation Focusrite Scarlett 6i6 type: USB 
  driver: snd-usb-audio 
  Sound Server: ALSA v: k5.4.0-31-lowlatency 
Network:
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi 
  IF: wlp9s0 state: up mac: <filter> 
  Device-2: Intel I211 Gigabit Network driver: igb 
  IF: enp11s0 state: down mac: <filter> 
  IF-ID-1: usb0 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:
  Local Storage: total: 2.73 TiB used: 1.08 TiB (39.5%) 
  ID-1: /dev/nvme0n1 vendor: Sabrent model: Rocket 4.0 500GB 
  size: 465.76 GiB 
  ID-2: /dev/sda vendor: Seagate model: ST2000DM008-2FR102 size: 1.82 TiB 
  ID-3: /dev/sdb vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB 
Partition:
  ID-1: / size: 141.72 GiB used: 18.95 GiB (13.4%) fs: ext4 
  dev: /dev/nvme0n1p7 
Sensors:
  System Temperatures: cpu: 43.2 C mobo: N/A gpu: amdgpu temp: 0 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0 
Info:
  Processes: 419 Uptime: 2h 48m Memory: 15.57 GiB used: 3.64 GiB (23.4%) 
  Shell: bash inxi: 3.0.38
sudo parted -l

Codice: Seleziona tutto

Modello: ATA ST2000DM008-2FR1 (scsi)
Disco /dev/sda: 2000GB
Dimensione del settore (logica/fisica): 512B/4096B
Tabella delle partizioni: gpt
Flag del disco: 

Numero  Inizio  Fine    Dimensione  File system  Nome                          Flag
 1      17,4kB  16,8MB  16,8MB                   Microsoft reserved partition  msftres
 2      16,8MB  2000GB  2000GB      ntfs         Basic data partition          msftdata


Modello: ATA Samsung SSD 860 (scsi)
Disco /dev/sdb: 500GB
Dimensione del settore (logica/fisica): 512B/512B
Tabella delle partizioni: gpt
Flag del disco: 

Numero  Inizio  Fine    Dimensione  File system  Nome                          Flag
 1      17,4kB  16,8MB  16,8MB                   Microsoft reserved partition  msftres
 2      16,8MB  500GB   500GB       ntfs         Basic data partition          msftdata


Modello: Sabrent Rocket 4.0 500GB (nvme)
Disco /dev/nvme0n1: 500GB
Dimensione del settore (logica/fisica): 512B/512B
Tabella delle partizioni: msdos
Flag del disco: 

Numero  Inizio  Fine    Dimensione  Tipo      File system  Flag
 1      1049kB  525MB   524MB       primary   ntfs         avvio
 2      526MB   157GB   157GB       extended
 5      526MB   1063MB  537MB       logical   fat32        esp
 6      1064MB  1601MB  537MB       logical   fat32
 7      1602MB  157GB   156GB       logical   ext4
 3      157GB   500GB   342GB       primary   ntfs
 4      500GB   500GB   554MB       primary   ntfs         msftres
efibootmgr -v

Codice: Seleziona tutto

EFI variables are not supported on this system.

Avatar utente
willy54
Rampante Reduce
Rampante Reduce
Messaggi: 5264
Iscrizione: lunedì 18 dicembre 2017, 21:42
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile
Località: Castell'Alfero (AT)
Contatti:

Re: Ho rotto ancora il grub e probabilmente ho anche toccato UEFI

Messaggio da willy54 » sabato 23 maggio 2020, 14:52

Windows installato Uefi Ubuntu installato Legacy/Csm/Mbr = installazione ibrida, avrai sempre dei problemi .
Un disco Gpt altro MsDos e per di più Nvme , due partizioni fat32 senza nessuna etichetta, un vero casino.
Se vuoi posso guidarti a fare una installazione pulità di Ubuntu studio in modalità UEFI , mi rifiuto di intervenire su installazioni pasticciate.
Non che non si possa sistemare ma entro 3 aggiornamenti saresti nuovamente a questo punto, decidi tu quello che vuoi fare.
Unica prova che puoi fare è provare a mettere il flag Esp sulla altra partizione Fat32 levandolo da quella attuale .
E' da reinstallare anche windows se vuoi un sistema stabile.
Hp Pavilon 15-CS2093nl Win10, UbuntuStudio (provvisorio)
Toshiba Satellite A660 11M Win7, Win10, Ubuntu 18.04 LTS- Kubuntu 18.04 LTS gparted sda inxi -Fz
disattivare Avvio rapido in Windows10

Avatar utente
et4beta
Rampante Reduce
Rampante Reduce
Messaggi: 7519
Iscrizione: mercoledì 9 gennaio 2008, 10:15
Desktop: Gnome
Distribuzione: 18.04-20.04-20.10 (NO UEFI)
Località: Ancona

Re: Ho rotto ancora il grub e probabilmente ho anche toccato UEFI

Messaggio da et4beta » sabato 23 maggio 2020, 15:34

In effetti è una modalità "ibrida" con le sue conseguenze, però se Ubuntu si avvia vuol dire che il sistema è compatibile con la modalità legacy e che tu stai avviando dall'SSD M2 NVMe in modalità msdos nel cui MBR hai installato il grub di Ubuntu. Il grub è installato nell'MBR del disco in cui è Ubuntu, non nella partizione, altrimenti Ubuntu non si avvierebbe.
Però se Ubuntu si avvia vuol dire che il disco in priorità di boot nel BIOS del PC è sdc(l'NVMe) ed è ovvio che Windows installato in UEFI non si possa avviare.
Quindi, in attesa di un doveroso riordinamento, puoi provare a mettere in priorità di boot, intervenendo nel setup del BIOS, il disco in cui è installato Win, non so se sia l'HDD Seagate da 2 Gb oppure l'SSD Samsung 860 da 500 Gb, e vedere se riesci ad avviare così Win(solo Win perché Ubuntu da lì non si avvia).
Tieni presente che anche se funzionasse non avrai mai un vero dual boot Win - Ubuntu perché installati in modalità diverse, quindi solo selezionando il disco dal BIOS o dal menu di avvio veloce di esso potrai far avviare uno dei due OS, e non è detto che questa situazione non ti possa dare, come ti è stato detto, problemi futuri, per cui fai pure le prove ma poi sistema il tutto.
Linux User #485103 - Ubuntu User #38220 - Desktop: MoBo Asus X99-A - Intel i7 5820K - RAM G.Skill Ripjaws V DDR4 32 Gb - GPU Asus STRIX Nvidia GTX 970 - Monitor Asus MG278Q - SSD Samsung 970 EVO Plus M.2 PCIe NVMe 500 Gb - SSD Samsung 850 EVO 500 Gb + 3 HDD (2 Seagate 2Tb+ 1 WD 2Tb) - / - Asus TUF Gaming FX705GE - i7 8750H - RAM 16 Gb - / - Asus K55VD i7 3610QM RAM 8Gb.

LeonardoMarco
Prode Principiante
Messaggi: 13
Iscrizione: lunedì 2 gennaio 2017, 19:56
Distribuzione: Ubuntu Studio 20.04
Sesso: Maschile

Re: Ho rotto ancora il grub e probabilmente ho anche toccato UEFI

Messaggio da LeonardoMarco » sabato 23 maggio 2020, 16:21

Beh, sinceramente preferisco un sistema stabile. Penso reinstallerò tutto.
L'ssd e l'hdd possono restare così? Così approfitto dell'hdd per il backup dei file importanti (nell'ssd ho i giochi di steam, epic, ecc.)
Ho la live cd, conviene che mi procuri una chiavetta o va bene il cd?
Mi affido a voi perché ho una paura matta di fare danni

Avatar utente
et4beta
Rampante Reduce
Rampante Reduce
Messaggi: 7519
Iscrizione: mercoledì 9 gennaio 2008, 10:15
Desktop: Gnome
Distribuzione: 18.04-20.04-20.10 (NO UEFI)
Località: Ancona

Re: Ho rotto ancora il grub e probabilmente ho anche toccato UEFI

Messaggio da et4beta » sabato 23 maggio 2020, 19:19

Non è detto che così com'é il sistema sia instabile, però un sistema ibrido è comunque sconsigliabile e, come ho detto, non avrai mai un vero dualboot.
Devi però sapere che in modalità UEFI è fortemente consigliato installare tutti gli OS in un unico disco, cosa invece non necessaria in un sistema legacy(msdos), ma non dico altro perché sono di parte e non apprezzo né tecnicamente né eticamente l'UEFI.
Però tu con 3 dischi fissi potresti trovare interessante anche la modalità MBR, in quanto avresti la massima libertà nell'installare gli OS nei vari dischi, mentre con solo disco il problema non si sarebbe posto.
Comunque, per rispondere alla tua domanda, se intendessi installare Ubuntu in modalità UEFI il tuo CD non va bene in quanto devi preparare il supporto(pendrive o DVD) per installare in UEFI mentre quello che hai è evidentemente predisposto per l'MBR.
Linux User #485103 - Ubuntu User #38220 - Desktop: MoBo Asus X99-A - Intel i7 5820K - RAM G.Skill Ripjaws V DDR4 32 Gb - GPU Asus STRIX Nvidia GTX 970 - Monitor Asus MG278Q - SSD Samsung 970 EVO Plus M.2 PCIe NVMe 500 Gb - SSD Samsung 850 EVO 500 Gb + 3 HDD (2 Seagate 2Tb+ 1 WD 2Tb) - / - Asus TUF Gaming FX705GE - i7 8750H - RAM 16 Gb - / - Asus K55VD i7 3610QM RAM 8Gb.

LeonardoMarco
Prode Principiante
Messaggi: 13
Iscrizione: lunedì 2 gennaio 2017, 19:56
Distribuzione: Ubuntu Studio 20.04
Sesso: Maschile

Re: Ho rotto ancora il grub e probabilmente ho anche toccato UEFI

Messaggio da LeonardoMarco » sabato 23 maggio 2020, 21:11

Riguardo al cd, nel menù di scelta del boot il lettore cd (esterno) compare due volte, una volta come USB e una come UEFI. Però farò una chiavetta, anche perché sarà comunque più veloce.
In realtà il mio piano per il computer prevedeva l'nvme come disco di sistema e per mettere i file che sto lavorando e l'hdd per lo storage dei file che non mi servono (in attesa di potermi permettere un nas), l'ssd viene dal mio vecchio portatile che non sia avviava più, così l'ho formattato e lo uso per mettere i giochi di steam, epic e i file grossi con cui devo lavorare e che sono troppo grandi per l'nvme.
Io vorrei mantenere i sistemi su un unico disco, anche perché non vedo l'utilità di dividerli.
Di UEFI e BIOS ho letto adesso differenze e diatribe, ma non ci ho capito molto, quindi mi affido a quel che consigliate voi. Dovendo anche lavorarci vorrei evitare instabilità del sistema (adesso, al boot di Ubuntu, mi compare un messaggio di errore di un programma di sistema, ma non dice quale).

Avatar utente
et4beta
Rampante Reduce
Rampante Reduce
Messaggi: 7519
Iscrizione: mercoledì 9 gennaio 2008, 10:15
Desktop: Gnome
Distribuzione: 18.04-20.04-20.10 (NO UEFI)
Località: Ancona

Re: Ho rotto ancora il grub e probabilmente ho anche toccato UEFI

Messaggio da et4beta » sabato 23 maggio 2020, 21:58

Io posso darti un parere dal mio punto di vista che però, come ho già detto, è viziato da una scelta da me fatta in base ai miei principi ed alle mie necessità, e lo si può chiaramente vedere nel mio profilo dove preciso "NO UEFI", ma non per partito preso bensì per una scelta nel mio caso, sia di principio sia tecnica, ben motivata, che non sto qui a ribadire perché OT.
Nel tuo caso, con 3 dischi fissi, a mio parere l'UEFI non ti permette una loro gestione completamente indipendente come a te andrebbe di fare, non perché sia impossibile ma la necessità di un unica partizione UEFI in uno degli HD, nel caso di un cedimento di questo renderebbe il PC inutilizzabile. Motivazione non più valida ovviamente se tu avessi un solo HD.
Con il sistema msdos, il sistema più vecchio, dovresti tenerti la limitazione del massimo di 4 partizioni primarie per ogni HD(aggirabile comunque con la creazione di un'estesa con le sue logiche), però avresti la possibilità di installare Win su un disco con nell'MBR di questi il suo bootloader(che avvierebbe solo Win), Ubuntu nell'NVMe con nell'MBR di questi il grub(che potrebbe avviare sia Win sia Ubuntu) e nel 3° HD i dati.
Tu dovresti tenere in priorità di boot nel BIOS l'NVMe così si avvierà il grub nel suo MBR con la possibilità di avviare Win o Ubuntu, se un giorno questo avesse un qualsiasi problema tu potresti mettere nel BIOS in priorità di boot l'SSD di Win ed avviare questo, quindi avresti sempre un OS da poter avviare per usare il PC.
Questo è ciò che penso riguardo al tuo sistema, però ripeto è il mio punto di vista. Nella mia situazione, vedi in firma, con 5 HD come farei a gestire tutti i sistemi indipendenti(vedi profilo) con l'UEFI, che non è stato creato per questo scopo ma per ben altro?
Ora prendi altre info, pensaci e poi decidi.
Linux User #485103 - Ubuntu User #38220 - Desktop: MoBo Asus X99-A - Intel i7 5820K - RAM G.Skill Ripjaws V DDR4 32 Gb - GPU Asus STRIX Nvidia GTX 970 - Monitor Asus MG278Q - SSD Samsung 970 EVO Plus M.2 PCIe NVMe 500 Gb - SSD Samsung 850 EVO 500 Gb + 3 HDD (2 Seagate 2Tb+ 1 WD 2Tb) - / - Asus TUF Gaming FX705GE - i7 8750H - RAM 16 Gb - / - Asus K55VD i7 3610QM RAM 8Gb.

Avatar utente
willy54
Rampante Reduce
Rampante Reduce
Messaggi: 5264
Iscrizione: lunedì 18 dicembre 2017, 21:42
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile
Località: Castell'Alfero (AT)
Contatti:

Re: Ho rotto ancora il grub e probabilmente ho anche toccato UEFI

Messaggio da willy54 » domenica 24 maggio 2020, 0:06

Se vuoi fare una installazione pulita in modalità Uefi, qui
0_InstallazioneUefiDualBoot.odt
(9.81 KiB) Scaricato 4 volte
hai una guida passo passo.
Stampala per averla sottomano durante tutti i passi.
Ovviamente se non riesci a riavviare Windows sul tuo pc per creare le due chiavette per quella di windows dovrai farla su un altro pc che esegua windows la installazione di windows si riattiverà automaticamente.
Quella di ubuntu in modalità uefi la farai da windows dopo che lo hai installato per cambiare il partizionamento puoi utilizzare il media attuale di Ubuntu Studio con cui hai fatto la precedente installazione.
Puoi tranquillamente eseguire la copia dei tuoi file importanti sul disco da 2tb sia di windows che di ubuntu , poi per procedere alla installazione staccherai momentaneamente sia il SSD che il HDD in modo tale da evitare di danneggiare i dati presenti sopra i medesimi.
Se hai dei dubbi chiedi .
Hp Pavilon 15-CS2093nl Win10, UbuntuStudio (provvisorio)
Toshiba Satellite A660 11M Win7, Win10, Ubuntu 18.04 LTS- Kubuntu 18.04 LTS gparted sda inxi -Fz
disattivare Avvio rapido in Windows10

LeonardoMarco
Prode Principiante
Messaggi: 13
Iscrizione: lunedì 2 gennaio 2017, 19:56
Distribuzione: Ubuntu Studio 20.04
Sesso: Maschile

Re: Ho rotto ancora il grub e probabilmente ho anche toccato UEFI

Messaggio da LeonardoMarco » domenica 24 maggio 2020, 13:39

Stavo un attimo ragionando riguardo soprattutto ai programmi che utilizzo e ho notato che, rispetto a quando ho guardato Ubuntu la prima volta anni fa, ci sono un sacco di programmi anche di livello avanzato con cui posso lavorare.
L'unico dubbio che ho sono per i docx e simili (che mi mandano, comunque basterebbe una virtual machine) e per i giochi che funzionano solo su windows (però adesso c'è lutris, devo capire come funziona)

Se facessi un sistema solo con Ubuntu sarebbe fattibile o è un azzardo?
Intanto mi informo sulle virtual machine per vedere se possono fare al caso mio per quelle due cose in croce per cui necessiterei di windows

Avatar utente
willy54
Rampante Reduce
Rampante Reduce
Messaggi: 5264
Iscrizione: lunedì 18 dicembre 2017, 21:42
Desktop: Xorg, Plasma
Distribuzione: Ubuntu, Kubuntu 18.04 x86_64
Sesso: Maschile
Località: Castell'Alfero (AT)
Contatti:

Re: Ho rotto ancora il grub e probabilmente ho anche toccato UEFI

Messaggio da willy54 » domenica 24 maggio 2020, 14:25

Se facessi un sistema solo con Ubuntu sarebbe fattibile o è un azzardo?
Se lo devi utilizzare anche per lavoro, considerando anche quanti in questo di homeworking hanno dovuto reinstallare windows, per me è un azzardo, Word e LOWriter hanno una ottima anche se non completa compatibilità, cosa che non è con i fogli di lavoro di Excell-->Calc dove la compatibilità è pessima, manca totalmente per le formule ed anche la impaginazione da problemi.
Se devi interagire con programmi cad (autocad) non c'è discorso è un azzardo
Giochi nessun emulatore darà mai le prestazioni del SO nativo salvo poi avere problemi di grafica ed eventuali blocchi.
Con le caratteristiche del tuo pc che puo anche essere potenziato non è un grosso problema ma a quel punto mi sembra più ragionevole virtualizzare Ubuntu su Windows piuttosto che il contrario.
Sto da qualche tempo facendo prove sul mio portatile in firma con Optane , la velocità di Ubuntu virtualizzato con Optane attivo è molto simile a quella del SO in dual boot , mentre windows quasi raddoppia la velocità rispetto al dual boot dove Optane per incompatibilità con Linux/x deve essere disattivato.
Ma ovvio che queste sono mie osservazioni in base all'uso che ne faccio io , no giochi , programmazione, cad, liste materiali, video editing.
Hp Pavilon 15-CS2093nl Win10, UbuntuStudio (provvisorio)
Toshiba Satellite A660 11M Win7, Win10, Ubuntu 18.04 LTS- Kubuntu 18.04 LTS gparted sda inxi -Fz
disattivare Avvio rapido in Windows10

LeonardoMarco
Prode Principiante
Messaggi: 13
Iscrizione: lunedì 2 gennaio 2017, 19:56
Distribuzione: Ubuntu Studio 20.04
Sesso: Maschile

Re: Ho rotto ancora il grub e probabilmente ho anche toccato UEFI

Messaggio da LeonardoMarco » lunedì 25 maggio 2020, 9:41

Mi fido di voi, io ci capisco fin là di queste cose.
Quindi potrei, come consigliava et4beta, mettere Ubuntu su nvme e windows su ssd, anche perché avevo quasi riempito la partizione di windows facendo a metà.
Per quanto concerne UEFI o legacy mi sembra di capire che UEFI è quello nuovo da usare, ma legacy è quello che risulterebbe più adatto alla mia situazione (non penso di mettere altri dischi, al massimo clono in dischi più capienti), giusto?

Avatar utente
et4beta
Rampante Reduce
Rampante Reduce
Messaggi: 7519
Iscrizione: mercoledì 9 gennaio 2008, 10:15
Desktop: Gnome
Distribuzione: 18.04-20.04-20.10 (NO UEFI)
Località: Ancona

Re: Ho rotto ancora il grub e probabilmente ho anche toccato UEFI

Messaggio da et4beta » lunedì 25 maggio 2020, 11:47

LeonardoMarco ha scritto:
lunedì 25 maggio 2020, 9:41
Mi fido di voi, io ci capisco fin là di queste cose.
Quindi potrei, come consigliava et4beta, mettere Ubuntu su nvme e windows su ssd, anche perché avevo quasi riempito la partizione di windows facendo a metà.
Per quanto concerne UEFI o legacy mi sembra di capire che UEFI è quello nuovo da usare, ma legacy è quello che risulterebbe più adatto alla mia situazione (non penso di mettere altri dischi, al massimo clono in dischi più capienti), giusto?
Esatto. Sta a te decidere. Avendo 3 dischi, se vuoi tenere ogni OS "a casa propria" e col proprio bootloader nell'MBR del proprio disco con l'avvio come ti ho spiegato, ti conviene installare in legacy(msdos) accettando le presunte "limitazioni" in fatto di numero di primarie(ma mi pare che non sia tua intenzione creare molte partizioni nello stesso disco), se invece preferisci mettere gli OS nello stesso disco è indifferente quale delle due modalità usi.
Con la modalità msdos un domani che volessi provare un altro OS Linux, potresti mettere il bootloader di questi nel 3° disco(HDD) indipendentemente dal disco in cui installi l'OS, senza andare a sovrascrivere quelli degli altri sistemi e scegliere da BIOS quale disco avviare in priorità di boot e quindi da quale OS far "iniziare i giochi".
Più nuovo non sempre vuol dire migliore. C'è sempre il libero arbitrio ..... ragionato.
Linux User #485103 - Ubuntu User #38220 - Desktop: MoBo Asus X99-A - Intel i7 5820K - RAM G.Skill Ripjaws V DDR4 32 Gb - GPU Asus STRIX Nvidia GTX 970 - Monitor Asus MG278Q - SSD Samsung 970 EVO Plus M.2 PCIe NVMe 500 Gb - SSD Samsung 850 EVO 500 Gb + 3 HDD (2 Seagate 2Tb+ 1 WD 2Tb) - / - Asus TUF Gaming FX705GE - i7 8750H - RAM 16 Gb - / - Asus K55VD i7 3610QM RAM 8Gb.

LeonardoMarco
Prode Principiante
Messaggi: 13
Iscrizione: lunedì 2 gennaio 2017, 19:56
Distribuzione: Ubuntu Studio 20.04
Sesso: Maschile

Re: Ho rotto ancora il grub e probabilmente ho anche toccato UEFI

Messaggio da LeonardoMarco » lunedì 25 maggio 2020, 13:24

Quindi dovrei:
- salvare i file importanti su hdd
- staccare hdd per evitare di toccarlo (?)
- installare windows sull'ssd cancellando tutto quello che c'è dentro
- installare Ubuntu sull'nvme cancellando tutto quello che c'è dentro
Poi dovrebbe funzionare tutto, giusto?

I miei dubbi sono:
- poi riesco a leggere i file dentro l'hdd anche se è stato formattato ntfs quando usavo UEFI?
- devo fare qualche impostazione dal bios per evitare rogne?
- avendo già cd win10 e cd Ubuntu posso usare quelli o devo comunque fare la chiavetta?
- devo fare io le partizioni o i SO se le fanno da soli? (intendo root, home, swap, ecc.)
- devo prestare attenzione a qualche cosa in particolare quando installo?

Avatar utente
et4beta
Rampante Reduce
Rampante Reduce
Messaggi: 7519
Iscrizione: mercoledì 9 gennaio 2008, 10:15
Desktop: Gnome
Distribuzione: 18.04-20.04-20.10 (NO UEFI)
Località: Ancona

Re: Ho rotto ancora il grub e probabilmente ho anche toccato UEFI

Messaggio da et4beta » lunedì 25 maggio 2020, 16:10

In un PC con OS installati in UEFI e quindi con partizionamento GPT, avere un disco dati con partizionamento msdos non crea il benché minimo problema, e lo stesso avviene per OS installati in legacy(msdos) se per caso il disco dati fosse in GPT.
I problemi sono limitati all'avvio degli OS che tra la due modalità non sono compatibili, ed un sistema "ibrido" creerebbe comunque dei problemi, oltre ad essere un assurdo tecnico se in HD interni dello stesso PC.
Ho scritto "se nello stesso PC", perché se il PC fosse un portatile con il suo OS nell'HD interno installato in UEFI, ed io volessi avere altro o OS(o più OS) in un HD esterno, potrei benissimo preparare l'esterno in modalità msdos ed installare gli altri OS in questa modalità in esso. Il BIOS del PC deve essere configurato UEFI e Legacy insieme, ed io connettendo l'HD esterno potrei avviare il PC da esso e quindi gli OS in esso contenuti e durante il lavoro andare anche a lavorare nei file e nelle cartelle dell'HD interno, pur essendo questo partizionato GPT.
Così sono infatti i notebook che ho in firma e che nati in modalità UEFI ho inteso mantenere così pur avendo su HD esterno, in modalità legacy, varie versioni di Linux. Le cose nate in un modo se vanno bene mi piace mantenerle tali.

Per rispondere alle tue domande, al primo gruppo rispondo:
Sì i file che vuoi salvare copiali su HDD
Staccare l'HDD durante l'installazione puoi anche farlo, ma non è indispensabile.
Sia l'NVMe sia l'SSD vanno riformattati e "partizionati di nuovo"(*) in msdos. Operazione che puoi fare da live di Ubuntu, basta che tu facci attenzione ad avviare la live in modalità legacy.
Per quanto riguarda l'HDD, che tu hai in GPT e che non influirebbe sull'andamento delle cose, però assurdo in quanto non contenendo né OS né partizioni di avvio, andrebbe meglio in MBR, puoi in seguito con comodo trasformalo in questa modalità.

Al secondo gruppo di domande in parte ho già risposto, per quello che riguarda l'installazione per fare una cosa ordinata ti scrivo sotto come fare.
Preparare le pendrive per Win 10 e per Ubuntu. Win 10 se troverà già pronto un partizionamento legacy si adatterà automaticamente ad esso, Per Ubuntu devi preparare la pendrive avviabile scegliendo(se usi Rufus) in "Schema partizione " l'opzione MBR, e in "Sistema destinazione" l'opzione BIOS(o UEFI CSM).
Questi supporti puoi prepararli fin da ora.
Avvii la live di Ubuntu e in essa l'applicazione Gparted è inclusa di default. Innanzitutto guarda e prendi un appunto di quale lettera Gparted usa per ognuno dei dischi(se sda, o sdb o sdc) e tienilo presente sia al momento della preparazione del partizionamento sia al momento dell'installazione degli OS.
Fai attenzione perché l'interfaccia grafica di Gparted ti mostra sempre come sarà la situazione una volta applicate le modifiche, ma per applicarle devi farle eseguire. Se durante il lavoro ti capitasse di sbagliare qualcosa, non rifare o correggere o altro, esci da Gparted e ricomincia da capo, altrimenti L'applicazione fa eseguire tutto anche gli errori e le correzioni e ci vuole troppo tempo.
Con Gparted nell'SSD che vuoi dedicare a Win, elimini tutte le partizioni ottenendo tutto spazio non allocato, in esso creerai una nuova tabella delle partizioni in msdos con 3 partizioni NTFS(che Ubuntu indicherà come sdx1-sdx2-sdx3(dove x sarà "a" o "b" o "c" a seconda di come le vede Ubuntu) badando bene che l'ultima(la 3ª di queste cioè quella verso dx) sia di 40/45 Gb(servirà in seguito, una volta installato Win) per essere eliminata e andare a costituire lo spazio per l'overprovisioning dell'SSD.
Subito dopo averle fatte creare, elimina le prime due lasciando al loro posto lo spazio non allocato in cui andrai ad installare Win 10 che si creerà le sue 2 partizioni(quella di avvio e quella dell'OS). La 3ª partizione la eliminerai in seguito con comodo.
Nell'SSD M2 NVMe(che è già in modalità MBR) eliminerai ugualmente tutte le partizioni, ma siccome Ubuntu non ha la tendenza "all'obesità" di Win, ti conviene creare, partendo da inizio disco(sinistra). 3 partizioni primarie ext4 da 50 Gb ognuna, dopo di queste una partizione estesa che occupi tutto il resto dello spazio allocato fino a lasciare i soliti 40/45 Gb a fine disco di spazio non allocato per l'overprovisioning. Infine creerai all'interno dell'estesa una logica NTFS che la occupi tutta. Questa sarà una ulteriore partizione dati condivisibile tra Ubuntu e Win.
La ragione della 3 primarie ext4 è perché 50 Gb per Ubuntu sono già tanti ed in più volendo passare ad una nuova versione di Ubuntu, o provare una distro diversa di Linux o altro, avrai delle partizioni dedicate in cui installare l'OS da zero mantenendo quelli che hai finché vuoi, basta che fai attenzione ad installare il loro bootlader nell'MBR dell'HDD oppure farlo installare "embedded" nel bootsector della stessa partizione dell'OS appena installato(in caso al momento chiedi), usando il grub del vecchio Ubuntu per il loro avvio.
Al momento dell'installazione di Ubuntu nell'NVMe fai attenzione a far installare il bootloader nell'MBR del suo stesso disco(NVMe) e che non vada ad installarsi nell'SSD dove c'è il bootloader di Win.
Sono stato un po' "lunghetto", ma spero di essere stato chiaro. Casomai chiedi.
Linux User #485103 - Ubuntu User #38220 - Desktop: MoBo Asus X99-A - Intel i7 5820K - RAM G.Skill Ripjaws V DDR4 32 Gb - GPU Asus STRIX Nvidia GTX 970 - Monitor Asus MG278Q - SSD Samsung 970 EVO Plus M.2 PCIe NVMe 500 Gb - SSD Samsung 850 EVO 500 Gb + 3 HDD (2 Seagate 2Tb+ 1 WD 2Tb) - / - Asus TUF Gaming FX705GE - i7 8750H - RAM 16 Gb - / - Asus K55VD i7 3610QM RAM 8Gb.

LeonardoMarco
Prode Principiante
Messaggi: 13
Iscrizione: lunedì 2 gennaio 2017, 19:56
Distribuzione: Ubuntu Studio 20.04
Sesso: Maschile

Re: Ho rotto ancora il grub e probabilmente ho anche toccato UEFI

Messaggio da LeonardoMarco » mercoledì 27 maggio 2020, 13:42

Ho reinstallato i due SO, Ubuntu su nvme e windows su ssd.
Adesso sembra funzionare tutto, sia il grub che i SO.

Vi posto l'output dei comandi che mi avevate detto all'inizio per chiedervi se ho fatto giusto.

inxi -Fz

Codice: Seleziona tutto

System:
  Kernel: 5.4.0-31-lowlatency x86_64 bits: 64 Desktop: Xfce 4.14.2 
  Distro: Ubuntu 20.04 LTS (Focal Fossa) 
Machine:
  Type: Desktop Mobo: ASRock model: X570 Steel Legend serial: <filter> 
  UEFI [Legacy]: American Megatrends v: P1.60 date: 07/18/2019 
CPU:
  Topology: 8-Core model: AMD Ryzen 7 3700X bits: 64 type: MT MCP 
  L2 cache: 4096 KiB 
  Speed: 2198 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 2200 2: 2199 
  3: 2196 4: 2199 5: 2200 6: 2199 7: 2198 8: 2201 9: 2198 10: 2196 11: 2200 
  12: 2202 13: 2198 14: 2200 15: 2199 16: 2202 
Graphics:
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] 
  driver: amdgpu v: kernel 
  Display: server: X.Org 1.20.8 driver: amdgpu,ati 
  unloaded: fbdev,modesetting,radeon,vesa 
  resolution: 1280x720~60Hz, 1920x1080~60Hz 
  OpenGL: renderer: AMD Radeon RX 5600 XT (NAVI10 DRM 3.35.0 
  5.4.0-31-lowlatency LLVM 9.0.1) 
  v: 4.6 Mesa 20.0.4 
Audio:
  Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel 
  Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel 
  Device-3: Focusrite-Novation Focusrite Scarlett 6i6 type: USB 
  driver: snd-usb-audio 
  Sound Server: ALSA v: k5.4.0-31-lowlatency 
Network:
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi 
  IF: wlp9s0 state: up mac: <filter> 
  Device-2: Intel I211 Gigabit Network driver: igb 
  IF: enp11s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 2.73 TiB used: 1.22 TiB (44.7%) 
  ID-1: /dev/nvme0n1 vendor: Sabrent model: Rocket 4.0 500GB 
  size: 465.76 GiB 
  ID-2: /dev/sda vendor: Seagate model: ST2000DM008-2FR102 size: 1.82 TiB 
  ID-3: /dev/sdb vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB 
Partition:
  ID-1: / size: 254.60 GiB used: 10.32 GiB (4.1%) fs: ext4 
  dev: /dev/nvme0n1p6 
  ID-2: swap-1 size: 59.60 GiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/nvme0n1p5 
Sensors:
  System Temperatures: cpu: 41.4 C mobo: N/A gpu: amdgpu temp: 0 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0 
Info:
  Processes: 438 Uptime: 4m Memory: 15.57 GiB used: 1.39 GiB (9.0%) 
  Shell: bash inxi: 3.0.38 

parted -l

Codice: Seleziona tutto

Modello: ATA ST2000DM008-2FR1 (scsi)
Disco /dev/sda: 2000GB
Dimensione del settore (logica/fisica): 512B/4096B
Tabella delle partizioni: gpt
Flag del disco: 

Numero  Inizio  Fine    Dimensione  File system  Nome                          Flag
 1      17,4kB  16,8MB  16,8MB                   Microsoft reserved partition  msftres
 2      16,8MB  2000GB  2000GB      ntfs         Basic data partition          msftdata


Modello: ATA Samsung SSD 860 (scsi)
Disco /dev/sdb: 500GB
Dimensione del settore (logica/fisica): 512B/512B
Tabella delle partizioni: msdos
Flag del disco: 

Numero  Inizio  Fine   Dimensione  Tipo     File system  Flag
 1      1049kB  525MB  524MB       primary  ntfs         avvio
 2      525MB   448GB  447GB       primary  ntfs
 3      448GB   500GB  52,4GB      primary  ntfs


Modello: Sabrent Rocket 4.0 500GB (nvme)
Disco /dev/nvme0n1: 500GB
Dimensione del settore (logica/fisica): 512B/512B
Tabella delle partizioni: msdos
Flag del disco: 

Numero  Inizio  Fine    Dimensione  Tipo      File system     Flag
 1      1048kB  343GB   343GB       extended                  avvio
 5      1049kB  64,0GB  64,0GB      logical   linux-swap(v1)
 6      64,0GB  343GB   279GB       logical   ext4
 2      343GB   395GB   52,4GB      primary   ext4
 3      395GB   448GB   52,4GB      primary   ext4
 4      448GB   500GB   52,4GB      primary   ntfs

efibootmgr -v

Codice: Seleziona tutto

sudo: efibootmgr: comando non trovato

Per quanto riguarda l'installazione di windows mi sembra di aver seguito quanto spiegato.
Per Ubuntu, facendo "installa affianco a win10" non mi faceva installare su nvme, quindi sono andato su personalizza.
Su personalizza non mi faceva installare perché mancava il punto di mount, quindi ho cercato qualche guida in internet e ho scoperto che va fatta la swap, la / e la /home, ma le ultime due non sono necessarie e io non sapevo bene come dividerle. Ho fatto la swap e l'ho messa a 64GB perché ho in programma di aumentare la ram (mi è successo un paio di volte che il programma di video editing crashasse perché la ram era satura e poi vorrei dare più ram a minecraft moddato quando gioco).
In più non ho fatto la partizione estesa ntfs sull'nvme perché ho già l'hdd e l'ssd per passare file da Ubuntu a windows, mentre non volevo che lo spazio fosse troppo stretto per usare Ubuntu come sistema principale e per quando devo scaricare clip di grandi dimensioni dal cloud.

Per ora non installo nulla, aspetto che mi diciate se ci sono problemi o se va tutto bene.

Grazie mille per l'aiuto :)

Avatar utente
et4beta
Rampante Reduce
Rampante Reduce
Messaggi: 7519
Iscrizione: mercoledì 9 gennaio 2008, 10:15
Desktop: Gnome
Distribuzione: 18.04-20.04-20.10 (NO UEFI)
Località: Ancona

Re: Ho rotto ancora il grub e probabilmente ho anche toccato UEFI

Messaggio da et4beta » mercoledì 27 maggio 2020, 15:06

Se tutto funziona è già buona cosa, non perché avessi dubbi sulla bontà del sistema ma eventualmente qualche incertezza sulla realizzazione delle installazioni, come in effetti, vedi punto di mount, ci sono state.
Ti ho scritto una miniguida(non proprio mini come numero di righe) sulla tipologia di ordinamento del sistema ma in merito alla installazione di Ubuntu c'è già il Wiki che va più che bene. Inoltre sul "punto di mount" i riferimenti sono abbondanti sul forum e non si può sbagliare perché se non lo indichi non vai avanti! Corretto per la swap non più necessaria e per la home separata che è una scelta e non un obbligo.
Riguardo alla estesa, il mio era un consiglio pratico dovuto all'esperienza che mi ha insegnato che molte cose è meglio averle a disposizione che non averle, e così è per lo spazio nel disco, se poi non servono pazienza.
Ora goditi il tuo sistema e sfrutta le numerose possibilità che ti offre.
:birra:
Linux User #485103 - Ubuntu User #38220 - Desktop: MoBo Asus X99-A - Intel i7 5820K - RAM G.Skill Ripjaws V DDR4 32 Gb - GPU Asus STRIX Nvidia GTX 970 - Monitor Asus MG278Q - SSD Samsung 970 EVO Plus M.2 PCIe NVMe 500 Gb - SSD Samsung 850 EVO 500 Gb + 3 HDD (2 Seagate 2Tb+ 1 WD 2Tb) - / - Asus TUF Gaming FX705GE - i7 8750H - RAM 16 Gb - / - Asus K55VD i7 3610QM RAM 8Gb.

LeonardoMarco
Prode Principiante
Messaggi: 13
Iscrizione: lunedì 2 gennaio 2017, 19:56
Distribuzione: Ubuntu Studio 20.04
Sesso: Maschile

Re: Ho rotto ancora il grub e probabilmente ho anche toccato UEFI

Messaggio da LeonardoMarco » mercoledì 27 maggio 2020, 15:18

Meglio lunga e spiegata bene, le cose super corte creano dubbi

Grazie a tutti e due! :birra: :birra: :D

Scrivi risposta

Ritorna a “Installazione e aggiornamento del sistema operativo”

Chi c’è in linea

Visualizzano questa sezione: crineri e 11 ospiti